summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/nedit/nedit-5.3-r1.ebuild10
-rw-r--r--app-editors/nedit/nedit-5.3-r2.ebuild9
-rw-r--r--app-editors/nedit/nedit-5.4_pre20030213.ebuild8
-rw-r--r--app-editors/qe/qe-0.1.1.ebuild15
-rw-r--r--app-editors/ted/ted-2.11.ebuild4
-rw-r--r--app-editors/ted/ted-2.12.ebuild11
-rw-r--r--app-editors/zile/zile-1.7_alpha6.ebuild13
7 files changed, 28 insertions, 42 deletions
diff --git a/app-editors/nedit/nedit-5.3-r1.ebuild b/app-editors/nedit/nedit-5.3-r1.ebuild
index 7be776b2bbaa..598dce66a80a 100644
--- a/app-editors/nedit/nedit-5.3-r1.ebuild
+++ b/app-editors/nedit/nedit-5.3-r1.ebuild
@@ -1,19 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.3-r1.ebuild,v 1.4 2003/02/13 06:57:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.3-r1.ebuild,v 1.5 2003/02/28 23:10:17 vapier Exp $
-S=${WORKDIR}/${P}
MY_PV=${PV/./_}
-DESCRIPTION="NEdit is a multi-purpose Motif-based text editor for the X Window System"
+DESCRIPTION="multi-purpose Motif-based text editor for the X Window System"
SRC_URI="http://www.nedit.org/ftp/v${MY_PV}/${P}-source.tar.gz"
HOMEPAGE="http://nedit.org/"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc "
+KEYWORDS="x86 ppc sparc"
RDEPEND=">=x11-libs/openmotif-2.1.30"
-
DEPEND="${RDEPEND}
dev-util/yacc"
@@ -29,7 +27,7 @@ src_compile() {
make linux || die
}
-src_install () {
+src_install() {
into /usr
dobin source/nedit
exeinto /usr/bin
diff --git a/app-editors/nedit/nedit-5.3-r2.ebuild b/app-editors/nedit/nedit-5.3-r2.ebuild
index 0fdf6ae8d969..f78cafd62e24 100644
--- a/app-editors/nedit/nedit-5.3-r2.ebuild
+++ b/app-editors/nedit/nedit-5.3-r2.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.3-r2.ebuild,v 1.4 2003/02/15 18:21:58 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.3-r2.ebuild,v 1.5 2003/02/28 23:10:17 vapier Exp $
inherit eutils
-S=${WORKDIR}/${P}
MY_PV=${PV/./_}
-DESCRIPTION="NEdit is a multi-purpose text editor for the X Window System"
+DESCRIPTION="multi-purpose text editor for the X Window System"
SRC_URI="http://www.nedit.org/ftp/v${MY_PV}/${P}-source.tar.gz"
HOMEPAGE="http://nedit.org/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc"
+IUSE="spell"
RDEPEND="spell? ( app-text/aspell )"
-
DEPEND="${RDEPEND}
dev-util/yacc
virtual/motif"
@@ -34,7 +33,7 @@ src_compile() {
make CC=${CC} linux || die
}
-src_install () {
+src_install() {
into /usr
dobin source/nedit
exeinto /usr/bin
diff --git a/app-editors/nedit/nedit-5.4_pre20030213.ebuild b/app-editors/nedit/nedit-5.4_pre20030213.ebuild
index 3fb1e6da8678..572f3fcfb21f 100644
--- a/app-editors/nedit/nedit-5.4_pre20030213.ebuild
+++ b/app-editors/nedit/nedit-5.4_pre20030213.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.4_pre20030213.ebuild,v 1.2 2003/02/16 00:14:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.4_pre20030213.ebuild,v 1.3 2003/02/28 23:10:17 vapier Exp $
inherit eutils
S=${WORKDIR}/${PN}
-DESCRIPTION="NEdit is a multi-purpose text editor for the X Window System"
+DESCRIPTION="multi-purpose text editor for the X Window System"
SRC_URI="mirror://gentoo/${P}.tar.gz"
HOMEPAGE="http://nedit.org/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="spell"
RDEPEND="spell? ( app-text/aspell )"
-
DEPEND="${RDEPEND}
dev-util/yacc
virtual/motif"
@@ -33,7 +33,7 @@ src_compile() {
make CC=${CC} linux || die
}
-src_install () {
+src_install() {
into /usr
dobin source/nedit
exeinto /usr/bin
diff --git a/app-editors/qe/qe-0.1.1.ebuild b/app-editors/qe/qe-0.1.1.ebuild
index ac71c92368df..218882aeea09 100644
--- a/app-editors/qe/qe-0.1.1.ebuild
+++ b/app-editors/qe/qe-0.1.1.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qe/qe-0.1.1.ebuild,v 1.2 2003/02/13 06:58:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qe/qe-0.1.1.ebuild,v 1.3 2003/02/28 23:10:32 vapier Exp $
-IUSE=""
-DESCRIPTION="QE is a PE2-like editor program under U*nix with Chinese support"
+DESCRIPTION="PE2-like editor program under U*nix with Chinese support"
HOMEPAGE="http://www.cc.ncu.edu.tw/~center5/product/qe/
- http://members.xoom.com/linux4tw/qe/"
+ http://members.xoom.com/linux4tw/qe/"
SRC_URI="ftp://freebsd.sinica.edu.tw/pub/statue/qe/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-DEPEND="virtual/glibc"
-S=${WORKDIR}/${P}
+DEPEND="virtual/glibc"
src_compile() {
- ./configure --prefix=/usr
+ ./configure --prefix=/usr || die
make all || die
}
-src_install () {
+src_install() {
make prefix=${D}/usr install || die
dodoc AUTHORS ChangeLog README README.big5
}
diff --git a/app-editors/ted/ted-2.11.ebuild b/app-editors/ted/ted-2.11.ebuild
index ca0df92b22ca..9bf729c0b119 100644
--- a/app-editors/ted/ted-2.11.ebuild
+++ b/app-editors/ted/ted-2.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.11.ebuild,v 1.9 2003/02/28 23:11:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.11.ebuild,v 1.10 2003/02/28 23:12:34 vapier Exp $
DESCRIPTION="X-based rich text editor"
HOMEPAGE="http://www.nllgg.nl/Ted"
@@ -27,7 +27,7 @@ src_unpack() {
src_compile() {
for dir in Ted tedPackage appFrame appUtil ind bitmap libreg; do
- cd ${dir}
+ cd ${S}/${dir}
econf --cache-file=../config.cache
done
diff --git a/app-editors/ted/ted-2.12.ebuild b/app-editors/ted/ted-2.12.ebuild
index 025fe8c2660c..e9573c6695fc 100644
--- a/app-editors/ted/ted-2.12.ebuild
+++ b/app-editors/ted/ted-2.12.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.12.ebuild,v 1.2 2003/02/13 06:59:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.12.ebuild,v 1.3 2003/02/28 23:11:40 vapier Exp $
-DESCRIPTION="ted is an X-based rich text editor."
+DESCRIPTION="X-based rich text editor."
HOMEPAGE="http://www.nllgg.nl/Ted"
SRC_URI="ftp://ftp.nluug.nl/pub/editors/ted/${P}.src.tar.gz"
@@ -26,13 +26,9 @@ src_unpack() {
}
src_compile() {
- cd ${S} || die "where are we? `pwd`"
-
for dir in Ted tedPackage appFrame appUtil ind bitmap libreg; do
- (
- cd ${dir}
+ cd ${S}/${dir}
econf --cache-file=../config.cache
- )
done
# The makefile doesn't really allow parallel make, but it does
@@ -63,4 +59,3 @@ src_install() {
rm -rf ${T}
}
-
diff --git a/app-editors/zile/zile-1.7_alpha6.ebuild b/app-editors/zile/zile-1.7_alpha6.ebuild
index f6c20ecea45f..ddab22b4f73b 100644
--- a/app-editors/zile/zile-1.7_alpha6.ebuild
+++ b/app-editors/zile/zile-1.7_alpha6.ebuild
@@ -1,25 +1,21 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-1.7_alpha6.ebuild,v 1.2 2003/02/13 07:02:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-1.7_alpha6.ebuild,v 1.3 2003/02/28 23:14:34 vapier Exp $
-DESCRIPTION="Zile is a tiny emacs clone."
+DESCRIPTION="tiny emacs clone"
HOMEPAGE="http://zile.sourceforge.net/"
SRC_URI="mirror://sourceforge/zile/${P/_alpha/-a}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
-
KEYWORDS="~x86 ~ppc"
RDEPEND=">=sys-libs/ncurses-5.2"
-DEPEND="${RDEPEND}"
S="${WORKDIR}/${P/_alpha/-a}"
src_compile() {
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ econf || die
make || die
}
@@ -38,4 +34,3 @@ src_install() {
dodoc COPYRIGHT CREDITS HISTORY KNOWNBUGS NEWS README* TODO LICENSE
}
-