summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-zope/plone/ChangeLog21
-rw-r--r--net-zope/plone/files/digest-plone-1.01
-rw-r--r--net-zope/plone/files/digest-plone-1.0.11
-rw-r--r--net-zope/plone/files/digest-plone-1.0.1-r11
-rw-r--r--net-zope/plone/plone-1.0.1-r1.ebuild32
-rw-r--r--net-zope/plone/plone-1.0.1.ebuild25
-rw-r--r--net-zope/plone/plone-1.0.ebuild25
7 files changed, 106 insertions, 0 deletions
diff --git a/net-zope/plone/ChangeLog b/net-zope/plone/ChangeLog
new file mode 100644
index 000000000000..b53551bb5d1b
--- /dev/null
+++ b/net-zope/plone/ChangeLog
@@ -0,0 +1,21 @@
+# ChangeLog for net-www/plone
+# Copyright 2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/plone/ChangeLog,v 1.1 2003/03/03 23:07:06 kutsuya Exp $
+
+*plone-1.0.1-r1 (18 Feb 2003)
+
+ 03 Mar 2003; Jason Shoemaker <kutsuya@gentoo.org> : Moving from net-www to
+ net-zope. Removed localizer and translationservice as dependencies.
+
+ 18 Feb 2003; Jason Shoemaker <kutsuya@gentoo.org> : Added a two more
+ dependencies for i18n. Since i18n folder isn't a product, leaving it in the
+ template zproduct folder.
+
+*plone-1.0.1 (17 Feb 2003)
+
+ 17 Feb 2003; Jason Shoemaker <kutsuya@gentoo.org> : Version bump.
+ Changed to mirror:// in SRC_URI.
+
+*plone-1.0 (16 Feb 2003)
+
+ 16 Feb 2003; Jason Shoemaker <kutsuya@gentoo.org> : Initial import.
diff --git a/net-zope/plone/files/digest-plone-1.0 b/net-zope/plone/files/digest-plone-1.0
new file mode 100644
index 000000000000..13f0e1d50385
--- /dev/null
+++ b/net-zope/plone/files/digest-plone-1.0
@@ -0,0 +1 @@
+MD5 55020c22c92d1c8ef72198442133e76b CMFPlone1.0.tar.gz 1232566
diff --git a/net-zope/plone/files/digest-plone-1.0.1 b/net-zope/plone/files/digest-plone-1.0.1
new file mode 100644
index 000000000000..e9043fb05a9b
--- /dev/null
+++ b/net-zope/plone/files/digest-plone-1.0.1
@@ -0,0 +1 @@
+MD5 720b293a485707386459f13bed3d32bb CMFPlone1.0.1.tar.gz 1185141
diff --git a/net-zope/plone/files/digest-plone-1.0.1-r1 b/net-zope/plone/files/digest-plone-1.0.1-r1
new file mode 100644
index 000000000000..e9043fb05a9b
--- /dev/null
+++ b/net-zope/plone/files/digest-plone-1.0.1-r1
@@ -0,0 +1 @@
+MD5 720b293a485707386459f13bed3d32bb CMFPlone1.0.1.tar.gz 1185141
diff --git a/net-zope/plone/plone-1.0.1-r1.ebuild b/net-zope/plone/plone-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..6185cfeb3285
--- /dev/null
+++ b/net-zope/plone/plone-1.0.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public Form License v2
+# $Header $
+
+inherit zproduct
+
+DESCRIPTION="A Zope Content Management System, based on Zope CMF."
+HOMEPAGE="http://plone.org"
+SRC_URI="mirror://sourceforge/plone/CMFPlone${PV}.tar.gz"
+S="${WORKDIR}/CMFPlone-${PV}"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+RDEPEND="=net-zope/cmf-1.3*
+ >=net-zope/formulator-1.2.0
+ ${RDEPEND}"
+
+ZPROD_LIST="CMFPlone DCWorkflow"
+
+src_install()
+{
+ rm -R Formulator/
+ zproduct_src_install all
+}
+
+# Since i18n isn't a product folder, leaving it in $ZP_DIR/$PF.
+
+pkg_postinst()
+{
+ zproduct_pkg_postinst
+ einfo "---> NOTE: i18n folder location: ${ZP_DIR}/${PF}"
+}
+
diff --git a/net-zope/plone/plone-1.0.1.ebuild b/net-zope/plone/plone-1.0.1.ebuild
new file mode 100644
index 000000000000..57b5ae7916c6
--- /dev/null
+++ b/net-zope/plone/plone-1.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public Form License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/plone/plone-1.0.1.ebuild,v 1.1 2003/03/03 23:07:06 kutsuya Exp $
+
+inherit zproduct
+
+DESCRIPTION="A Zope Content Management System, based on Zope CMF."
+HOMEPAGE="http://plone.org"
+SRC_URI="mirror://sourceforge/plone/CMFPlone${PV}.tar.gz"
+S="${WORKDIR}/CMFPlone-${PV}"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+RDEPEND="=net-zope/cmf-1.3*
+ >=net-zope/formulator-1.2.0
+ ${RDEPEND}"
+
+ZPROD_LIST="CMFPlone DCWorkflow"
+
+src_install()
+{
+ rm -R Formulator/
+ zproduct_src_install all
+}
+
+
diff --git a/net-zope/plone/plone-1.0.ebuild b/net-zope/plone/plone-1.0.ebuild
new file mode 100644
index 000000000000..887f6130a164
--- /dev/null
+++ b/net-zope/plone/plone-1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public Form License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/plone/plone-1.0.ebuild,v 1.1 2003/03/03 23:07:06 kutsuya Exp $
+
+inherit zproduct
+
+DESCRIPTION="A Zope Content Management System, based on Zope CMF."
+HOMEPAGE="http://plone.org"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/plone/CMFPlone${PV}.tar.gz"
+S="${WORKDIR}/CMFPlone-${PV}"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+RDEPEND="=net-zope/cmf-1.3*
+ >=net-zope/formulator-1.2.0
+ ${RDEPEND}"
+
+ZPROD_LIST="CMFPlone DCWorkflow"
+
+src_install()
+{
+ rm -R Formulator/
+ zproduct_src_install all
+}
+
+