summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/jed/ChangeLog6
-rw-r--r--app-editors/jed/jed-0.99.16-r2.ebuild36
-rw-r--r--app-editors/jed/jed-0.99.18.ebuild38
3 files changed, 38 insertions, 42 deletions
diff --git a/app-editors/jed/ChangeLog b/app-editors/jed/ChangeLog
index 512e65112a50..43952227d6ba 100644
--- a/app-editors/jed/ChangeLog
+++ b/app-editors/jed/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/jed
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/ChangeLog,v 1.36 2007/06/08 06:35:54 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/ChangeLog,v 1.37 2007/06/18 07:10:22 opfer Exp $
+
+ 18 Jun 2007; Christian Faulhammer <opfer@gentoo.org>
+ jed-0.99.16-r2.ebuild, jed-0.99.18.ebuild:
+ added a lot of quotes around variables; fix slang dependency,see bug 141947
08 Jun 2007; Christian Faulhammer <opfer@gentoo.org> metadata.xml:
adding emacs team to herd tag
diff --git a/app-editors/jed/jed-0.99.16-r2.ebuild b/app-editors/jed/jed-0.99.16-r2.ebuild
index fab741127a7f..fe0c069d524f 100644
--- a/app-editors/jed/jed-0.99.16-r2.ebuild
+++ b/app-editors/jed/jed-0.99.16-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.16-r2.ebuild,v 1.20 2007/02/09 21:29:28 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.16-r2.ebuild,v 1.21 2007/06/18 07:10:22 opfer Exp $
inherit eutils
@@ -15,12 +15,8 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE="X gpm truetype"
-RDEPEND="<sys-libs/slang-2
- X? ( || (
- ( x11-libs/libX11 x11-libs/libXext x11-libs/libXrender )
- virtual/x11
- )
- )
+RDEPEND="=sys-libs/slang-1.4*
+ X? ( x11-libs/libX11 x11-libs/libXext x11-libs/libXrender )
gpm? ( sys-libs/gpm )
X? ( truetype? ( || ( x11-libs/libXft virtual/xft )
>=media-libs/freetype-2.0 ) )"
@@ -31,8 +27,8 @@ PROVIDE="virtual/editor"
src_unpack() {
unpack ${A}
- cd ${S}; epatch ${FILESDIR}/${P}-jed.info.patch
- use userland_Darwin && epatch ${FILESDIR}/${P}-darwin.patch
+ cd "${S}"; epatch "${FILESDIR}/${P}-jed.info.patch"
+ use userland_Darwin && "epatch ${FILESDIR}/${P}-darwin.patch"
}
src_compile() {
@@ -50,7 +46,7 @@ src_compile() {
-e 's/#GPMMOUSEO/GPMMOUSEO/' \
-e 's/#OBJGPMMOUSEO/OBJGPMMOUSEO/' \
Makefile
- cd ${S}
+ cd "${S}"
fi
if use X && use truetype ; then
@@ -58,7 +54,7 @@ src_compile() {
sed -i -e 's/#XRENDERFONTLIBS/XRENDERFONTLIBS/' Makefile
sed -i -e 's/^CONFIG_H = config.h/xterm_C_FLAGS = `freetype-config --cflags`\nCONFIG_H = config.h/' Makefile
sed -i -e 's/#define XJED_HAS_XRENDERFONT 0/#define XJED_HAS_XRENDERFONT 1/' jed-feat.h
- cd ${S}
+ cd "${S}"
fi
make clean || die
@@ -73,19 +69,19 @@ src_compile() {
src_install() {
# make install in ${S} claims everything is up-to-date,
# so we manually cd ${S}/src before installing
- cd ${S}/src
- make DESTDIR=${D} install || die
+ cd "${S}/src"
+ make DESTDIR="${D}" install || die
- cd ${S}/doc
+ cd "${S}/doc"
cp README AUTHORS
- cd ${S}
+ cd "${S}"
dodoc INSTALL INSTALL.unx README doc/AUTHORS doc/manual/jed.tex
- cd ${S}/info
+ cd "${S}/info"
rm info.info
- epatch ${FILESDIR}/jed.info.diff
- cd ${S}
+ epatch "${FILESDIR}/jed.info.diff"
+ cd "${S}"
insinto /usr/share/info
doins info/*
@@ -94,9 +90,9 @@ src_install() {
doins lib/jed.conf
# replace IDE mode with EMACS mode
- sed -i -e 's/\(_Jed_Default_Emulation = \).*/\1"emacs";/' ${D}/etc/jed.conf || die "patching jed.conf failed"
+ sed -i -e 's/\(_Jed_Default_Emulation = \).*/\1"emacs";/' "${D}/etc/jed.conf" || die "patching jed.conf failed"
- cd ${D}
+ cd "${D}"
rm -rf usr/share/jed/info
# can't rm usr/share/jed/doc -- used internally by jed/xjed
}
diff --git a/app-editors/jed/jed-0.99.18.ebuild b/app-editors/jed/jed-0.99.18.ebuild
index a59880bb44eb..d51d11bb5550 100644
--- a/app-editors/jed/jed-0.99.18.ebuild
+++ b/app-editors/jed/jed-0.99.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.18.ebuild,v 1.1 2006/08/09 12:47:16 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.18.ebuild,v 1.2 2007/06/18 07:10:22 opfer Exp $
inherit eutils versionator
@@ -15,15 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="X gpm truetype"
-RDEPEND=">=sys-libs/slang-2.0
- X? ( || (
- ( x11-libs/libX11 x11-libs/libXext x11-libs/libXrender )
- virtual/x11
- )
- )
- gpm? ( sys-libs/gpm )
+RDEPEND="=sys-libs/slang-2*
+ X? ( x11-libs/libX11 x11-libs/libXext x11-libs/libXrender )
X? ( truetype? ( || ( x11-libs/libXft virtual/xft )
- >=media-libs/freetype-2.0 ) )"
+ >=media-libs/freetype-2.0 ) )
+ gpm? ( sys-libs/gpm )"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
@@ -33,7 +29,7 @@ src_unpack() {
unpack ${A}
# Gennto slotted slang-2
- cd ${S}
+ cd "${S}"
sed -e 's:-lslang:-lslang-2:g' -i src/Makefile.in
sed -e 's:libslang:libslang-2:g' -i configure
@@ -57,7 +53,7 @@ src_compile() {
-e 's/#GPMMOUSEO/GPMMOUSEO/' \
-e 's/#OBJGPMMOUSEO/OBJGPMMOUSEO/' \
Makefile
- cd ${S}
+ cd "${S}"
fi
if use X && use truetype ; then
@@ -65,7 +61,7 @@ src_compile() {
sed -i -e 's/#XRENDERFONTLIBS/XRENDERFONTLIBS/' Makefile
sed -i -e 's/^CONFIG_H = config.h/xterm_C_FLAGS = `freetype-config --cflags`\nCONFIG_H = config.h/' Makefile
sed -i -e 's/#define XJED_HAS_XRENDERFONT 0/#define XJED_HAS_XRENDERFONT 1/' jed-feat.h
- cd ${S}
+ cd "${S}"
fi
make clean || die
@@ -80,19 +76,19 @@ src_compile() {
src_install() {
# make install in ${S} claims everything is up-to-date,
# so we manually cd ${S}/src before installing
- cd ${S}/src
- make DESTDIR=${D} install || die
+ cd "${S}/src"
+ make DESTDIR="${D}" install || die
- cd ${S}/doc
+ cd "${S}/doc"
cp README AUTHORS
- cd ${S}
+ cd "${S}"
dodoc INSTALL INSTALL.unx README doc/AUTHORS doc/manual/jed.tex
- cd ${S}/info
+ cd "${S}/info"
rm info.info
#epatch ${FILESDIR}/jed.info.diff
- cd ${S}
+ cd "${S}"
insinto /usr/share/info
doins info/*
@@ -101,9 +97,9 @@ src_install() {
doins lib/jed.conf
# replace IDE mode with EMACS mode
- sed -i -e 's/\(_Jed_Default_Emulation = \).*/\1"emacs";/' ${D}/etc/jed.conf || die "patching jed.conf failed"
+ sed -i -e 's/\(_Jed_Default_Emulation = \).*/\1"emacs";/' "${D}/etc/jed.conf" || die "patching jed.conf failed"
- cd ${D}
+ cd "${D}"
rm -rf usr/share/jed/info
# can't rm usr/share/jed/doc -- used internally by jed/xjed
}