summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-block/tw_cli/ChangeLog9
-rw-r--r--sys-block/tw_cli/files/digest-tw_cli-9.4.16
-rw-r--r--sys-block/tw_cli/tw_cli-9.4.0.1.ebuild16
-rw-r--r--sys-block/tw_cli/tw_cli-9.4.1.ebuild77
4 files changed, 100 insertions, 8 deletions
diff --git a/sys-block/tw_cli/ChangeLog b/sys-block/tw_cli/ChangeLog
index 960f3b8e6497..477692d35574 100644
--- a/sys-block/tw_cli/ChangeLog
+++ b/sys-block/tw_cli/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-block/tw_cli
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/tw_cli/ChangeLog,v 1.15 2007/04/01 19:38:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tw_cli/ChangeLog,v 1.16 2007/04/01 19:56:28 robbat2 Exp $
+
+*tw_cli-9.4.1 (01 Apr 2007)
+
+ 01 Apr 2007; Robin H. Johnson <robbat2@gentoo.org> tw_cli-9.4.0.1.ebuild,
+ +tw_cli-9.4.1.ebuild:
+ More cleanup of ebuild style for 9.4.0.1. Version bump to 9.4.1 to support
+ new variants of 9650SE.
*tw_cli-9.4.0.1 (01 Apr 2007)
diff --git a/sys-block/tw_cli/files/digest-tw_cli-9.4.1 b/sys-block/tw_cli/files/digest-tw_cli-9.4.1
new file mode 100644
index 000000000000..7451fc0fd85b
--- /dev/null
+++ b/sys-block/tw_cli/files/digest-tw_cli-9.4.1
@@ -0,0 +1,6 @@
+MD5 a7b9659accceb139137102ac01aa53f4 tw_cli-linux-x86-9.4.1.tgz 798922
+RMD160 6e31644ca455741a59ad45e699135318212bcf94 tw_cli-linux-x86-9.4.1.tgz 798922
+SHA256 23835b6111cd27efad158ca3958ac0c7eca89db1a9904a3adff3fef3ab8f1589 tw_cli-linux-x86-9.4.1.tgz 798922
+MD5 7e022749ab63e7ed0570e1286e77e3ee tw_cli-linux-x86_64-9.4.1.tgz 846300
+RMD160 488559b6e52a7f423fbfe514c9f6fcd7485030df tw_cli-linux-x86_64-9.4.1.tgz 846300
+SHA256 3261be804da230437b27d5b1f8bd365eb0868a5783e1498aeb8ce1ea09f1bd46 tw_cli-linux-x86_64-9.4.1.tgz 846300
diff --git a/sys-block/tw_cli/tw_cli-9.4.0.1.ebuild b/sys-block/tw_cli/tw_cli-9.4.0.1.ebuild
index 537f0fda18d6..044fea461f97 100644
--- a/sys-block/tw_cli/tw_cli-9.4.0.1.ebuild
+++ b/sys-block/tw_cli/tw_cli-9.4.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/tw_cli/tw_cli-9.4.0.1.ebuild,v 1.1 2007/04/01 19:38:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tw_cli/tw_cli-9.4.0.1.ebuild,v 1.2 2007/04/01 19:56:28 robbat2 Exp $
DESCRIPTION="3ware SATA+PATA RAID controller Command Line Interface tool"
HOMEPAGE="http://www.3ware.com/"
@@ -36,12 +36,14 @@ src_unpack() {
}
supportedcards() {
- einfo "This binary supports should support ALL cards, including, but not"
- einfo "limited to the following series:"
- einfo ""
- einfo "PATA: 6xxx, 72xx, 74xx, 78xx, 7000, 7500, 7506"
- einfo "SATA: 8006, 8500, 8506, 9500S, 9550SX, 9590SE"
- einfo " 9550SXU, 9650SE"
+ elog "This binary supports should support ALL cards, including, but not"
+ elog "limited to the following series:"
+ elog ""
+ elog "PATA: 6xxx, 72xx, 74xx, 78xx, 7000, 7500, 7506"
+ elog "SATA: 8006, 8500, 8506, 9500S, 9550SX, 9590SE"
+ elog " 9550SXU, 9650SE"
+ elog ""
+ elog "Release notes for this version are available at http://3ware.com/support/release${PV}_highlights.asp"
}
pkg_setup() {
diff --git a/sys-block/tw_cli/tw_cli-9.4.1.ebuild b/sys-block/tw_cli/tw_cli-9.4.1.ebuild
new file mode 100644
index 000000000000..ee97cdd0bf49
--- /dev/null
+++ b/sys-block/tw_cli/tw_cli-9.4.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tw_cli/tw_cli-9.4.1.ebuild,v 1.1 2007/04/01 19:56:28 robbat2 Exp $
+
+DESCRIPTION="3ware SATA+PATA RAID controller Command Line Interface tool"
+HOMEPAGE="http://www.3ware.com/"
+LICENSE="3ware"
+SLOT="0"
+# binary packages
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+# stripping seems to break this sometimes
+RESTRICT="fetch nostrip nomirror"
+# binary packages
+DEPEND=""
+RDEPEND="virtual/libc"
+MY_P="${PN}-linux-${ARCH/amd64/x86_64}-${PV}"
+# Upstream actually only releases newer versions for new hardware
+# and doesn't release new major versions for old hardware
+# however their backwards compatibility is excellent.
+# I personally test tw_cli on two cards: 6200 (amd64) and 7006-2 (x86)
+# - Robin H. Johnson <robbat2@gentoo.org> - 23 Nov 2006
+#HW_VARIANT="Escalade7000Series" - for versions 9.3.0.*
+HW_VARIANT="Escalade9650SE-Series" # for versions 9.4.0*
+# package has different tarballs for x86 and amd64
+SRC_URI_BASE="http://www.3ware.com/download/${HW_VARIANT}/${PV}"
+SRC_URI_x86="${SRC_URI_BASE}/${PN}-linux-x86-${PV}.tgz"
+SRC_URI_amd64="${SRC_URI_BASE}/${PN}-linux-x86_64-${PV}.tgz"
+SRC_URI="x86? ( ${SRC_URI_x86} )
+ amd64? ( ${SRC_URI_amd64} )"
+LICENSE_URL="http://www.3ware.com/support/windows_agree.asp?path=/download/${HW_VARIANT}/${PV}/${MY_P}.tgz"
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${MY_P}.tgz
+}
+
+supportedcards() {
+ elog "This binary supports should support ALL cards, including, but not"
+ elog "limited to the following series:"
+ elog ""
+ elog "PATA: 6xxx, 72xx, 74xx, 78xx, 7000, 7500, 7506"
+ elog "SATA: 8006, 8500, 8506, 9500S, 9550SX, 9590SE"
+ elog " 9550SXU, 9650SE, 9650SE-{24M8,4LPME}"
+ elog ""
+ elog "Release notes for this version are available at http://3ware.com/support/release${PV}_highlights.asp"
+}
+
+pkg_setup() {
+ supportedcards
+}
+
+pkg_nofetch() {
+ einfo "Please agree to the license at URL"
+ einfo ""
+ einfo "\t${LICENSE_URL}"
+ einfo ""
+ einfo "And then use the following URL to download the"
+ einfo "correct tarball into ${DISTDIR}"
+ einfo ""
+ einfo "x86 - ${SRC_URI_x86}"
+ einfo "amd64 - ${SRC_URI_amd64}"
+ einfo ""
+ supportedcards
+}
+
+src_install() {
+ into /
+ dosbin tw_cli
+ dosbin tw_sched
+ insinto /etc
+ doins tw_sched.cfg
+ into /usr
+ newman tw_cli.8.nroff tw_cli.8
+ newman tw_sched.8.nroff tw_sched.8
+ dohtml *.html
+}