summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/gcc/ChangeLog10
-rw-r--r--sys-devel/gcc/gcc-3.2.2-r1.ebuild7
-rw-r--r--sys-devel/gcc/gcc-3.2.2-r2.ebuild7
-rw-r--r--sys-devel/gcc/gcc-3.2.2-r3.ebuild7
-rw-r--r--sys-devel/gcc/gcc-3.2.2.ebuild7
5 files changed, 30 insertions, 8 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 4907ee9bf5fc..6792d2473e43 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,11 +1,13 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.81 2003/03/24 19:49:06 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.82 2003/03/24 21:31:26 azarah Exp $
24 Mar 2003; Martin Schlemmer <azarah@gentoo.org> :
- Fix latest ebuild to only build static if we are just building the C
- frontend, else some C++ packages fails when trying to link to libstdc++.so,
- bug #18050.
+ - Fix latest ebuild to only build static if we are just building the C
+ frontend, else some C++ packages fails when trying to link to libstdc++.so,
+ bug #18050.
+ - One more effort to try and fix the corner cases where an upgrade borks
+ python, and thus portage, resulting in /etc/ld.so.conf not being updated.
*gcc-3.2.2-r2 (21 Mar 2003)
diff --git a/sys-devel/gcc/gcc-3.2.2-r1.ebuild b/sys-devel/gcc/gcc-3.2.2-r1.ebuild
index 3e3b8b33e62f..1607f25ac75d 100644
--- a/sys-devel/gcc/gcc-3.2.2-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r1.ebuild,v 1.5 2003/03/24 19:49:06 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r1.ebuild,v 1.6 2003/03/24 21:31:26 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -489,6 +489,11 @@ pkg_preinst() {
then
chk_gcc_version
fi
+
+ # Make again sure that the linker "should" be able to locate
+ # libstdc++.so ...
+ export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
+ ${ROOT}/sbin/ldconfig
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-3.2.2-r2.ebuild b/sys-devel/gcc/gcc-3.2.2-r2.ebuild
index f8e5bd79f5fa..96849a6a21dd 100644
--- a/sys-devel/gcc/gcc-3.2.2-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r2.ebuild,v 1.2 2003/03/24 19:49:06 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r2.ebuild,v 1.3 2003/03/24 21:31:26 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -500,6 +500,11 @@ pkg_preinst() {
then
chk_gcc_version
fi
+
+ # Make again sure that the linker "should" be able to locate
+ # libstdc++.so ...
+ export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
+ ${ROOT}/sbin/ldconfig
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-3.2.2-r3.ebuild b/sys-devel/gcc/gcc-3.2.2-r3.ebuild
index 90ce9dc5a225..a3f99649c445 100644
--- a/sys-devel/gcc/gcc-3.2.2-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r3.ebuild,v 1.6 2003/03/24 19:49:06 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r3.ebuild,v 1.7 2003/03/24 21:31:26 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -521,6 +521,11 @@ pkg_preinst() {
then
chk_gcc_version
fi
+
+ # Make again sure that the linker "should" be able to locate
+ # libstdc++.so ...
+ export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
+ ${ROOT}/sbin/ldconfig
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-3.2.2.ebuild b/sys-devel/gcc/gcc-3.2.2.ebuild
index dce442420102..d2ea4230803b 100644
--- a/sys-devel/gcc/gcc-3.2.2.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2.ebuild,v 1.13 2003/03/24 19:49:06 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2.ebuild,v 1.14 2003/03/24 21:31:26 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -502,6 +502,11 @@ pkg_preinst() {
then
chk_gcc_version
fi
+
+ # Make again sure that the linker "should" be able to locate
+ # libstdc++.so ...
+ export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
+ ${ROOT}/sbin/ldconfig
}
pkg_postinst() {