summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-base/xfce-utils/ChangeLog11
-rw-r--r--xfce-base/xfce-utils/files/digest-xfce-utils-4.4.0-r33
-rw-r--r--xfce-base/xfce-utils/files/xfce-utils-4.4.0-xdg_data_dirs.patch18
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.4.0-r3.ebuild41
4 files changed, 72 insertions, 1 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index dda59d1bc2b6..6756b2aa515c 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for xfce-base/xfce-utils
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.87 2007/02/22 04:06:20 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.88 2007/03/02 12:49:26 drac Exp $
+
+*xfce-utils-4.4.0-r3 (02 Mar 2007)
+
+ 02 Mar 2007; Samuli Suominen <drac@gentoo.org>
+ +files/xfce-utils-4.4.0-xdg_data_dirs.patch, +xfce-utils-4.4.0-r3.ebuild:
+ Fix startxfce4 script so it won't lose
+ /usr/share:/usr/local/share:/usr/kde/3.5/share:/usr/share set by /etc/env.d.
+ This allows KDE applications to show in Xfce Menu when kdelibs-3.5.6-r2 is
+ installed. Big thanks to Arttu arse Hanhela for testing.
22 Feb 2007; Joshua Nichols <nichoj@gentoo.org>
xfce-utils-4.4.0-r2.ebuild:
diff --git a/xfce-base/xfce-utils/files/digest-xfce-utils-4.4.0-r3 b/xfce-base/xfce-utils/files/digest-xfce-utils-4.4.0-r3
new file mode 100644
index 000000000000..3032e3b43ebb
--- /dev/null
+++ b/xfce-base/xfce-utils/files/digest-xfce-utils-4.4.0-r3
@@ -0,0 +1,3 @@
+MD5 e90a98cf6de0610170c39a4eae36ad8f xfce-utils-4.4.0.tar.bz2 559900
+RMD160 4e7668bd6827cfd8ed60b6e2a3b60b70cc2f05a2 xfce-utils-4.4.0.tar.bz2 559900
+SHA256 37ab42beaeea0d846920ec805213fcf8987bd74ac1f78153493ae9af3d5b2441 xfce-utils-4.4.0.tar.bz2 559900
diff --git a/xfce-base/xfce-utils/files/xfce-utils-4.4.0-xdg_data_dirs.patch b/xfce-base/xfce-utils/files/xfce-utils-4.4.0-xdg_data_dirs.patch
new file mode 100644
index 000000000000..665989b62505
--- /dev/null
+++ b/xfce-base/xfce-utils/files/xfce-utils-4.4.0-xdg_data_dirs.patch
@@ -0,0 +1,18 @@
+diff -ur xfce-utils-4.4.0.orig/scripts/startxfce4.in xfce-utils-4.4.0/scripts/startxfce4.in
+--- xfce-utils-4.4.0.orig/scripts/startxfce4.in 2007-01-20 19:02:51.000000000 +0200
++++ xfce-utils-4.4.0/scripts/startxfce4.in 2007-03-02 14:33:40.000000000 +0200
+@@ -26,13 +26,7 @@
+ BASEDIR=$XDG_CONFIG_HOME/xfce4
+ fi
+
+-if test x"$XDG_DATA_DIRS" = x""
+-then
+- XDG_DATA_DIRS="/usr/share:/usr/local/share:@datadir@"
+-else
+- XDG_DATA_DIRS="$XDG_DATA_DIRS:@datadir@"
+-fi
+-export XDG_DATA_DIRS
++export XDG_DATA_DIRS="/usr/share:/usr/local/share:$XDG_DATA_DIRS:@datadir@"
+
+ if test x"$DISPLAY" = x""
+ then
diff --git a/xfce-base/xfce-utils/xfce-utils-4.4.0-r3.ebuild b/xfce-base/xfce-utils/xfce-utils-4.4.0-r3.ebuild
new file mode 100644
index 000000000000..06ef564e8fa3
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.4.0-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.4.0-r3.ebuild,v 1.1 2007/03/02 12:49:26 drac Exp $
+
+inherit eutils xfce44
+
+xfce44
+
+DESCRIPTION="Collection of utils"
+HOMEPAGE="http://www.xfce.org/projects/xfce-utils/"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus debug"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libX11
+ >=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ >=xfce-base/libxfcegui4-${XFCE_MASTER_VERSION}
+ >=xfce-base/libxfce4mcs-${XFCE_MASTER_VERSION}
+ >=xfce-base/xfce-mcs-manager-${XFCE_MASTER_VERSION}
+ dbus? ( || ( dev-libs/dbus-glib <sys-apps/dbus-1 ) )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+XFCE_CONFIG="${XFCE_CONFIG} $(use_enable dbus) --enable-gdm --with-vendor-info=Gentoo"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+xfce44_core_package
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-xdg_data_dirs.patch
+}
+
+src_install() {
+ xfce44_src_install
+ insinto /usr/share/xfce4
+ newins ${FILESDIR}/Gentoo Gentoo
+}