summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/ksh/ChangeLog9
-rw-r--r--app-shells/ksh/files/digest-ksh-93.200711059
-rw-r--r--app-shells/ksh/ksh-93.20071105.ebuild70
3 files changed, 86 insertions, 2 deletions
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index 5a2bfb3ba667..18fcd5c25db4 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/ksh
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.32 2007/12/25 15:47:40 phreak Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.33 2008/01/28 21:35:25 armin76 Exp $
+
+*ksh-93.20071105 (28 Jan 2008)
+
+ 28 Jan 2008; Raúl Porcel <armin76@gentoo.org> +ksh-93.20071105.ebuild:
+ Version bump, fix bug #145400
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing taviso from metadata.xml as per #202471. Assigning to
diff --git a/app-shells/ksh/files/digest-ksh-93.20071105 b/app-shells/ksh/files/digest-ksh-93.20071105
new file mode 100644
index 000000000000..595cf41431d7
--- /dev/null
+++ b/app-shells/ksh/files/digest-ksh-93.20071105
@@ -0,0 +1,9 @@
+MD5 312f61269398c0fc854b753a51938230 INIT.2007-11-05.tgz 346223
+RMD160 77e7f0c543edfe5e16dde1948b8c14f77c7525bd INIT.2007-11-05.tgz 346223
+SHA256 d53e0cd6c96a12d279c2994104f636240bd28d73d0ae046557c0d8eed1c00d30 INIT.2007-11-05.tgz 346223
+MD5 8024e4ab068f933bc8fc0f45a9c4fb71 ast-ksh-locale.2007-11-05.tgz 621289
+RMD160 ca766ab613eb07553683785204272df909984307 ast-ksh-locale.2007-11-05.tgz 621289
+SHA256 fdbac41d366f64b37ee3c64555de1b9dd4252ec4c908d4353d7e2ffdfce5a970 ast-ksh-locale.2007-11-05.tgz 621289
+MD5 19c22f3711188c49564589f525ebd5d7 ast-ksh.2007-11-05.tgz 1675958
+RMD160 16b762ab7da6ad974f7773a772c8ab0f736e9734 ast-ksh.2007-11-05.tgz 1675958
+SHA256 36bac8b479a656102746961f1cc22a81dd62e304279130cce7d9a0d8c6734a4d ast-ksh.2007-11-05.tgz 1675958
diff --git a/app-shells/ksh/ksh-93.20071105.ebuild b/app-shells/ksh/ksh-93.20071105.ebuild
new file mode 100644
index 000000000000..9dee0e4367ae
--- /dev/null
+++ b/app-shells/ksh/ksh-93.20071105.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20071105.ebuild,v 1.1 2008/01/28 21:35:25 armin76 Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+RELEASE="2007-11-05"
+LOCALE_RELEASE="2007-11-05"
+INIT_RELEASE="${RELEASE}"
+
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
+HOMEPAGE="http://www.kornshell.com/"
+SRC_URI="nls? ( mirror://gentoo/ast-ksh-locale.${LOCALE_RELEASE}.tgz )
+ mirror://gentoo/INIT.${INIT_RELEASE}.tgz
+ mirror://gentoo/ast-ksh.${RELEASE}.tgz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="!app-shells/pdksh"
+
+S=${WORKDIR}
+
+src_unpack() {
+ # the AT&T build tools look in here for packages.
+ mkdir -p ${S}/lib/package/tgz
+
+ # move the packages into place.
+ cp ${DISTDIR}/ast-ksh.${RELEASE}.tgz ${S}/lib/package/tgz/ || die
+
+ if use nls; then
+ cp ${DISTDIR}/ast-ksh-locale.${LOCALE_RELEASE}.tgz ${S}/lib/package/tgz/ || die
+ fi
+
+ # INIT provides the basic tools to start building.
+ unpack INIT.${INIT_RELEASE}.tgz
+
+ # `package read` will unpack any tarballs put in place.
+ ${S}/bin/package read || die
+}
+
+src_compile() {
+ strip-flags; export CCFLAGS="${CFLAGS}"
+
+ cd ${S}; ./bin/package only make ast-ksh CC="$(tc-getCC)" || die
+
+ # install the optional locale data.
+ if use nls; then
+ cd ${S}; ./bin/package only make ast-ksh-locale CC="$(tc-getCC)"
+ fi
+}
+
+src_install() {
+ exeinto /bin
+
+ doexe ${S}/arch/linux.*/bin/ksh || die
+
+ newman ${S}/arch/linux.*/man/man1/sh.1 ksh.1
+
+ dodoc lib/package/LICENSES/ast
+ dohtml lib/package/ast-ksh.html
+
+ if use nls; then
+ dodir /usr/share
+ mv ${S}/share/lib/locale ${D}/usr/share
+ find ${D}/usr/share/locale -type f -name 'LC_TIME' -exec rm -rf {} \; 2>/dev/null
+ fi
+}