summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/heretic2/ChangeLog5
-rw-r--r--games-action/heretic2/heretic2-1.06c.ebuild30
2 files changed, 21 insertions, 14 deletions
diff --git a/games-action/heretic2/ChangeLog b/games-action/heretic2/ChangeLog
index 78f1966f302b..aa0d2af4bfe6 100644
--- a/games-action/heretic2/ChangeLog
+++ b/games-action/heretic2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/heretic2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/ChangeLog,v 1.3 2008/02/29 18:04:06 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/ChangeLog,v 1.4 2008/05/05 13:40:29 nyhm Exp $
+
+ 05 May 2008; Tristan Heaven <nyhm@gentoo.org> heretic2-1.06c.ebuild:
+ Add ~amd64 keyword
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> heretic2-1.06c.ebuild:
Remove icon extension from desktop entry to match Icon Theme Specification.
diff --git a/games-action/heretic2/heretic2-1.06c.ebuild b/games-action/heretic2/heretic2-1.06c.ebuild
index 9acd02a3f4b8..9aeab205707a 100644
--- a/games-action/heretic2/heretic2-1.06c.ebuild
+++ b/games-action/heretic2/heretic2-1.06c.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/heretic2-1.06c.ebuild,v 1.3 2008/02/29 18:04:06 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/heretic2-1.06c.ebuild,v 1.4 2008/05/05 13:40:29 nyhm Exp $
-inherit eutils games
+inherit eutils multilib games
DESCRIPTION="Third-person classic magical action-adventure game"
HOMEPAGE="http://lokigames.com/products/heretic2/
@@ -13,19 +13,18 @@ SRC_URI="mirror://lokigames/${PN}/${P/%?/b}-unified-x86.run
LICENSE="LOKI-EULA"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RESTRICT="strip"
QA_TEXTRELS="${GAMES_PREFIX_OPT:1}/${PN}/base/*.so"
DEPEND="games-util/loki_patch"
-RDEPEND="virtual/opengl"
+RDEPEND="virtual/opengl
+ amd64? ( app-emulation/emul-linux-x86-xlibs )"
S=${WORKDIR}
GAMES_CHECK_LICENSE="yes"
-dir=${GAMES_PREFIX_OPT}/${PN}
-Ddir=${D}/${dir}
src_unpack() {
cdrom_get_cds bin/x86/glibc-2.1/${PN}
@@ -39,6 +38,8 @@ src_unpack() {
}
src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
cd "${CDROM_ROOT}"
insinto "${dir}"
@@ -49,22 +50,25 @@ src_install() {
games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
newicon icon.xpm ${PN}.xpm
- make_desktop_entry ${PN} "Heretic II" ${PN}
+ make_desktop_entry ${PN} "Heretic II"
- cd "${Ddir}"
+ cd "${D}/${dir}"
ln -s "${CDROM_ROOT}"/*.gz .
unpack ./*.gz
rm -f *.gz
local d
for d in "${S}"/* ; do
- cd "${d}"
- loki_patch patch.dat "${Ddir}" || die "loki_patch ${d} failed"
+ pushd "${d}" > /dev/null
+ loki_patch patch.dat "${D}/${dir}" || die "loki_patch ${d} failed"
+ popd > /dev/null
done
- rmdir "${Ddir}"/gl_drivers
- sed -i '128i set gl_driver "/usr/lib/libGL.so"' \
- "${Ddir}"/base/default.cfg || die "sed failed"
+ rmdir gl_drivers
+ sed -i \
+ "128i set gl_driver \"/usr/$(ABI=x86 get_libdir)/libGL.so\"" \
+ base/default.cfg \
+ || die "sed failed"
prepgamesdirs
}