summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/files/digest-mathomatic-12.7.93
-rw-r--r--sci-mathematics/mathomatic/mathomatic-12.7.9.ebuild39
3 files changed, 49 insertions, 1 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index bfa8079674f0..b6dbc997708d 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.19 2007/07/18 02:13:19 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.20 2007/11/02 02:37:06 cryos Exp $
+
+*mathomatic-12.7.9 (02 Nov 2007)
+
+ 02 Nov 2007; Marcus D. Hanwell <cryos@gentoo.org>
+ +mathomatic-12.7.9.ebuild:
+ Version bump, closes bug 191530.
18 Jul 2007; Marcus D. Hanwell <cryos@gentoo.org>
-mathomatic-12.4.5.ebuild, -mathomatic-12.5.20.ebuild,
diff --git a/sci-mathematics/mathomatic/files/digest-mathomatic-12.7.9 b/sci-mathematics/mathomatic/files/digest-mathomatic-12.7.9
new file mode 100644
index 000000000000..170f301f891b
--- /dev/null
+++ b/sci-mathematics/mathomatic/files/digest-mathomatic-12.7.9
@@ -0,0 +1,3 @@
+MD5 2013de14801bd6d0634ae836ad46b214 mathomatic-12.7.9.tar.bz2 126391
+RMD160 85761e502ee2f346cbf2e549e8e03662cb0e8f99 mathomatic-12.7.9.tar.bz2 126391
+SHA256 5722c149bb258053f7de595c61d7d01c40eea13d0ae921e131a73979653a71aa mathomatic-12.7.9.tar.bz2 126391
diff --git a/sci-mathematics/mathomatic/mathomatic-12.7.9.ebuild b/sci-mathematics/mathomatic/mathomatic-12.7.9.ebuild
new file mode 100644
index 000000000000..d0c6c7442385
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-12.7.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.7.9.ebuild,v 1.1 2007/11/02 02:37:06 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc icc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses
+ icc? ( dev-lang/icc )"
+
+src_compile() {
+ if use icc; then
+ CC="icc" CFLAGS="-O3 -axKWNBP -ipo" LDFLAGS="-O3 -axKWNBP -ipo -limf" emake READLINE=1 || die "emake failed"
+ else
+ emake READLINE=1 || die "emake failed"
+ fi
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic
+ dodoc changes.txt README.txt
+ doman mathomatic.1
+
+ if use doc; then
+ dohtml doc/*
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/*.in
+ fi
+}