summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/tomahawk/ChangeLog7
-rw-r--r--media-sound/tomahawk/tomahawk-0.6.0.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/media-sound/tomahawk/ChangeLog b/media-sound/tomahawk/ChangeLog
index dc704aa88436..35ce67facddd 100644
--- a/media-sound/tomahawk/ChangeLog
+++ b/media-sound/tomahawk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/tomahawk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.20 2013/01/14 21:32:05 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.21 2013/02/14 22:02:14 creffett Exp $
+
+*tomahawk-0.6.0 (14 Feb 2013)
+
+ 14 Feb 2013; Chris Reffett <creffett@gentoo.org> +tomahawk-0.6.0.ebuild:
+ Bump to 0.6.0 wrt bug 452926, credit to Uwe Korn <uwelk@xhochy.com>.
14 Jan 2013; Johannes Huber <johu@gentoo.org> tomahawk-9999.ebuild:
EAPI 5, bump deps.
diff --git a/media-sound/tomahawk/tomahawk-0.6.0.ebuild b/media-sound/tomahawk/tomahawk-0.6.0.ebuild
new file mode 100644
index 000000000000..b6c7fee7fc90
--- /dev/null
+++ b/media-sound/tomahawk/tomahawk-0.6.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/tomahawk-0.6.0.ebuild,v 1.1 2013/02/14 22:02:14 creffett Exp $
+
+EAPI=5
+
+QT_MINIMAL="4.7.0"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="http://download.tomahawk-player.org/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ GIT_ECLASS="git-2"
+ EGIT_REPO_URI="git://github.com/tomahawk-player/tomahawk.git"
+ KEYWORDS=""
+fi
+
+inherit cmake-utils qt4-r2 ${GIT_ECLASS}
+
+DESCRIPTION="Qt playdar social music player"
+HOMEPAGE="http://tomahawk-player.org/"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+IUSE="debug jabber twitter"
+
+DEPEND="
+ app-crypt/qca
+ >=dev-cpp/clucene-2.3.3.4
+ >=dev-libs/boost-1.41
+ >=dev-libs/libattica-0.4.0
+ dev-libs/qjson
+ dev-libs/quazip
+ >=media-libs/liblastfm-1.0.1
+ >=media-libs/libechonest-2.0.1
+ >=media-libs/phonon-4.5.0
+ media-libs/taglib
+ x11-libs/libX11
+ >=x11-libs/qt-core-${QT_MINIMAL}:4
+ >=x11-libs/qt-dbus-${QT_MINIMAL}:4
+ >=x11-libs/qt-gui-${QT_MINIMAL}:4
+ >=x11-libs/qt-sql-${QT_MINIMAL}:4[sqlite]
+ >=x11-libs/qt-webkit-${QT_MINIMAL}:4
+ jabber? ( >=net-libs/jreen-1.1.1 )
+ twitter? ( net-libs/qtweetlib )
+"
+RDEPEND="${DEPEND}
+ app-crypt/qca-ossl
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with jabber Jreen)
+ $(cmake-utils_use_with twitter QTweetLib)
+ )
+
+ if [[ ${PV} != *9999* ]]; then
+ mycmakeargs+=( -DBUILD_RELEASE=ON )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}