summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/fcgi/ChangeLog6
-rw-r--r--dev-libs/fcgi/fcgi-2.4.0-r1.ebuild33
2 files changed, 28 insertions, 11 deletions
diff --git a/dev-libs/fcgi/ChangeLog b/dev-libs/fcgi/ChangeLog
index 31f3f735e493..6ff283a511be 100644
--- a/dev-libs/fcgi/ChangeLog
+++ b/dev-libs/fcgi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/fcgi
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/ChangeLog,v 1.22 2006/10/21 21:33:53 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/ChangeLog,v 1.23 2006/11/04 17:21:45 phreak Exp $
+
+ 04 Nov 2006; Christian Heim <phreak@gentoo.org> fcgi-2.4.0-r1.ebuild:
+ Fixing #153651 (thanks to Tobias Scherbaum for reporting it), cleaning up
+ the ebuild.
21 Oct 2006; Thomas Cort <tcort@gentoo.org> fcgi-2.4.0-r1.ebuild:
Stable on alpha.
diff --git a/dev-libs/fcgi/fcgi-2.4.0-r1.ebuild b/dev-libs/fcgi/fcgi-2.4.0-r1.ebuild
index 12cf04584038..d5b5d971f714 100644
--- a/dev-libs/fcgi/fcgi-2.4.0-r1.ebuild
+++ b/dev-libs/fcgi/fcgi-2.4.0-r1.ebuild
@@ -1,33 +1,46 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/fcgi-2.4.0-r1.ebuild,v 1.3 2006/10/21 21:33:53 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/fcgi-2.4.0-r1.ebuild,v 1.4 2006/11/04 17:21:45 phreak Exp $
-inherit autotools
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit autotools eutils
DESCRIPTION="FastCGI Developer's Kit"
HOMEPAGE="http://www.fastcgi.com/"
SRC_URI="http://www.fastcgi.com/dist/${P}.tar.gz"
+
LICENSE="FastCGI"
SLOT="0"
KEYWORDS="alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
+IUSE="html"
-DEPEND="virtual/libc"
+DEPEND=""
+RDEPEND=""
src_unpack() {
unpack ${A}
+
cd "${S}"
- epatch "${FILESDIR}"/${P}-*.patch
+ epatch "${FILESDIR}/fcgi-2.4.0-Makefile.patch"
+ epatch "${FILESDIR}/fcgi-2.4.0-clientdata-pointer.patch"
+
eautoreconf
}
src_install() {
make DESTDIR="${D}" install LIBRARY_PATH="${D}"/usr/lib || die
+
dodoc LICENSE.TERMS README
- mv doc/*.[13] . && doman *.[13]
- dohtml doc/*
- insinto /usr/share/doc/${P}/examples
+
+ # install the manpages into the right place
+ doman doc/*.[13]
+
+ # Only install the html documentation if USE=html
+ use html && dohtml doc/*/*
+
+ # install examples in the right place
+ insinto /usr/share/doc/${PF}/examples
doins examples/*.c
- insinto /usr/share/doc/${P}/images
- doins images/*
}