summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-radio/xlog/ChangeLog13
-rw-r--r--media-radio/xlog/Manifest6
-rw-r--r--media-radio/xlog/files/digest-xlog-0.9.121
-rw-r--r--media-radio/xlog/xlog-0.9.12.ebuild33
-rw-r--r--media-radio/xlog/xlog-0.9.7.ebuild4
5 files changed, 52 insertions, 5 deletions
diff --git a/media-radio/xlog/ChangeLog b/media-radio/xlog/ChangeLog
index 9e545d2d83a0..dfe186772ad1 100644
--- a/media-radio/xlog/ChangeLog
+++ b/media-radio/xlog/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-radio/xlog
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/ChangeLog,v 1.5 2004/10/01 23:13:15 killsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/ChangeLog,v 1.6 2004/12/09 00:23:25 killsoft Exp $
+
+ 08 Dec 2004; Robb Romans <killsoft@gentoo.org> :
+ Changes for xlog version 0.9.12
+ * Opening/closing the worked before dialog now correctly sets the
+ corresponding optionmenu.
+ * When a new log is created the corresponding filename is now created
+ correctly.
+ * The README has been left out of the help menu and is migrated with the
+ MANUAL. It is now included with the source code only.
+ * Some effort has been done to compile cleanly with mingw. Untested.
+ * Polish translations by Boguslaw Ciastek, SQ5TB. Thanks!
*xlog-0.9.7 (01 Oct 2004)
diff --git a/media-radio/xlog/Manifest b/media-radio/xlog/Manifest
index 68d9c15c2db0..f252c1bc8fc3 100644
--- a/media-radio/xlog/Manifest
+++ b/media-radio/xlog/Manifest
@@ -1,6 +1,8 @@
-MD5 379fc75b6c3f7c5a42cf8a255dfccd80 ChangeLog 1558
+MD5 e6bdc96de0c0274af56760ab552a15d3 xlog-0.9.12.ebuild 742
+MD5 73af3cc6b3d1c3f6729cebace1073fec ChangeLog 2003
MD5 28d0c3bb6c80425620241cff231da8d3 metadata.xml 224
-MD5 477da891d259272250fd9c25ce7e6385 xlog-0.9.7.ebuild 831
+MD5 393bbe62a8ad8d338d7f66c00d9bd923 xlog-0.9.7.ebuild 732
MD5 d8b2f26f31a931bb88e33404e4fe61ed xlog-0.9.6.ebuild 831
MD5 d0afee6be83642f398db70c755d275c8 files/digest-xlog-0.9.7 63
MD5 4a19ffcb3c1423a645b3c135e94fca43 files/digest-xlog-0.9.6 63
+MD5 cdcd0221e0bc5d8be27eb3ba47d55cee files/digest-xlog-0.9.12 63
diff --git a/media-radio/xlog/files/digest-xlog-0.9.12 b/media-radio/xlog/files/digest-xlog-0.9.12
new file mode 100644
index 000000000000..38f145f0ea76
--- /dev/null
+++ b/media-radio/xlog/files/digest-xlog-0.9.12
@@ -0,0 +1 @@
+MD5 1f6701532924cf1cb3595c6fd965a4dc xlog-0.9.12.tar.gz 431918
diff --git a/media-radio/xlog/xlog-0.9.12.ebuild b/media-radio/xlog/xlog-0.9.12.ebuild
new file mode 100644
index 000000000000..7e262960eae0
--- /dev/null
+++ b/media-radio/xlog/xlog-0.9.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/xlog-0.9.12.ebuild,v 1.1 2004/12/09 00:23:25 killsoft Exp $
+
+DESCRIPTION="GTK+ Amateur Radio logging program"
+HOMEPAGE="http://www.qsl.net/pg4i/linux/xlog.html"
+SRC_URI="http://www.qsl.net/pg4i/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="virtual/libc
+ virtual/x11
+ >=gnome-base/libgnomeprint-2.4.0
+ >=x11-libs/gtk+-2.4.0-r1
+ >=media-libs/hamlib-1.2.2"
+
+DEPEND="sys-devel/libtool
+ >=app-doc/doxygen-1.3.5-r1
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ econf --enable-hamlib \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+ make_desktop_entry xlog XLog xlog.xpm HamRadio
+}
diff --git a/media-radio/xlog/xlog-0.9.7.ebuild b/media-radio/xlog/xlog-0.9.7.ebuild
index afafb03cbaa5..3e85e28a1cc7 100644
--- a/media-radio/xlog/xlog-0.9.7.ebuild
+++ b/media-radio/xlog/xlog-0.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/xlog-0.9.7.ebuild,v 1.2 2004/10/01 23:17:37 killsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/xlog-0.9.7.ebuild,v 1.3 2004/12/09 00:23:25 killsoft Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.qsl.net/pg4i/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
IUSE=""
RDEPEND="virtual/libc