summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-18 21:42:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-18 21:42:58 +0000
commit0a832314abf0806c6e17d50bb959e35f3915e55e (patch)
tree7cd2d290e04ff0d9f0aa63b97c9a054517070873 /xfce-extra
parentRun eautoreconf after intltoolize. (diff)
downloadgentoo-2-0a832314abf0806c6e17d50bb959e35f3915e55e.tar.gz
gentoo-2-0a832314abf0806c6e17d50bb959e35f3915e55e.tar.bz2
gentoo-2-0a832314abf0806c6e17d50bb959e35f3915e55e.zip
Missing X-XFCE-Module-Path entry in quicklauncher.desktop wrt #301524.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-quicklauncher-plugin/ChangeLog11
-rw-r--r--xfce-extra/xfce4-quicklauncher-plugin/files/xfce4-quicklauncher-plugin-1.9.4-X-XFCE-Module-Path.patch9
-rw-r--r--xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild37
3 files changed, 55 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-quicklauncher-plugin/ChangeLog b/xfce-extra/xfce4-quicklauncher-plugin/ChangeLog
index 8178f2e042b9..3c9c1d1e0452 100644
--- a/xfce-extra/xfce4-quicklauncher-plugin/ChangeLog
+++ b/xfce-extra/xfce4-quicklauncher-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/xfce4-quicklauncher-plugin
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-quicklauncher-plugin/ChangeLog,v 1.2 2009/10/08 17:41:06 darkside Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-quicklauncher-plugin/ChangeLog,v 1.3 2010/02/18 21:42:57 ssuominen Exp $
+
+*xfce4-quicklauncher-plugin-1.9.4-r1 (18 Feb 2010)
+
+ 18 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-quicklauncher-plugin-1.9.4-r1.ebuild,
+ +files/xfce4-quicklauncher-plugin-1.9.4-X-XFCE-Module-Path.patch:
+ Missing X-XFCE-Module-Path entry in quicklauncher.desktop wrt #301524.
08 Oct 2009; Jeremy Olexa <darkside@gentoo.org>
xfce4-quicklauncher-plugin-1.9.4.ebuild:
diff --git a/xfce-extra/xfce4-quicklauncher-plugin/files/xfce4-quicklauncher-plugin-1.9.4-X-XFCE-Module-Path.patch b/xfce-extra/xfce4-quicklauncher-plugin/files/xfce4-quicklauncher-plugin-1.9.4-X-XFCE-Module-Path.patch
new file mode 100644
index 000000000000..a6bb168539b5
--- /dev/null
+++ b/xfce-extra/xfce4-quicklauncher-plugin/files/xfce4-quicklauncher-plugin-1.9.4-X-XFCE-Module-Path.patch
@@ -0,0 +1,9 @@
+--- panel-plugin/quicklauncher.desktop.in.in
++++ panel-plugin/quicklauncher.desktop.in.in
+@@ -4,4 +4,5 @@
+ _Name=Quicklauncher
+ _Comment=Program with several launchers
+ Icon=gnome-fs-executable
+-X-XFCE-Module=@INTERNAL_PLUGIN_PATH@/libquicklauncher.so
++X-XFCE-Module=libquicklauncher.so
++X-XFCE-Module-Path=@INTERNAL_PLUGIN_PATH@
diff --git a/xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild b/xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild
new file mode 100644
index 000000000000..c38a0094393b
--- /dev/null
+++ b/xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild,v 1.1 2010/02/18 21:42:57 ssuominen Exp $
+
+EAUTORECONF=yes
+EINTLTOOLIZE=yes
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Xfce4 panel quicklauncher plugin"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/1.9/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/xfce4-panel-4.3.20
+ >=xfce-base/libxfcegui4-4.3.20"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog TODO"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+ PATCHES=( "${FILESDIR}/${P}-X-XFCE-Module-Path.patch" )
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^AC_INIT/s/quicklauncher_version()/quicklauncher_version/" \
+ configure.ac || die
+ xfconf_src_prepare
+}