summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-03-15 13:02:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-03-15 13:02:49 +0000
commitc4a08f18ce41c2dd36d47624b4decb1c6fd7d1ac (patch)
treec1c82077c3f7b2dadf761c6d9b57756c740c8c54 /xfce-extra/xfce4-xkb-plugin
parentAdd new version of xfce4-xkb-plugin to p.mask together with >=xfce-base/xfce4... (diff)
downloadgentoo-2-c4a08f18ce41c2dd36d47624b4decb1c6fd7d1ac.tar.gz
gentoo-2-c4a08f18ce41c2dd36d47624b4decb1c6fd7d1ac.tar.bz2
gentoo-2-c4a08f18ce41c2dd36d47624b4decb1c6fd7d1ac.zip
Version bump for >=xfce-base/xfce4-settings-4.11 (git)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-extra/xfce4-xkb-plugin')
-rw-r--r--xfce-extra/xfce4-xkb-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.7.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-xkb-plugin/ChangeLog b/xfce-extra/xfce4-xkb-plugin/ChangeLog
index 9a3c4b87458c..b8199d0c7c6a 100644
--- a/xfce-extra/xfce4-xkb-plugin/ChangeLog
+++ b/xfce-extra/xfce4-xkb-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-xkb-plugin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-xkb-plugin/ChangeLog,v 1.47 2014/03/15 12:54:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-xkb-plugin/ChangeLog,v 1.48 2014/03/15 13:02:49 ssuominen Exp $
+
+*xfce4-xkb-plugin-0.7.0 (15 Mar 2014)
+
+ 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-xkb-plugin-0.7.0.ebuild:
+ Version bump for >=xfce-base/xfce4-settings-4.11 (git)
15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org>
-xfce4-xkb-plugin-0.5.4.3.ebuild, -xfce4-xkb-plugin-0.5.5.ebuild:
diff --git a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.7.0.ebuild b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.7.0.ebuild
new file mode 100644
index 000000000000..cecd540fe766
--- /dev/null
+++ b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.7.0.ebuild,v 1.1 2014/03/15 13:02:49 ssuominen Exp $
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="XKB layout switching panel plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+COMMON_DEPEND=">=gnome-base/librsvg-2.36.2
+ x11-libs/gtk+:2
+ >=x11-libs/libwnck-2.12:1
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5
+ >=xfce-base/garcon-0.1.5
+ >=xfce-base/libxfce4ui-4.11
+ >=xfce-base/libxfce4util-4.11
+ >=xfce-base/xfce4-panel-4.11"
+RDEPEND="${COMMON_DEPEND}
+ >=xfce-base/xfce4-settings-4.11"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog README )
+}