summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-14 10:26:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-14 10:26:24 +0000
commite3eb4f8820d7affcaa7e268d3affac6f23ef1897 (patch)
tree7e964d99b6b876f91bb9440cbb6047ae30a1d13c /xfce-extra/xfce4-battery-plugin
parentVersion bump. (diff)
downloadgentoo-2-e3eb4f8820d7affcaa7e268d3affac6f23ef1897.tar.gz
gentoo-2-e3eb4f8820d7affcaa7e268d3affac6f23ef1897.tar.bz2
gentoo-2-e3eb4f8820d7affcaa7e268d3affac6f23ef1897.zip
Version bump.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-battery-plugin')
-rw-r--r--xfce-extra/xfce4-battery-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.4.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/ChangeLog b/xfce-extra/xfce4-battery-plugin/ChangeLog
index 93af2633af3f..d37fe3d6733d 100644
--- a/xfce-extra/xfce4-battery-plugin/ChangeLog
+++ b/xfce-extra/xfce4-battery-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-battery-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/ChangeLog,v 1.14 2012/05/05 07:11:16 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/ChangeLog,v 1.15 2012/05/14 10:26:24 ssuominen Exp $
+
+*xfce4-battery-plugin-1.0.4 (14 May 2012)
+
+ 14 May 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-battery-plugin-1.0.4.ebuild:
+ Version bump.
05 May 2012; Michał Górny <mgorny@gentoo.org>
xfce4-battery-plugin-1.0.0-r1.ebuild, xfce4-battery-plugin-1.0.1.ebuild,
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.4.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.4.ebuild
new file mode 100644
index 000000000000..86e2fbcd098c
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.4.ebuild,v 1.1 2012/05/14 10:26:24 ssuominen Exp $
+
+EAPI=4
+inherit linux-info xfconf
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="debug kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}