summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-22 18:21:20 +0000
committerChristoph Mende <angelos@gentoo.org>2010-05-22 18:21:20 +0000
commit64922a9f22ab0ae2b372de395038119abfdea848 (patch)
tree1d86a29027d6f86c60d37990d71d5d6b7c9facf9 /xfce-base
parentVersion bump (diff)
downloadgentoo-2-64922a9f22ab0ae2b372de395038119abfdea848.tar.gz
gentoo-2-64922a9f22ab0ae2b372de395038119abfdea848.tar.bz2
gentoo-2-64922a9f22ab0ae2b372de395038119abfdea848.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfwm4/ChangeLog9
-rw-r--r--xfce-base/xfwm4/xfwm4-4.6.2.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/xfce-base/xfwm4/ChangeLog b/xfce-base/xfwm4/ChangeLog
index 9b287b3b4485..5eb0898f1f82 100644
--- a/xfce-base/xfwm4/ChangeLog
+++ b/xfce-base/xfwm4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfwm4
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.140 2009/11/01 23:52:07 angelos Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.141 2010/05/22 18:21:20 angelos Exp $
+
+*xfwm4-4.6.2 (22 May 2010)
+
+ 22 May 2010; Christoph Mende <angelos@gentoo.org> +xfwm4-4.6.2.ebuild:
+ Version bump
01 Nov 2009; Christoph Mende <angelos@gentoo.org> xfwm4-4.6.1.ebuild:
Enable xcomposite by default
diff --git a/xfce-base/xfwm4/xfwm4-4.6.2.ebuild b/xfce-base/xfwm4/xfwm4-4.6.2.ebuild
new file mode 100644
index 000000000000..ef2e10f8d6c8
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.6.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/xfwm4-4.6.2.ebuild,v 1.1 2010/05/22 18:21:20 angelos Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Window manager for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/xfwm4/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.6/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug startup-notification +xcomposite"
+
+RDEPEND=">=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-2.10:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXpm
+ x11-libs/pango
+ >=x11-libs/libwnck-2.12
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/xfconf-4.6
+ startup-notification? ( x11-libs/startup-notification )
+ xcomposite? ( x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xcomposite compositor)
+ $(use_enable debug)"
+ DOCS="AUTHORS ChangeLog COMPOSITOR NEWS README TODO"
+}