summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-03-12 18:14:19 +0000
committerSamuli Suominen <drac@gentoo.org>2008-03-12 18:14:19 +0000
commit0095c0f446261477322647a10d4d7423fa1c1ad4 (patch)
tree110f221d60cc98847b5410e9c7a633547ba9743e /xfce-base
parentRemoving Marien Zwart (marienz, #107204) from metadata.xml. (diff)
downloadgentoo-2-0095c0f446261477322647a10d4d7423fa1c1ad4.tar.gz
gentoo-2-0095c0f446261477322647a10d4d7423fa1c1ad4.tar.bz2
gentoo-2-0095c0f446261477322647a10d4d7423fa1c1ad4.zip
Fix problem with Thunar leaving defuncts by including a fix from upstream bug 2983, thanks to VQuickSilver and tcunha.
(Portage version: 2.1.4.4)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/ChangeLog9
-rw-r--r--xfce-base/thunar/files/thunar-0.9.0-fix-defuncts.patch31
-rw-r--r--xfce-base/thunar/thunar-0.9.0-r2.ebuild89
3 files changed, 128 insertions, 1 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index 60abfe547f8a..ec613d4edf7b 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/thunar
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.47 2008/03/10 01:55:13 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.48 2008/03/12 18:14:18 drac Exp $
+
+*thunar-0.9.0-r2 (12 Mar 2008)
+
+ 12 Mar 2008; Samuli Suominen <drac@gentoo.org>
+ +files/thunar-0.9.0-fix-defuncts.patch, +thunar-0.9.0-r2.ebuild:
+ Fix problem with Thunar leaving defuncts by including a fix from upstream
+ bug 2983, thanks to VQuickSilver and tcunha.
10 Mar 2008; <ricmm@gentoo.org> thunar-0.8.0-r3.ebuild:
Drop to ~mips due to unstable deps
diff --git a/xfce-base/thunar/files/thunar-0.9.0-fix-defuncts.patch b/xfce-base/thunar/files/thunar-0.9.0-fix-defuncts.patch
new file mode 100644
index 000000000000..4353c7490ffe
--- /dev/null
+++ b/xfce-base/thunar/files/thunar-0.9.0-fix-defuncts.patch
@@ -0,0 +1,31 @@
+Index: thunar-vfs/thunar-vfs-exec.c
+===================================================================
+--- thunar-vfs/thunar-vfs-exec.c (revision 26428)
++++ thunar-vfs/thunar-vfs-exec.c (working copy)
+@@ -324,8 +324,10 @@
+ if (startup_data->watch_id != 0)
+ g_source_remove (startup_data->watch_id);
+
+- /* close the PID */
+- g_spawn_close_pid (startup_data->pid);
++ /* make sure we don't leave zombies (see bug #2983 for details) */
++ g_child_watch_add_full (G_PRIORITY_LOW, startup_data->pid,
++ (GChildWatchFunc) g_spawn_close_pid,
++ NULL, NULL);
+
+ /* release the startup data */
+ _thunar_vfs_slice_free (TvsnStartupData, startup_data);
+@@ -513,7 +515,13 @@
+ startup_data->pid = pid;
+ }
+ }
++ else if (G_LIKELY (succeed))
++ {
++ /* make sure we don't leave zombies (see bug #2983 for details) */
++ g_child_watch_add_full (G_PRIORITY_LOW, pid, (GChildWatchFunc) g_spawn_close_pid, NULL, NULL);
+
++ }
++
+ /* release the sn display */
+ if (G_LIKELY (sn_display != NULL))
+ sn_display_unref (sn_display);
diff --git a/xfce-base/thunar/thunar-0.9.0-r2.ebuild b/xfce-base/thunar/thunar-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..bf304c7612f8
--- /dev/null
+++ b/xfce-base/thunar/thunar-0.9.0-r2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.9.0-r2.ebuild,v 1.1 2008/03/12 18:14:18 drac Exp $
+
+EAPI=1
+
+inherit eutils virtualx xfce44
+
+MY_P=${P/t/T}
+S=${WORKDIR}/${MY_P}
+
+XFCE_VERSION=4.4.2
+xfce44
+
+DESCRIPTION="File manager"
+HOMEPAGE="http://thunar.xfce.org"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc dbus debug exif gnome hal pcre startup-notification +trash-plugin"
+
+RDEPEND=">=dev-lang/perl-5.6
+ x11-libs/libSM
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=xfce-extra/exo-0.3.4
+ >=x11-misc/shared-mime-info-0.20
+ >=dev-util/desktop-file-utils-0.14
+ >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
+ virtual/fam
+ dbus? ( dev-libs/dbus-glib )
+ hal? ( dev-libs/dbus-glib
+ sys-apps/hal )
+ >=media-libs/freetype-2
+ gnome? ( gnome-base/gconf )
+ exif? ( >=media-libs/libexif-0.6 )
+ >=media-libs/jpeg-6b
+ startup-notification? ( x11-libs/startup-notification )
+ pcre? ( >=dev-libs/libpcre-6 )
+ trash-plugin? ( dev-libs/dbus-glib
+ >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} )
+ gnome-base/librsvg"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ doc? ( dev-util/gtk-doc )"
+
+pkg_setup() {
+ XFCE_CONFIG="${XFCE_CONFIG} $(use_enable exif)
+ $(use_enable gnome gnome-thumbnailers)
+ $(use_enable dbus) $(use_enable pcre)"
+
+ local fail="Re-emerge xfce-extra/exo with USE hal."
+
+ if use hal; then
+ XFCE_CONFIG="${XFCE_CONFIG} --enable-dbus --with-volume-manager=hal"
+ else
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=none"
+ fi
+
+ if use trash-plugin && ! use dbus; then
+ XFCE_CONFIG="${XFCE_CONFIG} --enable-dbus"
+ ewarn "USE trash-plugin detected, enabling dbus for you."
+ fi
+
+ use trash-plugin || XFCE_CONFIG="${XFCE_CONFIG} --disable-tpa-plugin"
+
+ if use hal && ! use dbus; then
+ ewarn "USE hal detected, enabling dbus for you."
+ fi
+
+ if use hal && ! built_with_use xfce-extra/exo hal; then
+ eerror "${fail}"
+ die "${fail}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-missing-audio-cds-for-volman.patch
+ epatch "${FILESDIR}"/${P}-fix-defuncts.patch
+}
+
+src_test() {
+ Xemake check || die "emake check failed."
+}
+
+DOCS="AUTHORS ChangeLog HACKING FAQ THANKS TODO README NEWS"
+
+xfce44_extra_package