summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-04 08:02:17 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-04 08:02:17 +0000
commitacdf0861b2a160eabe631be316ba1a62b64e4594 (patch)
tree25fbc5bf41e458065c214ab1ad37b03f6be536fe /x11-wm
parentVersion bump. (diff)
downloadgentoo-2-acdf0861b2a160eabe631be316ba1a62b64e4594.tar.gz
gentoo-2-acdf0861b2a160eabe631be316ba1a62b64e4594.tar.bz2
gentoo-2-acdf0861b2a160eabe631be316ba1a62b64e4594.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile/ChangeLog10
-rw-r--r--x11-wm/qtile/qtile-0.7.0.ebuild58
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild15
3 files changed, 76 insertions, 7 deletions
diff --git a/x11-wm/qtile/ChangeLog b/x11-wm/qtile/ChangeLog
index 6ab0f353a2c7..4881798ede4f 100644
--- a/x11-wm/qtile/ChangeLog
+++ b/x11-wm/qtile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/qtile
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/ChangeLog,v 1.9 2013/09/07 20:55:15 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/ChangeLog,v 1.10 2014/04/04 08:02:17 radhermit Exp $
+
+*qtile-0.7.0 (04 Apr 2014)
+
+ 04 Apr 2014; Tim Harder <radhermit@gentoo.org> +qtile-0.7.0.ebuild,
+ qtile-9999.ebuild:
+ Version bump.
07 Sep 2013; Tim Harder <radhermit@gentoo.org> qtile-9999.ebuild:
Convert to git-r3 eclass and use HTML_DOCS.
diff --git a/x11-wm/qtile/qtile-0.7.0.ebuild b/x11-wm/qtile/qtile-0.7.0.ebuild
new file mode 100644
index 000000000000..844dbe6d332a
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-0.7.0.ebuild,v 1.1 2014/04/04 08:02:17 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 virtualx
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="git://github.com/qtile/qtile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/qtile/qtile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="http://qtile.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/pycairo-1.10.0-r4[xcb,${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ >=x11-libs/xpyb-1.3.1-r1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ x11-base/xorg-server[kdrive]
+ )"
+
+# tests fail due to xauth errors from python-xlib
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+}
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
index bd14b46c2e47..99dd6ef490cf 100644
--- a/x11-wm/qtile/qtile-9999.ebuild
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -1,20 +1,25 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-9999.ebuild,v 1.7 2013/09/07 20:55:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-9999.ebuild,v 1.8 2014/04/04 08:02:17 radhermit Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
-inherit git-r3 distutils-r1 virtualx
+inherit distutils-r1 virtualx
-EGIT_REPO_URI="git://github.com/qtile/qtile.git"
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="git://github.com/qtile/qtile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/qtile/qtile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
HOMEPAGE="http://qtile.org/"
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
IUSE="doc test"
RDEPEND=">=dev-python/pycairo-1.10.0-r4[xcb,${PYTHON_USEDEP}]