summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-03 20:53:45 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-03 20:53:45 +0000
commit74d8bcecfbcc4d73069838a4fdbe35e99c9be4ff (patch)
tree3a259003515a9e7e8117a5d097f5d51d3c6e23e8 /x11-wm
parentVersion bump (diff)
downloadgentoo-2-74d8bcecfbcc4d73069838a4fdbe35e99c9be4ff.tar.gz
gentoo-2-74d8bcecfbcc4d73069838a4fdbe35e99c9be4ff.tar.bz2
gentoo-2-74d8bcecfbcc4d73069838a4fdbe35e99c9be4ff.zip
Version bump with GCC 4.3 patch wrt #220156, thanks to Peter Alfredsen.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/aewm++/ChangeLog10
-rw-r--r--x11-wm/aewm++/aewm++-1.1.5.ebuild38
-rw-r--r--x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch36
3 files changed, 82 insertions, 2 deletions
diff --git a/x11-wm/aewm++/ChangeLog b/x11-wm/aewm++/ChangeLog
index bac9510986b6..997aab140f2e 100644
--- a/x11-wm/aewm++/ChangeLog
+++ b/x11-wm/aewm++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/aewm++
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++/ChangeLog,v 1.14 2007/07/14 04:31:19 omp Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++/ChangeLog,v 1.15 2008/05/03 20:53:44 drac Exp $
+
+*aewm++-1.1.5 (03 May 2008)
+
+ 03 May 2008; Samuli Suominen <drac@gentoo.org>
+ +files/aewm++-1.1.5-gcc43.patch, +aewm++-1.1.5.ebuild:
+ Version bump with GCC 4.3 patch wrt #220156, thanks to Peter Alfredsen.
14 Jul 2007; David Shakaryan <omp@gentoo.org> aewm++-1.0.24.ebuild:
Update HOMEPAGE. (bug #185223)
diff --git a/x11-wm/aewm++/aewm++-1.1.5.ebuild b/x11-wm/aewm++/aewm++-1.1.5.ebuild
new file mode 100644
index 000000000000..2dbc1b1bb182
--- /dev/null
+++ b/x11-wm/aewm++/aewm++-1.1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++/aewm++-1.1.5.ebuild,v 1.1 2008/05/03 20:53:44 drac Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A window manager with more modern features than aewm but with the same look and feel."
+HOMEPAGE="http://frankhale.org"
+SRC_URI="http://frankhale.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ sed -i -e "s:install -s:install:" Makefile \
+ || die "sed failed."
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" LDPATH="" \
+ ADDITIONAL_CFLAGS="" INCLUDES="" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog README
+}
diff --git a/x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch b/x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch
new file mode 100644
index 000000000000..23cacdc43a2b
--- /dev/null
+++ b/x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch
@@ -0,0 +1,36 @@
+diff -ur aewm++-1.1.5.orig/client.cc aewm++-1.1.5/client.cc
+--- aewm++-1.1.5.orig/client.cc 2005-05-23 06:06:01.000000000 +0300
++++ aewm++-1.1.5/client.cc 2008-05-03 23:50:02.000000000 +0300
+@@ -6,6 +6,8 @@
+ */
+ #include "aewm.hh"
+
++#include <string.h>
++
+ Client::Client(Display *d, Window new_client)
+ {
+ initialize(d);
+diff -ur aewm++-1.1.5.orig/main.cc aewm++-1.1.5/main.cc
+--- aewm++-1.1.5.orig/main.cc 2005-02-12 05:38:32.000000000 +0200
++++ aewm++-1.1.5/main.cc 2008-05-03 23:50:02.000000000 +0300
+@@ -6,6 +6,8 @@
+ */
+ #include "aewm.hh"
+
++#include <string.h>
++
+ // Dunno where I ripped this from. Kudos to the author whoever he is!
+ void forkExec(char *cmd)
+ {
+diff -ur aewm++-1.1.5.orig/windowmanager.cc aewm++-1.1.5/windowmanager.cc
+--- aewm++-1.1.5.orig/windowmanager.cc 2005-05-17 04:41:42.000000000 +0300
++++ aewm++-1.1.5/windowmanager.cc 2008-05-03 23:50:02.000000000 +0300
+@@ -6,6 +6,8 @@
+ */
+ #include "aewm.hh"
+
++#include <string.h>
++
+ WindowManager* wm;
+
+ #define AEWM_KEY_ALT_COUNT 4