summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-04-24 07:42:39 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-04-24 07:42:39 +0000
commit73db64a6ff3eb3f4431ae311449697798f7c044c (patch)
tree0e5081fceedc9aac0178b169468de34efa6bd4e7 /x11-wm
parentCompile with GCC 4.3; patch from Debian modified by Peter Alfredsen. (bug #21... (diff)
downloadgentoo-2-73db64a6ff3eb3f4431ae311449697798f7c044c.tar.gz
gentoo-2-73db64a6ff3eb3f4431ae311449697798f7c044c.tar.bz2
gentoo-2-73db64a6ff3eb3f4431ae311449697798f7c044c.zip
Version bump; clean up ebuild. (bug #214313)
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/ratpoison/ChangeLog9
-rw-r--r--x11-wm/ratpoison/ratpoison-1.4.3.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/x11-wm/ratpoison/ChangeLog b/x11-wm/ratpoison/ChangeLog
index 1409ba003468..af01eb8d8c33 100644
--- a/x11-wm/ratpoison/ChangeLog
+++ b/x11-wm/ratpoison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/ratpoison
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.57 2007/10/31 06:49:37 jer Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.58 2008/04/24 07:42:39 omp Exp $
+
+*ratpoison-1.4.3 (24 Apr 2008)
+
+ 24 Apr 2008; David Shakaryan <omp@gentoo.org> +ratpoison-1.4.3.ebuild:
+ Version bump; clean up ebuild. (bug #214313)
*ratpoison-1.4.2 (31 Oct 2007)
diff --git a/x11-wm/ratpoison/ratpoison-1.4.3.ebuild b/x11-wm/ratpoison/ratpoison-1.4.3.ebuild
new file mode 100644
index 000000000000..544acea490ca
--- /dev/null
+++ b/x11-wm/ratpoison/ratpoison-1.4.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.4.3.ebuild,v 1.1 2008/04/24 07:42:39 omp Exp $
+
+inherit elisp-common eutils autotools
+
+DESCRIPTION="Ratpoison is an extremely light-weight and barebones wm modelled after screen"
+HOMEPAGE="http://www.nongnu.org/ratpoison/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs"
+
+DEPEND="x11-libs/libXinerama
+ x11-libs/libXtst
+ virtual/perl-PodParser
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+SITEFILE=50ratpoison-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}/contrib"
+ epatch ${FILESDIR}/ratpoison.el-gentoo.patch
+
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake CFLAGS="${CFLAGS} -I/usr/X11R6/include" || die "emake failed"
+ if use emacs; then
+ cd contrib && elisp-comp ratpoison.el
+ fi
+}
+
+src_install() {
+ einstall
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}/ratpoison.xsession" ratpoison
+
+ dodoc INSTALL TODO README NEWS AUTHORS ChangeLog
+ docinto example
+ dodoc contrib/{genrpbindings,split.sh} \
+ doc/{ipaq.ratpoisonrc,sample.ratpoisonrc}
+
+ rm -rf "${D}/usr/share/"{doc/ratpoison,ratpoison}
+
+ if use emacs; then
+ elisp-install ${PN} contrib/ratpoison.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}