summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-04-18 17:41:39 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-04-18 17:41:39 +0000
commit7061c202a3dd4ff668929cccc9e6569e9146db0c (patch)
tree1b8bfd5901d30a59c803139c2107745cf7a31ce6 /x11-wm
parentDrop old (diff)
downloadgentoo-2-7061c202a3dd4ff668929cccc9e6569e9146db0c.tar.gz
gentoo-2-7061c202a3dd4ff668929cccc9e6569e9146db0c.tar.bz2
gentoo-2-7061c202a3dd4ff668929cccc9e6569e9146db0c.zip
Bump to 3.5.5, bug #507604. Add upstream patch to fix xdg icons search.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/awesome/ChangeLog8
-rw-r--r--x11-wm/awesome/awesome-3.5.5.ebuild132
-rw-r--r--x11-wm/awesome/files/awesome-3.5.5-util.lua-xdg-icons-fix.patch46
3 files changed, 185 insertions, 1 deletions
diff --git a/x11-wm/awesome/ChangeLog b/x11-wm/awesome/ChangeLog
index 6be7f1195ccd..9c8aeb404938 100644
--- a/x11-wm/awesome/ChangeLog
+++ b/x11-wm/awesome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/awesome
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/ChangeLog,v 1.161 2014/04/03 19:16:52 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/ChangeLog,v 1.162 2014/04/18 17:41:39 maksbotan Exp $
+
+*awesome-3.5.5 (18 Apr 2014)
+
+ 18 Apr 2014; Maxim Koltsov <maksbotan@gentoo.org> +awesome-3.5.5.ebuild,
+ +files/awesome-3.5.5-util.lua-xdg-icons-fix.patch:
+ Bump to 3.5.5, bug #507604. Add upstream patch to fix xdg icons search.
*awesome-3.5.4 (03 Apr 2014)
diff --git a/x11-wm/awesome/awesome-3.5.5.ebuild b/x11-wm/awesome/awesome-3.5.5.ebuild
new file mode 100644
index 000000000000..29343893cfc7
--- /dev/null
+++ b/x11-wm/awesome/awesome-3.5.5.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/awesome-3.5.5.ebuild,v 1.1 2014/04/18 17:41:39 maksbotan Exp $
+
+EAPI="5"
+CMAKE_MIN_VERSION="2.8"
+inherit cmake-utils eutils
+
+DESCRIPTION="A dynamic floating and tiling window manager"
+HOMEPAGE="http://awesome.naquadah.org/"
+SRC_URI="http://awesome.naquadah.org/download/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="dbus doc elibc_FreeBSD gnome"
+
+COMMON_DEPEND="
+ >=dev-lang/lua-5.1
+ dev-libs/glib:2
+ >=dev-libs/libxdg-basedir-1
+ >=dev-lua/lgi-0.7
+ x11-libs/cairo[xcb]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/libxcb-1.6
+ >=x11-libs/pango-1.19.3[introspection]
+ >=x11-libs/startup-notification-0.10_p20110426
+ >=x11-libs/xcb-util-0.3.8
+ x11-libs/xcb-util-cursor
+ x11-libs/libXcursor
+ || ( <x11-libs/libX11-1.3.99.901[xcb] >=x11-libs/libX11-1.3.99.901 )
+ dbus? ( >=sys-apps/dbus-1 )
+ elibc_FreeBSD? ( dev-libs/libexecinfo )"
+
+# graphicsmagick's 'convert -channel' has no Alpha support, bug #352282
+DEPEND="${COMMON_DEPEND}
+ >=app-text/asciidoc-8.4.5
+ app-text/xmlto
+ dev-util/gperf
+ virtual/pkgconfig
+ media-gfx/imagemagick[png]
+ >=x11-proto/xcb-proto-1.5
+ >=x11-proto/xproto-7.0.15
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS="AUTHORS BUGS PATCHES README STYLE"
+
+src_prepare() {
+ # bug #408025
+ epatch "${FILESDIR}/${PN}-3.5_rc1-convert-path.patch"
+ epatch "${FILESDIR}/${PN}-xsession.patch"
+
+ # bug #507604
+ epatch "${FILESDIR}/${P}-util.lua-xdg-icons-fix.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DPREFIX="${EPREFIX}"/usr
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ $(cmake-utils_use_with dbus DBUS)
+ $(cmake-utils_use doc GENERATE_DOC)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ local myargs="all"
+
+ if use doc ; then
+ myargs="${myargs} doc"
+ fi
+ cmake-utils_src_make ${myargs}
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc ; then
+ (
+ cd "${CMAKE_BUILD_DIR}"/doc
+ mv html doxygen
+ dohtml -r doxygen || die
+ )
+ fi
+ rm -rf "${ED}"/usr/share/doc/${PN} || die "Cleanup of dupe docs failed"
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN} || die
+
+ # GNOME-based awesome
+ if use gnome ; then
+ # GNOME session
+ insinto /usr/share/gnome-session/sessions
+ newins "${FILESDIR}/${PN}-gnome-3.session" "${PN}-gnome.session" || die
+ # Application launcher
+ domenu "${FILESDIR}/${PN}-gnome.desktop" || die
+ # X Session
+ insinto /usr/share/xsessions/
+ doins "${FILESDIR}/${PN}-gnome-xsession.desktop" || die
+ fi
+}
+
+pkg_postinst() {
+ # bug #447308
+ if use gnome; then
+ elog
+ elog "You have enabled the gnome USE flag."
+ elog "Please note that quitting awesome won't kill your gnome session."
+ elog "To really quit the session, you should bind your quit key"
+ elog "to the following command:"
+ elog " gnome-session-quit --logout"
+ elog "For more info visit"
+ elog " https://bugs.gentoo.org/show_bug.cgi?id=447308"
+ fi
+
+ # bug #440724
+ elog
+ elog "If you are having issues with Java application windows being"
+ elog "completely blank, try installing"
+ elog " x11-misc/wmname"
+ elog "and setting the WM name to LG3D."
+ elog "For more info visit"
+ elog " https://bugs.gentoo.org/show_bug.cgi?id=440724"
+ elog
+}
diff --git a/x11-wm/awesome/files/awesome-3.5.5-util.lua-xdg-icons-fix.patch b/x11-wm/awesome/files/awesome-3.5.5-util.lua-xdg-icons-fix.patch
new file mode 100644
index 000000000000..588f9ab9ec52
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-3.5.5-util.lua-xdg-icons-fix.patch
@@ -0,0 +1,46 @@
+From: Uli Schlachter <psychon@znc.in>
+Date: Sat, 12 Apr 2014 14:15:11 +0000 (+0200)
+Subject: Merge git://github.com/Teknocrat/awesome
+X-Git-Url: http://git.naquadah.org/?p=awesome.git;a=commitdiff_plain;h=d76d3e0b6a00b8b289b3801ba197e0dae732a92d;hp=1090719d677c86e90a1394a34f0effb418728493
+
+Merge git://github.com/Teknocrat/awesome
+---
+
+diff --git a/lib/awful/util.lua.in b/lib/awful/util.lua.in
+index 1d35f2f..123c4a6 100644
+--- a/lib/awful/util.lua.in
++++ b/lib/awful/util.lua.in
+@@ -185,21 +185,24 @@ end
+ -- of the dirs are searched first
+ function util.geticonpath(iconname, exts, dirs, size)
+ exts = exts or { 'png', 'gif' }
+- dirs = dirs or { '/usr/share/pixmaps/' }
++ dirs = dirs or { '/usr/share/pixmaps/', '/usr/share/icons/hicolor/' }
++ icontypes = { 'apps', 'actions', 'categories', 'emblems',
++ 'mimetypes', 'status', 'devices', 'extras', 'places', 'stock' }
+ for _, d in pairs(dirs) do
++ local icon
+ for _, e in pairs(exts) do
+- local icon
+- if size then
+- icon = string.format("%s%ux%u/%s.%s",
+- d, size, size, iconname, e)
+- if util.file_readable(icon) then
+- return icon
+- end
+- end
+ icon = d .. iconname .. '.' .. e
+ if util.file_readable(icon) then
+ return icon
+ end
++ if size then
++ for _, t in pairs(icontypes) do
++ icon = string.format("%s%ux%u/%s/%s.%s", d, size, size, t, iconname, e)
++ if util.file_readable(icon) then
++ return icon
++ end
++ end
++ end
+ end
+ end
+ end