summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-02 18:00:43 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-02 18:00:43 +0000
commit698453c0e01eec96119bb21e7a4358aa54ba566e (patch)
tree93214f3b560c75572640bf47d1eae40e667fda0c /x11-wm
parentAdd to ruby herd. (diff)
downloadgentoo-2-698453c0e01eec96119bb21e7a4358aa54ba566e.tar.gz
gentoo-2-698453c0e01eec96119bb21e7a4358aa54ba566e.tar.bz2
gentoo-2-698453c0e01eec96119bb21e7a4358aa54ba566e.zip
Enabling shared libs, fixing as-needed issues wrt bug 248549. Thanks Diego for the report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/blackbox/ChangeLog7
-rw-r--r--x11-wm/blackbox/blackbox-0.70.1.ebuild13
-rw-r--r--x11-wm/blackbox/files/blackbox-0.70.1-asneeded.patch49
3 files changed, 62 insertions, 7 deletions
diff --git a/x11-wm/blackbox/ChangeLog b/x11-wm/blackbox/ChangeLog
index 303b4f738114..bd1dadf76702 100644
--- a/x11-wm/blackbox/ChangeLog
+++ b/x11-wm/blackbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/blackbox
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/ChangeLog,v 1.65 2010/02/22 19:53:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/ChangeLog,v 1.66 2010/06/02 18:00:42 xarthisius Exp $
+
+ 02 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ blackbox-0.70.1.ebuild, +files/blackbox-0.70.1-asneeded.patch:
+ Enabling shared libs, fixing as-needed issues wrt bug 248549. Thanks Diego
+ for the report.
22 Feb 2010; Raúl Porcel <armin76@gentoo.org> blackbox-0.70.1.ebuild:
arm stable
diff --git a/x11-wm/blackbox/blackbox-0.70.1.ebuild b/x11-wm/blackbox/blackbox-0.70.1.ebuild
index 0627d1325d1d..0c57af6f393d 100644
--- a/x11-wm/blackbox/blackbox-0.70.1.ebuild
+++ b/x11-wm/blackbox/blackbox-0.70.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.70.1.ebuild,v 1.11 2010/02/22 19:53:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.70.1.ebuild,v 1.12 2010/06/02 18:00:42 xarthisius Exp $
-inherit eutils
+inherit autotools eutils
DESCRIPTION="A small, fast, full-featured window manager for X"
HOMEPAGE="http://blackboxwm.sourceforge.net/"
@@ -28,7 +28,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch" \
+ "${FILESDIR}/${P}-asneeded.patch"
+ eautoreconf
}
src_compile() {
@@ -36,8 +38,7 @@ src_compile() {
--sysconfdir=/etc/X11/${PN} \
$(use_enable debug) \
$(use_enable nls) \
- $(use_enable truetype xft) \
- || die "econf failed"
+ $(use_enable truetype xft)
emake || die "emake failed"
}
@@ -50,5 +51,5 @@ src_install() {
doins "${FILESDIR}/${PN}.desktop"
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO
+ dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO || die
}
diff --git a/x11-wm/blackbox/files/blackbox-0.70.1-asneeded.patch b/x11-wm/blackbox/files/blackbox-0.70.1-asneeded.patch
new file mode 100644
index 000000000000..a6b1e22e62b5
--- /dev/null
+++ b/x11-wm/blackbox/files/blackbox-0.70.1-asneeded.patch
@@ -0,0 +1,49 @@
+Fixing build with as-needed. Enabling shared libs.
+
+http://bugs.gentoo.org/show_bug.cgi?id=248549
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -22,7 +22,7 @@
+
+ DEFAULT_MENU = $(pkgdatadir)/menu
+ DEFAULT_STYLE = $(pkgdatadir)/styles/Gray
+-CPPFLAGS = @CPPFLAGS@ @SHAPE@ @XFT@ @DEBUG@ @NLS@ \
++AM_CPPFLAGS = @SHAPE@ @XFT@ @DEBUG@ @NLS@ \
+ -DLOCALEPATH=\"$(pkgdatadir)/nls\" \
+ -DDEFAULTMENU=\"$(DEFAULT_MENU)\" \
+ -DDEFAULTSTYLE=\"$(DEFAULT_STYLE)\" \
+--- lib/Makefile.am
++++ lib/Makefile.am
+@@ -62,7 +62,8 @@
+ Util.hh \
+ XDG.hh
+
+-libbt_la_LIBADD = @ICONV@ @LOCALE@
++libbt_la_LIBADD = @ICONV@ @LOCALE@ @xft_LIBS@
++libbt_la_CFLAGS = @xft_CFLAGS@
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ nodist_pkgconfig_DATA = libbt.pc
+--- util/Makefile.am
++++ util/Makefile.am
+@@ -21,7 +21,7 @@
+ # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ # DEALINGS IN THE SOFTWARE.
+
+-CPPFLAGS = @CPPFLAGS@ @DEBUG@ @NLS@ \
++AM_CPPFLAGS = @DEBUG@ @NLS@ \
+ -I$(top_srcdir)/lib
+
+ bin_SCRIPTS = bsetbg
+--- configure.ac
++++ configure.ac
+@@ -29,7 +29,7 @@
+ AC_PROG_INSTALL
+
+ dnl libbt shouldn't be shared by default (yet)
+-AC_DISABLE_SHARED
++dnl AC_DISABLE_SHARED
+ AC_PROG_LIBTOOL
+ AC_SUBST(LIBTOOL_DEPS)
+