summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-12 14:13:00 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-12 14:13:00 +0000
commit276d32bf17116ce249e9e4606baea12d37da63ab (patch)
tree9f17e44b611fde14f7495b70eee90c5a921cc0ee /x11-wm
parentVersion bump, drop .la files, remove old. (diff)
downloadgentoo-2-276d32bf17116ce249e9e4606baea12d37da63ab.tar.gz
gentoo-2-276d32bf17116ce249e9e4606baea12d37da63ab.tar.bz2
gentoo-2-276d32bf17116ce249e9e4606baea12d37da63ab.zip
Version bump, drop .la files.
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/sawfish/ChangeLog7
-rw-r--r--x11-wm/sawfish/sawfish-1.3.3.ebuild4
-rw-r--r--x11-wm/sawfish/sawfish-1.8.2.ebuild75
3 files changed, 83 insertions, 3 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 8ab7f6201859..b155d35a4f8e 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/sawfish
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.101 2011/08/07 17:40:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.102 2011/09/12 14:12:59 pacho Exp $
+
+*sawfish-1.8.2 (12 Sep 2011)
+
+ 12 Sep 2011; Pacho Ramos <pacho@gentoo.org> +sawfish-1.8.2.ebuild:
+ Version bump, drop .la files.
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> sawfish-1.6.3.ebuild:
alpha/ia64/sparc stable wrt #376345
diff --git a/x11-wm/sawfish/sawfish-1.3.3.ebuild b/x11-wm/sawfish/sawfish-1.3.3.ebuild
index d6f106ebc2c0..625faf5f63d4 100644
--- a/x11-wm/sawfish/sawfish-1.3.3.ebuild
+++ b/x11-wm/sawfish/sawfish-1.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.3.3.ebuild,v 1.9 2011/07/20 16:44:05 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.3.3.ebuild,v 1.10 2011/09/12 14:13:00 pacho Exp $
EAPI=1
@@ -24,7 +24,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ~ppc64 sparc x86"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
IUSE="gnome esd nls audiofile pango"
RDEPEND=">=x11-libs/rep-gtk-0.17
diff --git a/x11-wm/sawfish/sawfish-1.8.2.ebuild b/x11-wm/sawfish/sawfish-1.8.2.ebuild
new file mode 100644
index 000000000000..28a9a5da00d1
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.8.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.8.2.ebuild,v 1.1 2011/09/12 14:13:00 pacho Exp $
+
+EAPI="4"
+
+# detect cvs snapshots; fex. 1.3_p20040120
+[[ $PV == *_p[0-9][0-9][0-9][0-9][0-9][0-9][0-9][0-9] ]]
+(( snapshot = !$? ))
+
+if (( snapshot )); then
+ inherit eutils autotools
+else
+ inherit eutils
+fi
+
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+HOMEPAGE="http://sawfish.wikia.com/"
+if (( snapshot )); then
+ SRC_URI="mirror://gentoo/${P/_p/.}.tar.bz2"
+else
+ SRC_URI="http://download.tuxfamily.org/sawfish/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2 Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls xinerama"
+
+RDEPEND=">=dev-libs/librep-0.92.0
+ >=x11-libs/rep-gtk-0.90.4
+ >=x11-libs/pango-1.8.0
+ >=x11-libs/gtk+-2.12.0:2
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+if (( snapshot )); then
+ S="${WORKDIR}/${PN}"
+fi
+
+src_prepare() {
+ if (( snapshot )); then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ set -- \
+ $(use_with xinerama) \
+ --with-gdk-pixbuf \
+ --disable-static
+
+ if ! use nls; then
+ # Use a space because configure script reads --enable-linguas="" as
+ # "install everything"
+ # Don't use --disable-linguas, because that means --enable-linguas="no",
+ # which means "install Norwegian translations"
+ set -- "$@" --enable-linguas=" "
+ elif [[ "${LINGUAS+set}" == "set" ]]; then
+ strip-linguas -i po
+ set -- "$@" --enable-linguas=" ${LINGUAS} "
+ else
+ set -- "$@" --enable-linguas=""
+ fi
+
+ econf "$@"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ dodoc AUTHORS ChangeLog DOC FAQ NEWS OPTIONS README README.IMPORTANT TODO
+}