summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2007-06-30 13:14:15 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2007-06-30 13:14:15 +0000
commit2843e39de92b529bf5348b8f9aadfd596f873645 (patch)
tree98c4f81070c3cf5b0fa58071750c7d9736684786 /x11-wm/wm2
parentinclude a resolv.conf patch form SuSE and a malloc fix from upstream (diff)
downloadgentoo-2-2843e39de92b529bf5348b8f9aadfd596f873645.tar.gz
gentoo-2-2843e39de92b529bf5348b8f9aadfd596f873645.tar.bz2
gentoo-2-2843e39de92b529bf5348b8f9aadfd596f873645.zip
Fixed build on amd64. Thanks to angelos and vapier. bug \#153575
(Portage version: 2.1.2.7)
Diffstat (limited to 'x11-wm/wm2')
-rw-r--r--x11-wm/wm2/ChangeLog6
-rw-r--r--x11-wm/wm2/files/wm2-4-gentoo.patch137
-rw-r--r--x11-wm/wm2/wm2-4.ebuild41
3 files changed, 112 insertions, 72 deletions
diff --git a/x11-wm/wm2/ChangeLog b/x11-wm/wm2/ChangeLog
index 2882353634ee..954cd1abc023 100644
--- a/x11-wm/wm2/ChangeLog
+++ b/x11-wm/wm2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/wm2
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/wm2/ChangeLog,v 1.9 2007/02/21 22:44:08 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/wm2/ChangeLog,v 1.10 2007/06/30 13:14:15 coldwind Exp $
+
+ 30 Jun 2007; Santiago M. Mola <coldwind@gentoo.org>
+ files/wm2-4-gentoo.patch, wm2-4.ebuild:
+ Fixed build on amd64. Thanks to angelos and vapier. bug #153575
21 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/x11-wm/wm2/files/wm2-4-gentoo.patch b/x11-wm/wm2/files/wm2-4-gentoo.patch
index 9ec201424218..88c78080c542 100644
--- a/x11-wm/wm2/files/wm2-4-gentoo.patch
+++ b/x11-wm/wm2/files/wm2-4-gentoo.patch
@@ -1,107 +1,146 @@
-diff -Nru wm2-4/Border.C wm2-4.orig/Border.C
---- wm2-4/Border.C 2003-03-09 19:34:25.000000000 +0900
-+++ wm2-4.orig/Border.C 2003-03-09 19:43:14.000000000 +0900
+diff -ur wm2-4/Border.C wm2-4.new/Border.C
+--- wm2-4/Border.C 1997-03-21 12:12:30.000000000 +0100
++++ wm2-4.new/Border.C 2007-06-30 16:56:10.000000000 +0200
@@ -183,7 +183,7 @@
if (m_label) free(m_label);
m_label = m_client->iconName() ?
-- NewString(m_client->iconName()) : NewString(CONFIG_INCOGNITO);
-+ NewString(m_client->iconName()) : NewString("incognito");
+- NewString(m_client->iconName()) : NewString("incognito");
++ NewString(m_client->iconName()) : NewString(CONFIG_INCOGNITO);
int len = strlen(m_label);
m_tabHeight = XRotTextWidth(m_tabFont, m_label, len) + 6 + m_tabWidth;
-diff -Nru wm2-4/Buttons.C wm2-4.orig/Buttons.C
---- wm2-4/Buttons.C 2003-03-09 19:42:37.000000000 +0900
-+++ wm2-4.orig/Buttons.C 2003-03-09 19:43:14.000000000 +0900
-@@ -139,11 +139,7 @@
+diff -ur wm2-4/Buttons.C wm2-4.new/Buttons.C
+--- wm2-4/Buttons.C 1997-03-21 12:12:30.000000000 +0100
++++ wm2-4.new/Buttons.C 2007-06-30 16:56:10.000000000 +0200
+@@ -139,7 +139,11 @@
(allowExit && ((n) > clients.count())) ? "[Exit wm2]" \
: clients.item((n)-1)->label())
--#ifdef CONFIG_MENU_REVERSE
-- for (i = m_hiddenClients.count() - 1; i>=0; --i) {
--#else
++#ifdef CONFIG_MENU_REVERSE
++ for (i = m_hiddenClients.count() - 1; i>=0; --i) {
++#else
for (i = 0; i < m_hiddenClients.count(); ++i) {
--#endif
++#endif
clients.append(m_hiddenClients.item(i));
}
int nh = clients.count() + 1;
-diff -Nru wm2-4/Client.C wm2-4.orig/Client.C
---- wm2-4/Client.C 2003-03-09 19:34:25.000000000 +0900
-+++ wm2-4.orig/Client.C 2003-03-09 19:43:14.000000000 +0900
+diff -ur wm2-4/Client.C wm2-4.new/Client.C
+--- wm2-4/Client.C 1997-03-21 12:12:30.000000000 +0100
++++ wm2-4.new/Client.C 2007-06-30 16:56:10.000000000 +0200
@@ -4,7 +4,7 @@
#include <X11/Xutil.h>
--const char *const Client::m_defaultLabel = CONFIG_INCOGNITO;
-+const char *const Client::m_defaultLabel = "incognito";
+-const char *const Client::m_defaultLabel = "incognito";
++const char *const Client::m_defaultLabel = CONFIG_INCOGNITO;
-diff -Nru wm2-4/Config.h wm2-4.orig/Config.h
---- wm2-4/Config.h 2003-03-09 19:41:43.000000000 +0900
-+++ wm2-4.orig/Config.h 2003-03-09 19:43:14.000000000 +0900
-@@ -39,9 +39,6 @@
+@@ -400,7 +400,7 @@
+ }
+
+
+-int Client::getAtomProperty(Atom a, Atom type)
++uintptr_t Client::getAtomProperty(Atom a, Atom type)
+ {
+ char **p, *x;
+ if (getProperty_aux(display(), m_window, a, type, 1L,
+@@ -410,7 +410,7 @@
+
+ x = *p;
+ XFree((void *)p);
+- return (int)x;
++ return (uintptr_t)x;
+ }
+
+
+diff -ur wm2-4/Client.h wm2-4.new/Client.h
+--- wm2-4/Client.h 1997-03-21 12:12:30.000000000 +0100
++++ wm2-4.new/Client.h 2007-06-30 16:56:10.000000000 +0200
+@@ -2,6 +2,8 @@
+ #ifndef _CLIENT_H_
+ #define _CLIENT_H_
+
++#include <inttypes.h>
++
+ #include "General.h"
+ #include "Manager.h"
+ #include "Border.h"
+@@ -125,7 +127,7 @@
+ WindowManager *const m_windowManager;
+
+ char *getProperty(Atom);
+- int getAtomProperty(Atom, Atom);
++ uintptr_t getAtomProperty(Atom, Atom);
+ int getIntegerProperty(Atom);
+
+ // accessors
+diff -ur wm2-4/Config.h wm2-4.new/Config.h
+--- wm2-4/Config.h 1997-03-21 12:12:30.000000000 +0100
++++ wm2-4.new/Config.h 2007-06-30 16:56:10.000000000 +0200
+@@ -39,6 +39,9 @@
#define CONFIG_FRAME_THICKNESS 7
--#define CONFIG_INCOGNITO "incognito"
--#define CONFIG_MENU_REVERSE
--
++#define CONFIG_INCOGNITO "incognito"
++#define CONFIG_MENU_REVERSE
++
// If CONFIG_PROD_SHAPE is True, all frame element shapes will be
// recalculated afresh every time their focus changes. This will
// probably slow things down hideously, but has been reported as
-@@ -49,3 +46,4 @@
+@@ -46,4 +49,3 @@
#define CONFIG_PROD_SHAPE False
#endif
-+
-diff -Nru wm2-4/General.h wm2-4.orig/General.h
---- wm2-4/General.h 2003-03-09 19:34:25.000000000 +0900
-+++ wm2-4.orig/General.h 2003-03-09 19:43:14.000000000 +0900
+-
+diff -ur wm2-4/General.h wm2-4.new/General.h
+--- wm2-4/General.h 1997-03-21 12:12:30.000000000 +0100
++++ wm2-4.new/General.h 2007-06-30 16:56:10.000000000 +0200
@@ -32,7 +32,7 @@
#define NewString(x) (strcpy((char *)malloc(strlen(x)+1),(x)))
#ifndef SIGNAL_CALLBACK_TYPE
--#define SIGNAL_CALLBACK_TYPE (void (*)(int))
-+#define SIGNAL_CALLBACK_TYPE (void (*)(...))
+-#define SIGNAL_CALLBACK_TYPE (void (*)(...))
++#define SIGNAL_CALLBACK_TYPE (void (*)(int))
#endif
#define signal(x,y) \
-diff -Nru wm2-4/Makefile wm2-4.orig/Makefile
---- wm2-4/Makefile 2003-03-09 19:34:25.000000000 +0900
-+++ wm2-4.orig/Makefile 2003-03-09 19:43:14.000000000 +0900
+diff -ur wm2-4/Makefile wm2-4.new/Makefile
+--- wm2-4/Makefile 1997-03-21 12:12:30.000000000 +0100
++++ wm2-4.new/Makefile 2007-06-30 16:56:10.000000000 +0200
@@ -1,8 +1,8 @@
--LIBS = -L/usr/X11R6/lib -lXext -lX11 -lXmu -lm
-+LIBS = -L/usr/X11/lib -lXext -lX11 -lXmu -lm
+-LIBS = -L/usr/X11/lib -lXext -lX11 -lXmu -lm
++LIBS = -L/usr/X11R6/lib -lXext -lX11 -lXmu -lm
CC = gcc
--CCC = g++
-+CCC = gcc
+-CCC = gcc
++CCC = g++
CFLAGS = -O2
OBJECTS = Border.o Buttons.o Client.o Events.o Main.o Manager.o Rotated.o
-diff -Nru wm2-4/Manager.C wm2-4.orig/Manager.C
---- wm2-4/Manager.C 2003-03-09 19:34:25.000000000 +0900
-+++ wm2-4.orig/Manager.C 2003-03-09 19:43:14.000000000 +0900
+diff -ur wm2-4/Manager.C wm2-4.new/Manager.C
+--- wm2-4/Manager.C 1997-03-21 12:12:30.000000000 +0100
++++ wm2-4.new/Manager.C 2007-06-30 16:56:10.000000000 +0200
@@ -368,7 +368,7 @@
return m_currentTime;
}
--void WindowManager::sigHandler(int n)
-+void WindowManager::sigHandler()
+-void WindowManager::sigHandler()
++void WindowManager::sigHandler(int n)
{
m_signalled = True;
}
-diff -Nru wm2-4/Manager.h wm2-4.orig/Manager.h
---- wm2-4/Manager.h 2003-03-09 19:34:25.000000000 +0900
-+++ wm2-4.orig/Manager.h 2003-03-09 19:43:14.000000000 +0900
+diff -ur wm2-4/Manager.h wm2-4.new/Manager.h
+--- wm2-4/Manager.h 1997-03-21 12:12:30.000000000 +0100
++++ wm2-4.new/Manager.h 2007-06-30 16:56:10.000000000 +0200
@@ -85,7 +85,7 @@
static Boolean m_initialising;
static int errorHandler(Display *, XErrorEvent *);
-- static void sigHandler(int);
-+ static void sigHandler();
+- static void sigHandler();
++ static void sigHandler(int);
static int m_signalled;
void initialiseScreen();
diff --git a/x11-wm/wm2/wm2-4.ebuild b/x11-wm/wm2/wm2-4.ebuild
index eacb8d4c92a3..4f3c2c8f7aff 100644
--- a/x11-wm/wm2/wm2-4.ebuild
+++ b/x11-wm/wm2/wm2-4.ebuild
@@ -1,29 +1,27 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/wm2/wm2-4.ebuild,v 1.8 2006/03/15 08:17:16 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/wm2/wm2-4.ebuild,v 1.9 2007/06/30 13:14:15 coldwind Exp $
inherit eutils
-IUSE=""
-
DESCRIPTION="Small, unconfigurable window manager"
HOMEPAGE="http://www.all-day-breakfast.com/wm2/"
SRC_URI="http://www.all-day-breakfast.com/wm2/${P}.tar.gz"
-RDEPEND="|| ( x11-libs/libXmu virtual/x11 )"
+RDEPEND="x11-libs/libXmu"
DEPEND="${RDEPEND}
- || ( x11-proto/xextproto virtual/x11 )"
+ x11-proto/xextproto"
SLOT="0"
LICENSE="freedist"
KEYWORDS="amd64 ppc x86"
+IUSE=""
src_unpack() {
unpack ${A}
- cd ${S}
- EPATCH_OPTS="-R"
- epatch ${FILESDIR}/${PF}-gentoo.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${PF}-gentoo.patch"
sed 's/^#//' Config.h > wm2.conf
if [ -e "/etc/wm2.conf" ]; then
@@ -33,24 +31,23 @@ src_unpack() {
}
src_compile() {
- make CFLAGS="${CFLAGS}" || die
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
- exeinto /usr/bin
- doexe wm2
+ dobin wm2 || die
insinto /etc
- doins wm2.conf
- dodoc README
+ doins wm2.conf || die
+ dodoc README || die
}
pkg_postinst() {
- einfo
- einfo "wm2 is unconfigurable after you have installed. If you want to"
- einfo "change settings of wm2, please have a look at /etc/wm2.conf"
- einfo "and rewrite it, then emerge wm2 again (wm2 ebuild uses settings"
- einfo "from that file automatically). If you think wm2 lacks some important"
- einfo "features that you want to use (such as background pixmaps),"
- einfo "consider using wmx, written by the same author."
- einfo
+ echo
+ elog "wm2 is unconfigurable after you have installed. If you want to"
+ elog "change settings of wm2, please have a look at /etc/wm2.conf"
+ elog "and rewrite it, then emerge wm2 again (wm2 ebuild uses settings"
+ elog "from that file automatically). If you think wm2 lacks some important"
+ elog "features that you want to use (such as background pixmaps),"
+ elog "consider using wmx, written by the same author."
+ echo
}