summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-07-28 22:40:26 +0000
committerSteve Dibb <beandog@gentoo.org>2007-07-28 22:40:26 +0000
commita620ab74886ae017f6913e84ebaf1a20aca85b1b (patch)
treeb5f32c89afcdade199c3bcca4b8ef247b01eecde /x11-wm/icewm
parentclean out unneeded ebuilds (diff)
downloadgentoo-2-a620ab74886ae017f6913e84ebaf1a20aca85b1b.tar.gz
gentoo-2-a620ab74886ae017f6913e84ebaf1a20aca85b1b.tar.bz2
gentoo-2-a620ab74886ae017f6913e84ebaf1a20aca85b1b.zip
Add patch to build with uclibc
(Portage version: 2.1.2.9)
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/ChangeLog8
-rw-r--r--x11-wm/icewm/files/digest-icewm-1.2.30-r13
-rw-r--r--x11-wm/icewm/files/icewm-uclibc.patch31
-rw-r--r--x11-wm/icewm/icewm-1.2.30-r1.ebuild102
4 files changed, 143 insertions, 1 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index 187b8f8d9ab8..d6ed9d93ad7f 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/icewm
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.127 2007/07/22 04:25:55 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.128 2007/07/28 22:40:26 beandog Exp $
+
+*icewm-1.2.30-r1 (28 Jul 2007)
+
+ 28 Jul 2007; Steve Dibb <beandog@gentoo.org> +files/icewm-uclibc.patch,
+ +icewm-1.2.30-r1.ebuild:
+ Add patch to build with uclibc
22 Jul 2007; David Shakaryan <omp@gentoo.org> icewm-1.2.30.ebuild:
Remove virtual/x11 from dependencies.
diff --git a/x11-wm/icewm/files/digest-icewm-1.2.30-r1 b/x11-wm/icewm/files/digest-icewm-1.2.30-r1
new file mode 100644
index 000000000000..191b31a08926
--- /dev/null
+++ b/x11-wm/icewm/files/digest-icewm-1.2.30-r1
@@ -0,0 +1,3 @@
+MD5 8a302c5e629bb81d87cc02004a694ece icewm-1.2.30.tar.gz 809353
+RMD160 6848ac22f6562a8e0bb43def621b26f66bef56a7 icewm-1.2.30.tar.gz 809353
+SHA256 4b802cf77ecf09bc44345f8fba3c11fd08dca0e8272e628b447ecf7289637e1d icewm-1.2.30.tar.gz 809353
diff --git a/x11-wm/icewm/files/icewm-uclibc.patch b/x11-wm/icewm/files/icewm-uclibc.patch
new file mode 100644
index 000000000000..e7b273a6c397
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-uclibc.patch
@@ -0,0 +1,31 @@
+--- orig/icewm-1.2.21/src/acpustatus.cc 2005-05-31 14:23:48 -0500
++++ work/icewm-1.2.21/src/acpustatus.cc 2005-08-03 18:29:29 -0500
+@@ -25,17 +25,12 @@
+ #include "sysdep.h"
+ #include "default.h"
+
+-#if defined(linux)
+-//#include <linux/kernel.h>
+-#include <sys/sysinfo.h>
+-#endif
+ #if defined(sun) && defined(SVR4)
+ #include <sys/loadavg.h>
+ #endif
+ #ifdef HAVE_KSTAT_H
+ #include <sys/resource.h>
+ #include <kstat.h>
+-#include <sys/sysinfo.h>
+ #endif
+
+ #ifdef HAVE_SYS_PARAM_H
+@@ -54,6 +49,10 @@
+ #include <sched.h>
+ #endif
+
++#if defined(linux) || defined(HAVE_KSTAT_H)
++#include <sys/sysinfo.h>
++#endif
++
+ #include "intl.h"
+
+ #if (defined(linux) || defined(HAVE_KSTAT_H)) || defined(HAVE_SYSCTL_CP_TIME)
diff --git a/x11-wm/icewm/icewm-1.2.30-r1.ebuild b/x11-wm/icewm/icewm-1.2.30-r1.ebuild
new file mode 100644
index 000000000000..3f715fb95d83
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.2.30-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.2.30-r1.ebuild,v 1.1 2007/07/28 22:40:26 beandog Exp $
+
+inherit eutils
+
+DESCRIPTION="Ice Window Manager with Themes"
+
+HOMEPAGE="http://www.icewm.org/"
+
+#fix for icewm preversion package names
+S=${WORKDIR}/${P/_}
+
+SRC_URI="mirror://sourceforge/${PN}/${P/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="esd imlib nls spell truetype xinerama minimal debug uclibc"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libXrender
+ x11-libs/libXft
+ xinerama? ( x11-libs/libXinerama )
+ esd? ( media-sound/esound )
+ imlib? ( >=media-libs/imlib-1.9.10-r1 )
+ nls? ( sys-devel/gettext )
+ truetype? ( >=media-libs/freetype-2.0.9 )
+ media-libs/giflib"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )
+ >=sys-apps/sed-4"
+
+pkg_setup() {
+ if use truetype && use minimal; then
+ ewarn "You have both 'truetype' and 'minimal' use flags enabled."
+ ewarn "If you really want a minimal install, you will have to turn off"
+ ewarn "the truetype flag for this package."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+
+ use uclibc && epatch "${FILESDIR}/icewm-uclibc.patch"
+
+ echo "#!/bin/sh" > $T/icewm
+ echo "/usr/bin/icewm-session" >> $T/icewm
+}
+
+src_compile() {
+
+ if use truetype
+ then
+ myconf="${myconf} --enable-gradients --enable-shape --enable-movesize-fx --enable-shaped-decorations"
+ else
+ myconf="${myconf} --disable-xfreetype --enable-corefonts
+ $(use_enable minimal lite)"
+ fi
+
+ myconf="${myconf}
+ --with-libdir=/usr/share/icewm
+ --with-cfgdir=/etc/icewm
+ --with-docdir=/usr/share/doc/${PF}/html
+ $(use_with esd esd-config /usr/bin/esd-config)
+ $(use_enable nls)
+ $(use_enable nls i18n)
+ $(use_with imlib)
+ $(use_enable spell GtkSpell)
+ $(use_enable x86 x86-asm)
+ $(use_enable xinerama)
+ $(use_enable debug)"
+
+ CXXFLAGS="${CXXFLAGS}" econf ${myconf} || die "configure failed"
+
+ sed -i "s:/icewm-\$(VERSION)::" src/Makefile || die "patch failed"
+ sed -i "s:ungif:gif:" src/Makefile || die "libungif fix failed"
+
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS BUGS CHANGES PLATFORMS README* TODO VERSION
+ dohtml -a html,sgml doc/*
+
+ exeinto /etc/X11/Sessions
+ doexe $T/icewm
+
+ insinto /usr/share/xsessions
+ doins ${FILESDIR}/IceWM.desktop
+}