summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-05-11 08:51:24 +0000
committerPacho Ramos <pacho@gentoo.org>2013-05-11 08:51:24 +0000
commit4e285621727027f1538bc9d29a8ade1faefe65eb (patch)
tree581b4c8d0c3ee587ab1f78e85626bfe52908d50d /x11-themes/light-themes
parentVersion bump, drop old (diff)
downloadgentoo-2-4e285621727027f1538bc9d29a8ade1faefe65eb.tar.gz
gentoo-2-4e285621727027f1538bc9d29a8ade1faefe65eb.tar.bz2
gentoo-2-4e285621727027f1538bc9d29a8ade1faefe65eb.zip
Fix remaining gtk+-3.8 issue (#469062 by Evgeny Bobkin)
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-themes/light-themes')
-rw-r--r--x11-themes/light-themes/ChangeLog9
-rw-r--r--x11-themes/light-themes/files/light-themes-0.1.93-gtk3.8-3.patch42
-rw-r--r--x11-themes/light-themes/light-themes-0.1.93-r2.ebuild (renamed from x11-themes/light-themes/light-themes-0.1.93-r1.ebuild)3
3 files changed, 52 insertions, 2 deletions
diff --git a/x11-themes/light-themes/ChangeLog b/x11-themes/light-themes/ChangeLog
index 42f0507f278d..2d15ca7a0816 100644
--- a/x11-themes/light-themes/ChangeLog
+++ b/x11-themes/light-themes/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-themes/light-themes
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/light-themes/ChangeLog,v 1.18 2013/05/09 18:27:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/light-themes/ChangeLog,v 1.19 2013/05/11 08:51:24 pacho Exp $
+
+*light-themes-0.1.93-r2 (11 May 2013)
+
+ 11 May 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/light-themes-0.1.93-gtk3.8-3.patch, +light-themes-0.1.93-r2.ebuild,
+ -light-themes-0.1.93-r1.ebuild:
+ Fix remaining gtk+-3.8 issue (#469062 by Evgeny Bobkin)
*light-themes-0.1.93-r1 (09 May 2013)
diff --git a/x11-themes/light-themes/files/light-themes-0.1.93-gtk3.8-3.patch b/x11-themes/light-themes/files/light-themes-0.1.93-gtk3.8-3.patch
new file mode 100644
index 000000000000..4f51f7dab979
--- /dev/null
+++ b/x11-themes/light-themes/files/light-themes-0.1.93-gtk3.8-3.patch
@@ -0,0 +1,42 @@
+=== modified file 'Ambiance/gtk-3.0/gtk-widgets.css'
+--- Ambiance/gtk-3.0/gtk-widgets.css 2013-02-19 13:06:53 +0000
++++ Ambiance/gtk-3.0/gtk-widgets.css 2013-03-01 23:35:05 +0000
+@@ -44,7 +44,6 @@
+ -GtkToolbar-internal-padding: 0;
+ -GtkTreeView-expander-size: 8;
+ -GtkTreeView-vertical-separator: 0;
+- -GtkWidget-wide-separators: true;
+ -GtkWidget-separator-width: 2;
+ -GtkWidget-separator-height: 2;
+ -GtkWidget-focus-padding: 0;
+@@ -1567,6 +1566,8 @@
+
+ .menuitem.separator {
+ -GtkMenuItem-horizontal-padding: 0;
++ border: none;
++ color: @dark_bg_color;
+ }
+
+ GtkTreeMenu .menuitem.separator,
+
+=== modified file 'Radiance/gtk-3.0/gtk-widgets.css'
+--- Radiance/gtk-3.0/gtk-widgets.css 2013-02-19 13:06:53 +0000
++++ Radiance/gtk-3.0/gtk-widgets.css 2013-03-01 23:35:05 +0000
+@@ -44,7 +44,6 @@
+ -GtkToolbar-internal-padding: 0;
+ -GtkTreeView-expander-size: 8;
+ -GtkTreeView-vertical-separator: 0;
+- -GtkWidget-wide-separators: true;
+ -GtkWidget-separator-width: 2;
+ -GtkWidget-separator-height: 2;
+ -GtkWidget-focus-padding: 0;
+@@ -1567,6 +1566,8 @@
+
+ .menuitem.separator {
+ -GtkMenuItem-horizontal-padding: 0;
++ border: none;
++ color: @dark_bg_color;
+ }
+
+ GtkTreeMenu .menuitem.separator,
+
diff --git a/x11-themes/light-themes/light-themes-0.1.93-r1.ebuild b/x11-themes/light-themes/light-themes-0.1.93-r2.ebuild
index 2bfba69206ee..011fda0b0b1a 100644
--- a/x11-themes/light-themes/light-themes-0.1.93-r1.ebuild
+++ b/x11-themes/light-themes/light-themes-0.1.93-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/light-themes/light-themes-0.1.93-r1.ebuild,v 1.1 2013/05/09 18:27:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/light-themes/light-themes-0.1.93-r2.ebuild,v 1.1 2013/05/11 08:51:24 pacho Exp $
EAPI=5
inherit eutils
@@ -23,6 +23,7 @@ src_prepare() {
# upstream: https://bugs.launchpad.net/ubuntu-themes/+bug/1130183
epatch "${FILESDIR}/${P}-gtk3.8-1.patch"
epatch "${FILESDIR}/${P}-gtk3.8-2.patch"
+ epatch "${FILESDIR}/${P}-gtk3.8-3.patch"
cp -r Ambiance/ Ambiance-Gentoo || die
cp -r Radiance/ Radiance-Gentoo || die