summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-09-03 10:46:20 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-09-03 10:46:20 +0000
commitedda2bac0760af68def515a2e0a5d352ecd8fa52 (patch)
treee12768c31c78284e3493618e43dbcb908cf2a9e3 /x11-themes/gtk-engines
parent[profiles] Mask KDE 4.2.4 (diff)
downloadgentoo-2-edda2bac0760af68def515a2e0a5d352ecd8fa52.tar.gz
gentoo-2-edda2bac0760af68def515a2e0a5d352ecd8fa52.tar.bz2
gentoo-2-edda2bac0760af68def515a2e0a5d352ecd8fa52.zip
Add lua USE-flag per bug #283407, Fix the patch which did not work with --enable-animation --disable-lua --without-system-lua.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/gtk-engines')
-rw-r--r--x11-themes/gtk-engines/ChangeLog7
-rw-r--r--x11-themes/gtk-engines/files/gtk-engines-2.18.2-system-lua.patch19
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.18.2-r1.ebuild15
3 files changed, 23 insertions, 18 deletions
diff --git a/x11-themes/gtk-engines/ChangeLog b/x11-themes/gtk-engines/ChangeLog
index e8e91344e279..7e5e4cc8da56 100644
--- a/x11-themes/gtk-engines/ChangeLog
+++ b/x11-themes/gtk-engines/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/gtk-engines
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/ChangeLog,v 1.146 2009/08/31 20:16:07 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/ChangeLog,v 1.147 2009/09/03 10:46:19 mrpouet Exp $
+
+ 03 Sep 2009; Romain Perier <mrpouet@gentoo.org>
+ gtk-engines-2.18.2-r1.ebuild, files/gtk-engines-2.18.2-system-lua.patch:
+ Add lua USE-flag per bug #283407, Fix the patch which did not work with
+ --enable-animation --disable-lua --without-system-lua.
31 Aug 2009; Romain Perier <mrpouet@gentoo.org>
gtk-engines-2.18.2-r1.ebuild:
diff --git a/x11-themes/gtk-engines/files/gtk-engines-2.18.2-system-lua.patch b/x11-themes/gtk-engines/files/gtk-engines-2.18.2-system-lua.patch
index 418fbd3c9c4c..ea56941caac0 100644
--- a/x11-themes/gtk-engines/files/gtk-engines-2.18.2-system-lua.patch
+++ b/x11-themes/gtk-engines/files/gtk-engines-2.18.2-system-lua.patch
@@ -1,23 +1,26 @@
-From 7508e8941bc664df0e7b8c952d82d901f9a95c75 Mon Sep 17 00:00:00 2001
-From: Ihar Hrachyshka <ihar.hrachyshka@gmail.com>
-Date: Mon, 31 Aug 2009 16:09:55 +0300
-Subject: [PATCH] Added configure option to use system liblua for Lua engine.
+From 832010dc4c679a35103d2add5c7e6a28bf5f8b07 Mon Sep 17 00:00:00 2001
+From: Romain Perier <mrpouet@gentoo.org>
+Date: Thu, 3 Sep 2009 12:35:15 +0200
+Subject: [PATCH] Add configure option to use lua system library instead of embedded version
+
+Fixed version: Replaced $enableval by $withval in AC_ARG_WITH(system-lua...),
+otherwises it was impossible to exec the configure script correctly with the following options:
+--enable-animation --disable-lua --without-system-lua, because LUA was checked anyway.
-Signed-off-by: Ihar Hrachyshka <ihar.hrachyshka@gmail.com>
---
configure.ac | 10 ++++
engines/lua/Makefile.am | 118 +++++++++++++++++++++++++----------------------
2 files changed, 73 insertions(+), 55 deletions(-)
diff --git a/configure.ac b/configure.ac
-index df673ed..3c3ce2a 100644
+index df673ed..6273675 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,9 @@ AC_ARG_ENABLE(paranoia, [ --enable-paranoia use wall, werror, ansi, peda
AC_ARG_ENABLE(deprecated, [ --disable-deprecated disable deprecated functions in gtk et al], [deprecated=$enableval], [deprecated="no"])
AC_ARG_ENABLE(schemas, [ --disable-schema disable engine schemas], [schemas=$enableval], [schemas="yes"])
-+AC_ARG_WITH(system-lua, [ --with-system-lua link with system Lua library], [system_lua=$enableval], [system_lua="no"])
++AC_ARG_WITH(system-lua, [ --with-system-lua link with system Lua library], [system_lua=$withval], [system_lua="no"])
+
+AM_CONDITIONAL([SYSTEM_LUA], [test x$system_lua = xtrue])
@@ -179,5 +182,5 @@ index 736154d..6243e5a 100644
-include $(top_srcdir)/git.mk
--
-1.6.3.3
+1.6.4.2
diff --git a/x11-themes/gtk-engines/gtk-engines-2.18.2-r1.ebuild b/x11-themes/gtk-engines/gtk-engines-2.18.2-r1.ebuild
index 5e547ff92d67..bde1cdf90645 100644
--- a/x11-themes/gtk-engines/gtk-engines-2.18.2-r1.ebuild
+++ b/x11-themes/gtk-engines/gtk-engines-2.18.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/gtk-engines-2.18.2-r1.ebuild,v 1.2 2009/08/31 20:16:07 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/gtk-engines-2.18.2-r1.ebuild,v 1.3 2009/09/03 10:46:19 mrpouet Exp $
EAPI="2"
GCONF_DEBUG="no"
@@ -13,10 +13,10 @@ HOMEPAGE="http://www.gtk.org/"
LICENSE="LGPL-2.1"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="accessibility"
+IUSE="accessibility lua"
RDEPEND=">=x11-libs/gtk+-2.12
- dev-lang/lua"
+ lua? ( dev-lang/lua )"
DEPEND="${RDEPEND}
>=dev-util/intltool-0.31
>=dev-util/pkgconfig-0.9"
@@ -24,18 +24,15 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README"
pkg_setup() {
- G2CONF="${G2CONF} --enable-animation --enable-lua --with-system-lua"
+ G2CONF="${G2CONF} --enable-animation $(use_enable lua) $(use_with lua system-lua)"
use accessibility || G2CONF="${G2CONF} --disable-hc"
}
-
src_prepare() {
gnome2_src_prepare
- # Fix intltoolize broken file, see upstream #577133
- sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
- || die "sed failed"
# Don't use liblua embedded version, use system lib instead
- # fix bug #255773, import from upstream bug #593674
+ # fix bug #255773, import from upstream bug #593674, FIXED VERSION
+ # (patch commented out)
epatch "${FILESDIR}"/${P}-system-lua.patch
intltoolize --automake --copy --force || die "intltoolize failed"
eautoreconf