summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené Nussbaumer <killerfox@gentoo.org>2006-12-23 21:27:38 +0000
committerRené Nussbaumer <killerfox@gentoo.org>2006-12-23 21:27:38 +0000
commit5bd0f2cbf16dfefb96cd2da27e095318beb9a531 (patch)
tree9d732c98e976868b643e62e5cfe4fbd77b2ae142 /x11-terms
parentkinda need this for testing purposes :-) (diff)
downloadgentoo-2-5bd0f2cbf16dfefb96cd2da27e095318beb9a531.tar.gz
gentoo-2-5bd0f2cbf16dfefb96cd2da27e095318beb9a531.tar.bz2
gentoo-2-5bd0f2cbf16dfefb96cd2da27e095318beb9a531.zip
Version bump from upstream
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog8
-rw-r--r--x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.13
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-8.1.ebuild78
3 files changed, 88 insertions, 1 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 891dae35ff65..286efd420a69 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.80 2006/11/08 20:35:16 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.81 2006/12/23 21:27:38 killerfox Exp $
+
+*rxvt-unicode-8.1 (23 Dec 2006)
+
+ 23 Dec 2006; René Nussbaumer <killerfox@gentoo.org>
+ +rxvt-unicode-8.1.ebuild:
+ Version bump from upstream
*rxvt-unicode-8.0 (08 Nov 2006)
diff --git a/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.1 b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.1
new file mode 100644
index 000000000000..14fcd33a7781
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.1
@@ -0,0 +1,3 @@
+MD5 35b40231ea62b9ad4340080d34781927 rxvt-unicode-8.1.tar.bz2 874511
+RMD160 2e0535449267a43222976fd6a3dfeb7fd3201c87 rxvt-unicode-8.1.tar.bz2 874511
+SHA256 28a80b8976da496e7748cc6a26a10a3d0fb1eeffaef708804848cca86b96bb69 rxvt-unicode-8.1.tar.bz2 874511
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-8.1.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-8.1.ebuild
new file mode 100644
index 000000000000..4c08b47bc621
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-8.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-8.1.ebuild,v 1.1 2006/12/23 21:27:38 killerfox Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="rxvt clone with XFT and Unicode support"
+HOMEPAGE="http://software.schmorp.de/"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="truetype perl iso14755"
+
+# see bug #115992 for modular x deps
+RDEPEND="
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrender
+ )
+ virtual/x11
+ )
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ || (
+ (
+ x11-proto/xproto
+ )
+ virtual/x11
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ local tdir=/usr/share/terminfo
+ sed -i -e \
+ "s~@TIC@ \(etc/rxvt\)~@TIC@ -o ${D}/${tdir} \1~" \
+ doc/Makefile.in
+}
+
+src_compile() {
+ myconf=''
+
+ use iso14755 || myconf='--disable-iso14755'
+
+ econf \
+ --enable-everything \
+ $(use_enable truetype xft) \
+ $(use_enable perl) \
+ --disable-text-blink \
+ ${myconf} \
+ || die
+
+ emake || die
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ ${S}/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README.FAQ Changes
+ cd "${S}"/doc
+ dodoc README* changes.txt etc/* rxvt-tabbed
+}
+
+pkg_postinst() {
+ einfo "urxvt now always uses TERM=rxvt-unicode so that the"
+ einfo "upstream-supplied terminfo files can be used."
+}
+