summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-02-24 10:59:21 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-02-24 10:59:21 +0000
commit79b00d1e41e20a3456675abe032bf6bf5fc06fea (patch)
tree641072e1ff82d5ecaa2e33100b3debf3acbded8a /x11-terms/root-tail/root-tail-1.2-r2.ebuild
parentAdd new revision of root-tail pending testing under kde. (diff)
downloadgentoo-2-79b00d1e41e20a3456675abe032bf6bf5fc06fea.tar.gz
gentoo-2-79b00d1e41e20a3456675abe032bf6bf5fc06fea.tar.bz2
gentoo-2-79b00d1e41e20a3456675abe032bf6bf5fc06fea.zip
Revision bump; added patch for kde support thanks to Evgeniy <dushistov@mail.ru> in bug 83091.
(Portage version: 2.0.51.16)
Diffstat (limited to 'x11-terms/root-tail/root-tail-1.2-r2.ebuild')
-rw-r--r--x11-terms/root-tail/root-tail-1.2-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-terms/root-tail/root-tail-1.2-r2.ebuild b/x11-terms/root-tail/root-tail-1.2-r2.ebuild
new file mode 100644
index 000000000000..6637caf94575
--- /dev/null
+++ b/x11-terms/root-tail/root-tail-1.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/root-tail/root-tail-1.2-r2.ebuild,v 1.1 2005/02/24 10:59:21 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="Terminal to display (multiple) log files on the root window"
+HOMEPAGE="http://www.goof.com/pcg/marc/root-tail.html"
+SRC_URI="http://www.goof.com/pcg/marc/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~ppc64"
+IUSE="kde"
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use kde && epatch ${FILESDIR}/${P}-kde.patch
+}
+
+src_compile() {
+ xmkmf -a
+ sed -i 's|/usr/X11R6/bin|/usr/bin|' Makefile || die "sed Makefile failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install install.man || die "make install failed"
+ dodoc Changes README
+}