summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-03-07 21:45:00 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-03-07 21:45:00 +0000
commitf6463faf98e2533d108c07069a1cb9e66aa9e2e7 (patch)
treeafc1dc2f1f3f96995d46239e38cbb0e892da1d93 /x11-plugins
parentAdd X-Forwarded-For support via xforward useflag/patch, closes #306127 (diff)
downloadgentoo-2-f6463faf98e2533d108c07069a1cb9e66aa9e2e7.tar.gz
gentoo-2-f6463faf98e2533d108c07069a1cb9e66aa9e2e7.tar.bz2
gentoo-2-f6463faf98e2533d108c07069a1cb9e66aa9e2e7.zip
Version bump, fix for newer buddy icons being too small, and also downloads all your offline buddies as well as your online ones
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-facebookchat/ChangeLog9
-rw-r--r--x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.65.ebuild49
2 files changed, 57 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-facebookchat/ChangeLog b/x11-plugins/pidgin-facebookchat/ChangeLog
index 277bed549e49..fbe1281fd7d4 100644
--- a/x11-plugins/pidgin-facebookchat/ChangeLog
+++ b/x11-plugins/pidgin-facebookchat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/pidgin-facebookchat
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/ChangeLog,v 1.29 2010/02/17 10:44:35 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/ChangeLog,v 1.30 2010/03/07 21:45:00 voyageur Exp $
+
+*pidgin-facebookchat-1.65 (07 Mar 2010)
+
+ 07 Mar 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +pidgin-facebookchat-1.65.ebuild:
+ Version bump, fix for newer buddy icons being too small, and also
+ downloads all your offline buddies as well as your online ones
17 Feb 2010; Bernard Cafarelli <voyageur@gentoo.org>
-pidgin-facebookchat-1.50.ebuild, -pidgin-facebookchat-1.60.ebuild,
diff --git a/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.65.ebuild b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.65.ebuild
new file mode 100644
index 000000000000..f07d28677a59
--- /dev/null
+++ b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.65.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.65.ebuild,v 1.1 2010/03/07 21:45:00 voyageur Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Facebook chat plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/pidgin-facebookchat/"
+
+SRC_URI="http://pidgin-facebookchat.googlecode.com/files/${PN}-source-${PV}.tar.bz2"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/json-glib-0.7.6
+ >=net-im/pidgin-2.3.0"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ ewarn "This plugin is not mandatory anymore for Facebook chat"
+ ewarn "as it is now available via XMPP, see:"
+ ewarn "http://blog.facebook.com/blog.php?post=297991732130"
+ ewarn "You can still use this plugin for extra features if you want"
+ ewarn "Future versions will use XMPP and provide these features at the same time"
+}
+
+src_compile() {
+ # Grabbed from makefile
+ FACEBOOK_SOURCES="libfacebook.c fb_blist.c fb_connection.c fb_conversation.c fb_friendlist.c fb_info.c fb_json.c fb_managefriends.c fb_messages.c fb_notifications.c fb_search.c fb_util.c"
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} `pkg-config --cflags purple json-glib-1.0` \
+ -DPURPLE_PLUGINS -DENABLE_NLS -DHAVE_ZLIB -shared -fPIC -DPIC \
+ ${FACEBOOK_SOURCES} `pkg-config --libs json-glib-1.0` \
+ -o libfacebook.so || die "compilation failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/purple-2
+ doexe libfacebook.so
+ for size in 16 22 48; do
+ insinto /usr/share/pixmaps/pidgin/protocols/${size}
+ newins facebook${size}.png facebook.png
+ done
+}