summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-02-19 15:18:25 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-02-19 15:18:25 +0000
commitecf6710d05d9d3e7735c93cf3fa2f9293d339001 (patch)
tree7c3ecf93285acfe29c5cdef786d861bf063ae1e8 /x11-plugins
parentVersion bump (diff)
downloadgentoo-2-ecf6710d05d9d3e7735c93cf3fa2f9293d339001.tar.gz
gentoo-2-ecf6710d05d9d3e7735c93cf3fa2f9293d339001.tar.bz2
gentoo-2-ecf6710d05d9d3e7735c93cf3fa2f9293d339001.zip
Revision bump, see bug #207762.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmDownload/ChangeLog8
-rw-r--r--x11-plugins/wmDownload/files/wmDownload-0.1.2a-makefile.patch28
-rw-r--r--x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild36
3 files changed, 71 insertions, 1 deletions
diff --git a/x11-plugins/wmDownload/ChangeLog b/x11-plugins/wmDownload/ChangeLog
index 1eacb386a05c..4673adfbf6fc 100644
--- a/x11-plugins/wmDownload/ChangeLog
+++ b/x11-plugins/wmDownload/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmDownload
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmDownload/ChangeLog,v 1.9 2007/02/06 01:50:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmDownload/ChangeLog,v 1.10 2008/02/19 15:18:24 s4t4n Exp $
+
+*wmDownload-0.1.2a-r1 (19 Feb 2008)
+
+ 19 Feb 2008; Michele Noberasco <s4t4n@gentoo.org> wmDownload-0.1.2a-r1.ebuild,
+ files/wmDownload-0.1.2a-makefile.patch:
+ Revision bump, see bug #207762.
06 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/x11-plugins/wmDownload/files/wmDownload-0.1.2a-makefile.patch b/x11-plugins/wmDownload/files/wmDownload-0.1.2a-makefile.patch
new file mode 100644
index 000000000000..7dfdabc9cd76
--- /dev/null
+++ b/x11-plugins/wmDownload/files/wmDownload-0.1.2a-makefile.patch
@@ -0,0 +1,28 @@
+--- Makefile.orig 2000-04-14 15:39:52.000000000 +0200
++++ Makefile 2008-01-27 23:07:51.000000000 +0100
+@@ -1,17 +1,17 @@
+-CC = gcc
+-CFLAGS = -O2 -Wall -fomit-frame-pointer -s
+-INCDIR = -I/usr/X11R6/include/X11
+-DESTDIR= /usr/bin
+-LIBDIR = -L/usr/X11R6/lib
++CC ?= gcc
++CFLAGS += -Wall
++INCDIR = -I/usr/include/X11
++PREFIX = /usr
++LIBDIR ?= /usr/lib
+ LIBS = -ldockapp -lX11 -lXext -lXpm
+ OBJS = wmDownload.o
+
+ wmDownload: $(OBJS)
+- $(CC) $(CFLAGS) $(OBJS) -o wmDownload $(INCDIR) $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) $(OBJS) -o wmDownload $(INCDIR) -L$(LIBDIR) $(LDFLAGS) $(LIBS)
+
+ install: wmDownload
+- strip wmDownload
+- install -s wmDownload $(DESTDIR)
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -m 0755 wmDownload $(DESTDIR)$(PREFIX)/bin
+
+ uninstall:
+ rm -f $(DESTDIR)/wmDownload
diff --git a/x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild b/x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild
new file mode 100644
index 000000000000..f2bf46bd4279
--- /dev/null
+++ b/x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild,v 1.1 2008/02/19 15:18:24 s4t4n Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="dockapp that displays how much data you've received on each eth and ppp device."
+SRC_URI="mirror://sourceforge/wmdownload/${P}.tar.gz"
+HOMEPAGE="http://wmdownload.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE=""
+
+DEPEND="x11-libs/libdockapp
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)" || die "compile failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc CHANGELOG CREDITS HINTS README TODO
+}