summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-10-28 10:13:29 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-10-28 10:13:29 +0000
commit8a7b44f997973ff49c29f8f2bd20db2308f8dfaa (patch)
treef858b69f1d5ac242da96c7974ffdd247b1cf7da9 /x11-plugins
parentAdded missing inherit eutils, bug 244706 (diff)
downloadgentoo-2-8a7b44f997973ff49c29f8f2bd20db2308f8dfaa.tar.gz
gentoo-2-8a7b44f997973ff49c29f8f2bd20db2308f8dfaa.tar.bz2
gentoo-2-8a7b44f997973ff49c29f8f2bd20db2308f8dfaa.zip
Revision bump, with patch to fix bug #242500.
(Portage version: 2.1.4.5)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmtimer/ChangeLog8
-rw-r--r--x11-plugins/wmtimer/files/wmtimer-counter-fix.patch22
-rw-r--r--x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild40
3 files changed, 69 insertions, 1 deletions
diff --git a/x11-plugins/wmtimer/ChangeLog b/x11-plugins/wmtimer/ChangeLog
index 8b5a592b2b2c..0493ac7ba451 100644
--- a/x11-plugins/wmtimer/ChangeLog
+++ b/x11-plugins/wmtimer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmtimer
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/ChangeLog,v 1.22 2008/01/13 02:32:50 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/ChangeLog,v 1.23 2008/10/28 10:13:29 s4t4n Exp $
+
+*wmtimer-2.92-r1 (28 Oct 2008)
+
+ 28 Oct 2008; Michele Noberasco <s4t4n@gentoo.org> +wmtimer-2.9.2-r1.ebuild,
+ +wmtimer-counter-fix.patch:
+ Revision bump with patch to correct counter behaviour. Closes bug #242500.
*wmtimer-2.92 (13 Jan 2008)
diff --git a/x11-plugins/wmtimer/files/wmtimer-counter-fix.patch b/x11-plugins/wmtimer/files/wmtimer-counter-fix.patch
new file mode 100644
index 000000000000..62f2a5a82795
--- /dev/null
+++ b/x11-plugins/wmtimer/files/wmtimer-counter-fix.patch
@@ -0,0 +1,22 @@
+--- wmtimer.c.orig 2004-01-29 02:45:48.000000000 +0000
++++ wmtimer.c 2008-10-17 20:49:05.000000000 +0100
+@@ -128,7 +128,8 @@
+ switch (mode)
+ {
+ case TIMER:
+- if (prevSec < thisTime->tm_sec)
++ if ( (prevSec < thisTime->tm_sec)
++ || ((prevSec == 59) && (thisTime->tm_sec == 0)))
+ {
+ decrementTimer();
+ updateACT();
+@@ -138,7 +139,8 @@
+ prevSec = thisTime->tm_sec;
+ break;
+ case CHRONO:
+- if (prevSec < thisTime->tm_sec)
++ if ( (prevSec < thisTime->tm_sec)
++ || ((prevSec == 59) && (thisTime->tm_sec == 0)))
+ {
+ incrementTimer();
+ updateACT();
diff --git a/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild b/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild
new file mode 100644
index 000000000000..deb993bbddd8
--- /dev/null
+++ b/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild,v 1.1 2008/10/28 10:13:29 s4t4n Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Dockable clock which can run in alarm, countdown timer or chronograph mode"
+HOMEPAGE="http://www.darkops.net/wmtimer"
+SRC_URI="http://www.darkops.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s:-O2::" -e "s:-g:${CFLAGS}:g" -i Makefile
+ epatch "${FILESDIR}"/"${PN}"-counter-fix.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ LIBDIR="-L/usr/$(get_libdir)" || die "emake failed."
+}
+
+src_install() {
+ dobin wmtimer
+ dodoc ../{Changelog,CREDITS,README}
+}