summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-03-29 11:28:04 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-03-29 11:28:04 +0000
commit77dc7af8c1236bac058516fe57b3c3f3f5cb1ba8 (patch)
treec2e1bd7969fa2e8ef90964b29aac8165fd5e0b7b /x11-plugins
parentStable for AMD64, wrt bug #407789 (diff)
downloadgentoo-2-77dc7af8c1236bac058516fe57b3c3f3f5cb1ba8.tar.gz
gentoo-2-77dc7af8c1236bac058516fe57b3c3f3f5cb1ba8.tar.bz2
gentoo-2-77dc7af8c1236bac058516fe57b3c3f3f5cb1ba8.zip
Version bump, thanks wbk in bug #407325
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmon/ChangeLog12
-rw-r--r--x11-plugins/wmmon/files/wmmon-1.0_beta2-kernel26.patch121
-rw-r--r--x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch20
-rw-r--r--x11-plugins/wmmon/wmmon-1.2_beta1.ebuild37
4 files changed, 67 insertions, 123 deletions
diff --git a/x11-plugins/wmmon/ChangeLog b/x11-plugins/wmmon/ChangeLog
index c6eb556538df..f2324cb88f20 100644
--- a/x11-plugins/wmmon/ChangeLog
+++ b/x11-plugins/wmmon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/wmmon
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmon/ChangeLog,v 1.24 2010/08/31 09:48:41 s4t4n Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmon/ChangeLog,v 1.25 2012/03/29 11:28:04 voyageur Exp $
+
+*wmmon-1.2_beta1 (29 Mar 2012)
+
+ 29 Mar 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ -files/wmmon-1.0_beta2-kernel26.patch, +wmmon-1.2_beta1.ebuild,
+ +files/wmmon-1.2_beta1-Makefile.patch:
+ Version bump, thanks wbk in bug #407325. Rewrote ebuild, updated homepage,
+ install manpage. Also remove lefotver patch
31 Aug 2010; Michele Noberasco <s4t4n@gentoo.org> wmmon-1.0_beta2-r3.ebuild:
Honour LDFLAGS. Closes bug #334919.
diff --git a/x11-plugins/wmmon/files/wmmon-1.0_beta2-kernel26.patch b/x11-plugins/wmmon/files/wmmon-1.0_beta2-kernel26.patch
deleted file mode 100644
index 3b1234b4eb1c..000000000000
--- a/x11-plugins/wmmon/files/wmmon-1.0_beta2-kernel26.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-diff -ruN wmmon.app.orig/wmmon/Makefile wmmon.app/wmmon/Makefile
---- wmmon.app.orig/wmmon/Makefile 1998-05-19 23:13:16.000000000 +0200
-+++ wmmon.app/wmmon/Makefile 2004-05-22 04:27:19.000000000 +0200
-@@ -5,9 +5,8 @@
- ../wmgeneral/misc.o \
- ../wmgeneral/list.o
-
--
- .c.o:
-- cc -c -O2 -Wall $< -o $*.o
-+ cc -c $(CFLAGS) $(DEFINES) -Wall $< -o $*.o
-
- wmmon: $(OBJS)
- cc -o wmmon $^ $(LIBDIR) $(LIBS)
-diff -ruN wmmon.app.orig/wmmon/wmmon.c wmmon.app/wmmon/wmmon.c
---- wmmon.app.orig/wmmon/wmmon.c 1998-05-19 23:13:16.000000000 +0200
-+++ wmmon.app/wmmon/wmmon.c 2004-05-22 04:29:39.000000000 +0200
-@@ -187,8 +187,7 @@
-
- void update_stat_cpu(stat_dev *);
- void update_stat_io(stat_dev *);
--void update_stat_mem(stat_dev *st, stat_dev *st2);
--void update_stat_swp(stat_dev *);
-+void update_stat_mem_k26(stat_dev *st, stat_dev *st2);
-
- void wmmon_routine(int argc, char **argv) {
-
-@@ -297,8 +296,7 @@
- update_stat_io(&stat_device[1]);
-
- if(stat_current == 2) {
-- update_stat_mem(&stat_device[2], &stat_device[3]);
--// update_stat_swp(&stat_device[3]);
-+ update_stat_mem_k26(&stat_device[2], &stat_device[3]);
- }
-
- if (stat_current < 2) {
-@@ -497,47 +495,56 @@
- st->hisaddcnt += 1;
- }
-
--void update_stat_mem(stat_dev *st, stat_dev *st2) {
-+void update_stat_mem_k26(stat_dev *st, stat_dev *st2) {
-
- char temp[128];
-- unsigned long free, shared, buffers, cached;
-+ unsigned long free, shared, buffers, cached, swap_free;
-
- freopen("/proc/meminfo", "r", fp_meminfo);
- while (fgets(temp, 128, fp_meminfo)) {
-- if (strstr(temp, "Mem:")) {
-- sscanf(temp, "Mem: %ld %ld %ld %ld %ld %ld",
-- &st->rt_idle, &st->rt_stat,
-- &free, &shared, &buffers, &cached);
-- st->rt_idle >>= 10;
-- st->rt_stat -= buffers+cached;
-- st->rt_stat >>= 10;
--// break;
-+ if (strstr(temp, "MemTotal:")) {
-+ sscanf(temp, "MemTotal: %ld", &st->rt_idle);
-+ continue;
- }
-- if (strstr(temp, "Swap:")) {
-- sscanf(temp, "Swap: %ld %ld", &st2->rt_idle, &st2->rt_stat);
-- st2->rt_idle >>= 10;
-- st2->rt_stat >>= 10;
-- break;
-+ if (strstr(temp, "MemFree:")) {
-+ sscanf(temp, "MemFree: %ld", &free);
-+ continue;
-+ }
-+ if (strstr(temp, "Buffers:")) {
-+ sscanf(temp, "Buffers: %ld", &buffers);
-+ continue;
-+ }
-+ if (strstr(temp, "Cached:")) {
-+ sscanf(temp, "Cached: %ld", &cached);
-+ continue;
-+ }
-+
-+ if (strstr(temp, "SwapTotal:")) {
-+ sscanf(temp, "SwapTotal: %ld", &st2->rt_idle);
-+ continue;
-+ }
-+ if (strstr(temp, "SwapFree:")) {
-+ sscanf(temp, "SwapFree: %ld", &swap_free);
-+ continue;
- }
- }
--}
-
--void update_stat_swp(stat_dev *st) {
-+ // used = total - free;
-+ st->rt_stat = st->rt_idle - free;
-+ st2->rt_stat = st2->rt_idle - swap_free;
-
-- char temp[128];
-+ // ignore shared
-+ shared = 0;
-
-- fseek(fp_meminfo, 0, SEEK_SET);
-- while (fgets(temp, 128, fp_meminfo)) {
-- if (strstr(temp, "Swap:")) {
-- sscanf(temp, "Swap: %ld %ld", &st->rt_idle, &st->rt_stat);
-- st->rt_idle >>= 10;
-- st->rt_stat >>= 10;
-- break;
-- }
-- }
-+ st->rt_idle >>= 10;
-+ st->rt_stat -= buffers+cached;
-+ st->rt_stat >>= 10;
-
-+ st2->rt_idle >>= 10;
-+ st2->rt_stat >>= 10;
- }
-
-+
- /*******************************************************************************\
- |* get_statistics *|
- \*******************************************************************************/
diff --git a/x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch b/x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch
new file mode 100644
index 000000000000..c7633ad7388b
--- /dev/null
+++ b/x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch
@@ -0,0 +1,20 @@
+--- wmmon/Makefile.orig 2012-03-29 13:17:39.380764054 +0200
++++ wmmon/Makefile 2012-03-29 13:18:06.623931767 +0200
+@@ -6,14 +6,14 @@
+ ../wmgeneral/list.o
+
+ CFLAGS = -O2
+-CC = cc $(CFLAGS)
++CC = cc
+
+
+ .c.o:
+- $(CC) -c -Wall $< -o $*.o
++ $(CC) $(CFLAGS) -c -Wall $< -o $*.o
+
+ wmmon: $(OBJS)
+- $(CC) -o wmmon $^ $(LIBDIR) $(LIBS)
++ $(CC) $(LDFLAGS) -o wmmon $^ $(LIBDIR) $(LIBS)
+
+ debug: CFLAGS = -g3
+ debug: wmmon
diff --git a/x11-plugins/wmmon/wmmon-1.2_beta1.ebuild b/x11-plugins/wmmon/wmmon-1.2_beta1.ebuild
new file mode 100644
index 000000000000..83d7b951f73b
--- /dev/null
+++ b/x11-plugins/wmmon/wmmon-1.2_beta1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmon/wmmon-1.2_beta1.ebuild,v 1.1 2012/03/29 11:28:04 voyageur Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dockable system resources monitor applet for WindowMaker"
+HOMEPAGE="http://repo.or.cz/w/dockapps.git"
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P/_beta/b}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/${P/_beta/b}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" -C ${PN}
+}
+
+src_install () {
+ dobin wmmon/wmmon
+ doman wmmon/wmmon.1
+ dodoc BUGS CHANGES HINTS README TODO
+}