summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-05-19 19:11:04 +0000
committerDane Smith <c1pher@gentoo.org>2011-05-19 19:11:04 +0000
commit2cd6e11c6ca2ee6e8f1b45cff17482256e192129 (patch)
tree3dce55876aeaed0df83f693a1a1223de7cd98942 /x11-plugins
parentAdd perl-5.14.0 as provider. Change version scheme. Force stable keywords (diff)
downloadgentoo-2-2cd6e11c6ca2ee6e8f1b45cff17482256e192129.tar.gz
gentoo-2-2cd6e11c6ca2ee6e8f1b45cff17482256e192129.tar.bz2
gentoo-2-2cd6e11c6ca2ee6e8f1b45cff17482256e192129.zip
x11-plugins/wmlpq: Revbump. Fix respect for toolchain. Fix respect for LDFLAGS wrt bug 351012.
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmlpq/ChangeLog13
-rw-r--r--x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch30
-rw-r--r--x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild4
-rw-r--r--x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild44
4 files changed, 87 insertions, 4 deletions
diff --git a/x11-plugins/wmlpq/ChangeLog b/x11-plugins/wmlpq/ChangeLog
index f17d64e5e22c..e6dc37aca48d 100644
--- a/x11-plugins/wmlpq/ChangeLog
+++ b/x11-plugins/wmlpq/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-plugins/wmlpq
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/ChangeLog,v 1.8 2009/01/16 16:21:10 s4t4n Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/ChangeLog,v 1.9 2011/05/19 19:11:04 c1pher Exp $
+
+*wmlpq-0.2.1-r2 (19 May 2011)
+
+ 19 May 2011; Dane Smith <c1pher@gentoo.org> +wmlpq-0.2.1-r2.ebuild,
+ +files/wmlpq-makefile-ldflags.patch:
+ QA: Revision bump. Add new patch.
+ New patch allows for fixing of toolchain respect which is then used in -r2.
+ The new revision also respects LDFLAGS wrt bug 351012.
+ Update copyright lines.
16 Jan 2009; Michele Noberasco <s4t4n@gentoo.org> wmlpq-0.2.1-r1.ebuild,
files/wmlpq-makefile.patch:
diff --git a/x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch b/x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch
new file mode 100644
index 000000000000..308e7f4e687e
--- /dev/null
+++ b/x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch
@@ -0,0 +1,30 @@
+--- /Makefile.orig 2009-01-16 17:01:47.000000000 +0100
++++ /Makefile 2009-01-16 17:04:18.000000000 +0100
+@@ -2,11 +2,11 @@
+ CPPFLAGS = -I/usr/X11R6/include -I/usr/local/include
+ LIBS = -lXpm -lX11 -ldockapp
+ LDFLAGS = -L/usr/X11R6/lib -L/usr/local/lib
+-CFLAGS = -O2 -Wall
++CFLAGS = -Wall
+ DFLAGS = -ggdb3 -Wall
++DESTDIR = /usr/bin/
+
+ wmlpq: wmlpq.c wmlpq-master.xpm
+- cc $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) -o wmlpq $(LIBS) wmlpq.c
++ $(CC) $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) wmlpq.c -o wmlpq $(LIBS)
+- strip wmlpq
+
+ debug: wmlpq.c wmlpq-master.xpm
+@@ -18,10 +19,8 @@
+ rm -f wmlpq
+
+ install: wmlpq
+- cp -f wmlpq /usr/local/bin/
+- chmod 755 /usr/local/bin/wmlpq
+- cp -f wmlpq.1x /usr/local/man/man1/
+- chmod 644 /usr/local/man/man1/wmlpq.1x
++ cp -f wmlpq ${DESTDIR}
++ chmod 755 ${DESTDIR}/wmlpq
+
+ install-debian: wmlpq
+ cp -f wmlpq $(prefix)/usr/X11R6/bin/
diff --git a/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild b/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
index 55a676b8c5a1..2e095fd436a2 100644
--- a/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
+++ b/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild,v 1.3 2009/01/16 16:21:10 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild,v 1.4 2011/05/19 19:11:04 c1pher Exp $
inherit eutils
diff --git a/x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild b/x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..4e01c3667a15
--- /dev/null
+++ b/x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild,v 1.1 2011/05/19 19:11:04 c1pher Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+IUSE=""
+
+DESCRIPTION="Windowmaker dockapp which monitors up to 5 printqueues"
+SRC_URI="http://www.ur.uklinux.net/wmlpq/dl/wmlpq_0.2.1.tar.gz"
+HOMEPAGE="http://www.ur.uklinux.net/wmlpq/"
+
+DEPEND="x11-libs/libdockapp"
+
+RDEPEND=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86"
+
+src_unpack()
+{
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-makefile-ldflags.patch"
+}
+
+src_compile()
+{
+ append-ldflags "-L/usr/X11R6/lib -L/usr/local/lib"
+ emake CC=$(tc-getCC) LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install()
+{
+ dodir /usr/bin || die
+ emake DESTDIR="${D}/usr/bin" install || die "Installation failed"
+
+ dodoc README sample.wmlpqrc || die
+ newman wmlpq.1x wmlpq.1 || die
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}/${PN}.desktop" || die
+}