summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-06-29 09:09:41 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-06-29 09:09:41 +0000
commit5004c1c3c6c9fd826c4abd9fb534893672b5d73c (patch)
treef4210170bb3b3650e987b6664168ae997a6d2727 /x11-plugins/wmpeople
parentInitial import; #55486 (Manifest recommit) (diff)
downloadgentoo-2-5004c1c3c6c9fd826c4abd9fb534893672b5d73c.tar.gz
gentoo-2-5004c1c3c6c9fd826c4abd9fb534893672b5d73c.tar.bz2
gentoo-2-5004c1c3c6c9fd826c4abd9fb534893672b5d73c.zip
initial import of x11-plugins/wmpeople
Diffstat (limited to 'x11-plugins/wmpeople')
-rw-r--r--x11-plugins/wmpeople/ChangeLog8
-rw-r--r--x11-plugins/wmpeople/Manifest4
-rw-r--r--x11-plugins/wmpeople/files/digest-wmpeople-1.21
-rw-r--r--x11-plugins/wmpeople/metadata.xml5
-rw-r--r--x11-plugins/wmpeople/wmpeople-1.2.ebuild37
5 files changed, 55 insertions, 0 deletions
diff --git a/x11-plugins/wmpeople/ChangeLog b/x11-plugins/wmpeople/ChangeLog
new file mode 100644
index 000000000000..2548c8485d9e
--- /dev/null
+++ b/x11-plugins/wmpeople/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for x11-plugins/wmpeople
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpeople/ChangeLog,v 1.1 2004/06/29 09:09:41 s4t4n Exp $
+
+*wmpeople-1.2 (29 Jun 2004)
+
+ 29 Jun 2004; Michele Noberasco <s4t4n@gentoo.org> wmpeople-1.2.ebuild:
+ Initial import.
diff --git a/x11-plugins/wmpeople/Manifest b/x11-plugins/wmpeople/Manifest
new file mode 100644
index 000000000000..300f1feb6fcb
--- /dev/null
+++ b/x11-plugins/wmpeople/Manifest
@@ -0,0 +1,4 @@
+MD5 854bb0f46f37e16adc1615c037518fef wmpeople-1.2.ebuild 882
+MD5 9911bf59033ae85abc6484ef4f5ce224 ChangeLog 241
+MD5 62ba71d3b2fa785a4cbd5d47fdbd0eb6 metadata.xml 165
+MD5 83b57b77cf974f19f425edef563078fe files/digest-wmpeople-1.2 64
diff --git a/x11-plugins/wmpeople/files/digest-wmpeople-1.2 b/x11-plugins/wmpeople/files/digest-wmpeople-1.2
new file mode 100644
index 000000000000..3e8b71ee512d
--- /dev/null
+++ b/x11-plugins/wmpeople/files/digest-wmpeople-1.2
@@ -0,0 +1 @@
+MD5 acc1cb1933a6635e547b5b8d3098866a wmpeople-1.2.tar.gz 108551
diff --git a/x11-plugins/wmpeople/metadata.xml b/x11-plugins/wmpeople/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmpeople/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmpeople/wmpeople-1.2.ebuild b/x11-plugins/wmpeople/wmpeople-1.2.ebuild
new file mode 100644
index 000000000000..019e1ce8f068
--- /dev/null
+++ b/x11-plugins/wmpeople/wmpeople-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpeople/wmpeople-1.2.ebuild,v 1.1 2004/06/29 09:09:41 s4t4n Exp $
+
+inherit eutils
+
+DESCRIPTION="Nice, highly configurable WMaker DockApp that monitors your mail boxes"
+HOMEPAGE="http://peephole.sourceforge.net/"
+SRC_URI="mirror://sourceforge/peephole/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+# This program supports the nptl, but there is no need
+# for ebuild code to enable it...
+IUSE="nptl"
+
+DEPEND="
+ virtual/x11
+ >=net-mail/peephole-1.2"
+
+src_install()
+{
+ einstall || die "Installation failed"
+ dodoc AUTHORS COPYING ChangeLog README
+}
+
+pkg_postinst()
+{
+ einfo "Before you can use wmpeople you must copy"
+ einfo "/etc/skel/.wmpeoplerc to your home dir"
+ einfo "and edit it to suit your needs."
+ einfo "Also, make sure that the peephole daemon"
+ einfo "is up and running before you start wmpeople."
+ sleep 5
+}