summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-02-16 09:22:02 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-02-16 09:22:02 +0000
commit7895cc8de650cded203e10e1613e29cd34130fe7 (patch)
tree1cf332b6b89abd72d8fb95fb5ce7e98905182b0e /x11-plugins/wmmemfree
parentx86 stable, security bug #209133 (diff)
downloadgentoo-2-7895cc8de650cded203e10e1613e29cd34130fe7.tar.gz
gentoo-2-7895cc8de650cded203e10e1613e29cd34130fe7.tar.bz2
gentoo-2-7895cc8de650cded203e10e1613e29cd34130fe7.zip
Revision bump, with patch to fix a floating point exception
when there is no swap on the system. (Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins/wmmemfree')
-rw-r--r--x11-plugins/wmmemfree/ChangeLog14
-rw-r--r--x11-plugins/wmmemfree/files/wmmemfree-0.7-fix-crash-when-there-is-no-swap.patch18
-rw-r--r--x11-plugins/wmmemfree/wmmemfree-0.7-r2.ebuild38
3 files changed, 65 insertions, 5 deletions
diff --git a/x11-plugins/wmmemfree/ChangeLog b/x11-plugins/wmmemfree/ChangeLog
index 8efbe0732a3f..4dc2fb3fc5aa 100644
--- a/x11-plugins/wmmemfree/ChangeLog
+++ b/x11-plugins/wmmemfree/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmmemfree
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmemfree/ChangeLog,v 1.12 2008/01/15 08:11:47 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmemfree/ChangeLog,v 1.13 2008/02/16 09:22:01 s4t4n Exp $
+
+*wmmemfree-0.7-r2 (16 Feb 2008)
+
+ 16 Feb 2008; Michele Noberasco <s4t4n@gentoo.org> wmmemfree-0.7-r2.ebuild:
+ New revision trivial patch to fix floating point exception when there is no swap
+ on the system. See bug #210300. Stable for x86 since the patch is trivial.
15 Jan 2008; Samuli Suominen <drac@gentoo.org> wmmemfree-0.7-r1.ebuild:
Stop pre-stripping wmmemfree binary during src_compile and keyword ~amd64.
@@ -34,15 +40,13 @@
wmmemfree-0.7-r1.ebuild, wmmemfree-0.7.ebuild:
Masked wmmemfree-0.7.ebuild stable for ppc
-*wmmemfree-0.7-r1 (02 Sep 2004)
-
02 Sep 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
wmmemfree-0.7-r1.ebuild:
Masked wmmemfree-0.7-r1.ebuild stable for ppc
-*wmmemfree-0.7-1 (28 Aug 2004)
+*wmmemfree-0.7-r1 (28 Aug 2004)
- 28 Aug 2004; Michele Noberasco <s4t4n@gentoo.org> wmmemfree-0.7-1.ebuild:
+ 28 Aug 2004; Michele Noberasco <s4t4n@gentoo.org> wmmemfree-0.7-r1.ebuild:
New revision with 2.6 kernel support...
04 Jul 2004; David Holm <dholm@gentoo.org> wmmemfree-0.7.ebuild:
diff --git a/x11-plugins/wmmemfree/files/wmmemfree-0.7-fix-crash-when-there-is-no-swap.patch b/x11-plugins/wmmemfree/files/wmmemfree-0.7-fix-crash-when-there-is-no-swap.patch
new file mode 100644
index 000000000000..06aea65052fa
--- /dev/null
+++ b/x11-plugins/wmmemfree/files/wmmemfree-0.7-fix-crash-when-there-is-no-swap.patch
@@ -0,0 +1,18 @@
+--- wmmemfree-0.7/draw.c 2003-03-21 21:56:25.000000000 +0100
++++ wmmemfree-0.7/draw.c 2008-02-16 10:02:51.000000000 +0100
+@@ -44,13 +44,13 @@
+ XCopyArea(display, on, buffer, gc, 0, 0, 2, 11, 7 + n * 2, 27);
+ else
+ XCopyArea(display, off, buffer, gc, 0, 0, 2, 11, 7 + n * 2, 27);
+- if(n < (swp * 25 / swp_total))
++ if(n < (swp_total) ? (swp * 25 / swp_total) : 0)
+ XCopyArea(display, on, buffer, gc, 0, 0, 2, 11, 7 + n * 2, 47);
+ else
+ XCopyArea(display, off, buffer, gc, 0, 0, 2, 11, 7 + n * 2, 47);
+ }
+ mem_percent = mem * 100 / mem_total;
+- swp_percent = swp * 100 / swp_total;
++ swp_percent = (swp_total) ? swp * 100 / swp_total : 0;
+ if(mem_percent == 100)
+ XCopyArea(display, numbers, buffer, gc, 5, 0, 5, 6, 33, 20);
+ else
diff --git a/x11-plugins/wmmemfree/wmmemfree-0.7-r2.ebuild b/x11-plugins/wmmemfree/wmmemfree-0.7-r2.ebuild
new file mode 100644
index 000000000000..9102e39d763b
--- /dev/null
+++ b/x11-plugins/wmmemfree/wmmemfree-0.7-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmemfree/wmmemfree-0.7-r2.ebuild,v 1.1 2008/02/16 09:22:01 s4t4n Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a blue memory monitoring dockapp."
+HOMEPAGE="http://misuceldestept.go.ro/wmmemfree"
+SRC_URI="http://ibiblio.org/pub/linux/X11/xutils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-add-kernel-26-support.patch
+ epatch "${FILESDIR}"/${P}-fix-crash-when-there-is-no-swap.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" FLAGS="${CFLAGS}" \
+ STRIP="true" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc ChangeLog README THANKS TODO WMS
+}