summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2009-04-28 14:41:17 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2009-04-28 14:41:17 +0000
commit9eb89c27d338a1409404346cbc3136f94f1eca38 (patch)
tree8fb0141ab39ab28562dfc9235eafeea13f44874e /x11-plugins/wmdl
parentsh stable (diff)
downloadgentoo-2-9eb89c27d338a1409404346cbc3136f94f1eca38.tar.gz
gentoo-2-9eb89c27d338a1409404346cbc3136f94f1eca38.tar.bz2
gentoo-2-9eb89c27d338a1409404346cbc3136f94f1eca38.zip
Reworked patch so that CC is no longer hardcoded, bug #215651.
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/wmdl')
-rw-r--r--x11-plugins/wmdl/ChangeLog5
-rw-r--r--x11-plugins/wmdl/files/makefile.diff14
-rw-r--r--x11-plugins/wmdl/wmdl-1.4.1.ebuild4
3 files changed, 13 insertions, 10 deletions
diff --git a/x11-plugins/wmdl/ChangeLog b/x11-plugins/wmdl/ChangeLog
index a43b2afab42e..d2c0fa15e4bf 100644
--- a/x11-plugins/wmdl/ChangeLog
+++ b/x11-plugins/wmdl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmdl
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdl/ChangeLog,v 1.12 2008/11/28 18:49:48 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdl/ChangeLog,v 1.13 2009/04/28 14:41:17 s4t4n Exp $
+
+ 28 Ape 2009; Michele Noberasco <tcunha@gentoo.org> files/makefile.diff:
+ Reworked patch so that CC is no longer hardcoded, bug #215651.
28 Nov 2008; Tiago Cunha <tcunha@gentoo.org> wmdl-1.4.1.ebuild:
stable sparc, bug 215651
diff --git a/x11-plugins/wmdl/files/makefile.diff b/x11-plugins/wmdl/files/makefile.diff
index 8081263b1f0d..90491b7a93e9 100644
--- a/x11-plugins/wmdl/files/makefile.diff
+++ b/x11-plugins/wmdl/files/makefile.diff
@@ -1,7 +1,7 @@
diff -urN wmdl-1.4.1/Makefile wmdl-1.4.1-modified/Makefile
---- wmdl-1.4.1/Makefile 1999-11-14 12:56:47.000000000 -0600
-+++ wmdl-1.4.1-modified/Makefile 2002-10-04 10:11:42.000000000 -0500
-@@ -1,12 +1,7 @@
+--- Makefile 2009-04-28 16:34:24.000000000 +0200
++++ Makefile.new 2009-04-28 16:33:55.000000000 +0200
+@@ -1,23 +1,14 @@
-INCLUDES = -I/usr/include \
- -I/usr/local/include \
@@ -17,19 +17,19 @@ diff -urN wmdl-1.4.1/Makefile wmdl-1.4.1-modified/Makefile
PIXMAPINC = -I./images
-@@ -14,10 +9,8 @@
+ LIBS = -lm -lX11 -lXpm -lXext
- CC=gcc
+-CC=gcc
-#CC=cc
-
+-
-#CFLAGS= -g --verbose
-CFLAGS= -g
+FLAGS=${CFLAGS}
TARGET=wmdl
SOURCE=wmdl.c
-@@ -25,10 +18,10 @@
+@@ -25,10 +16,10 @@
all: ${TARGET}
${TARGET}: ${SOURCE}
diff --git a/x11-plugins/wmdl/wmdl-1.4.1.ebuild b/x11-plugins/wmdl/wmdl-1.4.1.ebuild
index 32af67233cde..c6f490b420b9 100644
--- a/x11-plugins/wmdl/wmdl-1.4.1.ebuild
+++ b/x11-plugins/wmdl/wmdl-1.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdl/wmdl-1.4.1.ebuild,v 1.16 2008/11/28 18:49:48 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdl/wmdl-1.4.1.ebuild,v 1.17 2009/04/28 14:41:17 s4t4n Exp $
inherit eutils