summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-14 10:21:49 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-14 10:21:49 +0000
commitb73b7cd6683bd84d4eceda099398d8e213bbb7c4 (patch)
tree218e85ac0f0ae4d0a38ac5eae4109db39795dd16 /x11-plugins/wmauda
parentUntil newer baselayout stabilizes, only use config() when it exists #203906. (diff)
downloadgentoo-2-b73b7cd6683bd84d4eceda099398d8e213bbb7c4.tar.gz
gentoo-2-b73b7cd6683bd84d4eceda099398d8e213bbb7c4.tar.bz2
gentoo-2-b73b7cd6683bd84d4eceda099398d8e213bbb7c4.zip
Check for use dbus in audacious, needed both compile and runtime. Depend on pkg-config wrt #205084.
(Portage version: 2.1.4)
Diffstat (limited to 'x11-plugins/wmauda')
-rw-r--r--x11-plugins/wmauda/ChangeLog8
-rw-r--r--x11-plugins/wmauda/wmauda-0.7.ebuild35
2 files changed, 29 insertions, 14 deletions
diff --git a/x11-plugins/wmauda/ChangeLog b/x11-plugins/wmauda/ChangeLog
index adb9eedee8a0..bb41c4a3d40b 100644
--- a/x11-plugins/wmauda/ChangeLog
+++ b/x11-plugins/wmauda/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmauda
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/ChangeLog,v 1.9 2007/11/10 17:45:49 joker Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/ChangeLog,v 1.10 2008/01/14 10:21:49 drac Exp $
+
+ 14 Jan 2008; Samuli Suominen <drac@gentoo.org> wmauda-0.7.ebuild:
+ Check for use dbus in audacious, needed both compile and runtime. Depend on
+ pkg-config wrt #205084.
10 Nov 2007; Christian Birchinger <joker@gentoo.org> wmauda-0.7.ebuild:
Remove built-with dbus check because Audacious has a hard dependency on it now.
diff --git a/x11-plugins/wmauda/wmauda-0.7.ebuild b/x11-plugins/wmauda/wmauda-0.7.ebuild
index 5e9b00e88597..0b4db04db56c 100644
--- a/x11-plugins/wmauda/wmauda-0.7.ebuild
+++ b/x11-plugins/wmauda/wmauda-0.7.ebuild
@@ -1,26 +1,37 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/wmauda-0.7.ebuild,v 1.2 2007/11/10 17:45:49 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/wmauda-0.7.ebuild,v 1.3 2008/01/14 10:21:49 drac Exp $
-IUSE=""
+inherit eutils toolchain-funcs
DESCRIPTION="Dockable applet for WindowMaker that controls Audacious."
+HOMEPAGE="http://www.netswarm.net"
SRC_URI="http://www.netswarm.net/misc/${P}.tar.gz"
-HOMEPAGE="http://www.netswarm.net/"
-
-DEPEND="=x11-libs/gtk+-2*
- dev-libs/dbus-glib
- >=media-sound/audacious-1.4"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/dbus-glib
+ x11-libs/libX11
+ >=x11-libs/gtk+-2
+ >=media-sound/audacious-1.4"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ built_with_use media-sound/audacious dbus || \
+ die "needs media-sound/audacious with USE dbus."
+}
src_compile() {
- emake || die
+ tc-export CC
+ emake || die "emake failed."
}
src_install () {
- make DESTDIR="${D}" PREFIX="/usr" install || die "make install failed"
- dodoc README AUTHORS
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed."
+ dodoc AUTHORS README
}