summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-01-07 21:49:56 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-01-07 21:49:56 +0000
commit900b8077d96a0e1803e23f80947213ea7608bd25 (patch)
tree8ba865576f2de9ff52b16f1f8d1d5ff0123a1f8c /x11-plugins/hexchat-javascript
parentadded some prefix keywords (tested by me) (diff)
downloadgentoo-2-900b8077d96a0e1803e23f80947213ea7608bd25.tar.gz
gentoo-2-900b8077d96a0e1803e23f80947213ea7608bd25.tar.bz2
gentoo-2-900b8077d96a0e1803e23f80947213ea7608bd25.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-plugins/hexchat-javascript')
-rw-r--r--x11-plugins/hexchat-javascript/ChangeLog10
-rw-r--r--x11-plugins/hexchat-javascript/hexchat-javascript-0.3.1.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/x11-plugins/hexchat-javascript/ChangeLog b/x11-plugins/hexchat-javascript/ChangeLog
index 162e4197ec9c..d01e4f42d885 100644
--- a/x11-plugins/hexchat-javascript/ChangeLog
+++ b/x11-plugins/hexchat-javascript/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/hexchat-javascript
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/hexchat-javascript/ChangeLog,v 1.2 2013/09/12 10:34:25 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/hexchat-javascript/ChangeLog,v 1.3 2014/01/07 21:49:56 hasufell Exp $
+
+*hexchat-javascript-0.3.1 (07 Jan 2014)
+
+ 07 Jan 2014; Julian Ospald <hasufell@gentoo.org>
+ +hexchat-javascript-0.3.1.ebuild:
+ version bump
12 Sep 2013; Julian Ospald <hasufell@gentoo.org>
hexchat-javascript-0.3.ebuild:
diff --git a/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.1.ebuild b/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.1.ebuild
new file mode 100644
index 000000000000..ef239c19aedb
--- /dev/null
+++ b/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.1.ebuild,v 1.1 2014/01/07 21:49:56 hasufell Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Javascript interface for HexChat"
+HOMEPAGE="https://github.com/TingPing/hexchat-javascript"
+SRC_URI="https://github.com/TingPing/hexchat-javascript/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-lang/spidermonkey
+ >=net-irc/hexchat-2.9.6[plugins]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-export CXX PKG_CONFIG
+ fi
+}
+
+src_install() {
+ default
+ if use examples ; then
+ dodoc -r examples
+ fi
+}