summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-16 21:59:01 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-16 21:59:01 +0000
commit8c820cdeec5fd2a4681c8132b56812eb1664e3f0 (patch)
tree7b2abe0cdfee2f1db2f979f59c5bd2910c4e6f30 /x11-plugins/gkrellshoot/gkrellshoot-0.3.2.ebuild
parentmasked old version of gkrellshoot (diff)
downloadgentoo-2-8c820cdeec5fd2a4681c8132b56812eb1664e3f0.tar.gz
gentoo-2-8c820cdeec5fd2a4681c8132b56812eb1664e3f0.tar.bz2
gentoo-2-8c820cdeec5fd2a4681c8132b56812eb1664e3f0.zip
version bumps
Diffstat (limited to 'x11-plugins/gkrellshoot/gkrellshoot-0.3.2.ebuild')
-rw-r--r--x11-plugins/gkrellshoot/gkrellshoot-0.3.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/gkrellshoot/gkrellshoot-0.3.2.ebuild b/x11-plugins/gkrellshoot/gkrellshoot-0.3.2.ebuild
new file mode 100644
index 000000000000..4dec2ab2fb64
--- /dev/null
+++ b/x11-plugins/gkrellshoot/gkrellshoot-0.3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellshoot/gkrellshoot-0.3.2.ebuild,v 1.1 2002/10/16 21:59:01 seemant Exp $
+
+S=${WORKDIR}/${P/s/S}
+DESCRIPTION="A GKrellM plugin to snap screenshots."
+SRC_URI="mirror://sourceforge/gkrellshoot/${P}.tar.gz"
+HOMEPAGE="http://gkrellshoot.sf.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="=app-admin/gkrellm-1.2*
+ >=media-libs/imlib-1.9.10-r1"
+
+# It uses "import" which comes with imagemagick to snap the screenshots
+RDEPEND="media-gfx/imagemagick"
+
+src_compile() {
+ export CFLAGS="${CFLAGS/-O?/}"
+ emake || die
+}
+
+src_install () {
+ insinto /usr/lib/gkrellm/plugins
+ doins gkrellshoot.so
+ dodoc ChangeLog README
+}