summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2005-06-23 20:59:40 +0000
committerJonathan Smith <smithj@gentoo.org>2005-06-23 20:59:40 +0000
commit73eaa5c2ad82a565fbe335191826d662bed576b3 (patch)
tree66450ff18fc7eb219bb659539c683bdb55eacb18 /x11-misc
parentadded pdf use for x11-misc/openclipart (diff)
downloadgentoo-2-73eaa5c2ad82a565fbe335191826d662bed576b3.tar.gz
gentoo-2-73eaa5c2ad82a565fbe335191826d662bed576b3.tar.bz2
gentoo-2-73eaa5c2ad82a565fbe335191826d662bed576b3.zip
initial commit for #62278; thanks to Stefan Briesenick <sbriesen@gentoo.org> for the ebuild
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/openclipart/ChangeLog11
-rw-r--r--x11-misc/openclipart/Manifest3
-rw-r--r--x11-misc/openclipart/files/digest-openclipart-0.121
-rw-r--r--x11-misc/openclipart/metadata.xml8
-rw-r--r--x11-misc/openclipart/openclipart-0.12.ebuild78
5 files changed, 101 insertions, 0 deletions
diff --git a/x11-misc/openclipart/ChangeLog b/x11-misc/openclipart/ChangeLog
new file mode 100644
index 000000000000..4fb73a2249fc
--- /dev/null
+++ b/x11-misc/openclipart/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/openclipart
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/openclipart/ChangeLog,v 1.1 2005/06/23 20:59:40 smithj Exp $
+
+*openclipart-0.12 (23 Jun 2005)
+
+ 23 Jun 2005; Jonathan Smith <smithj@gentoo.org> +metadata.xml,
+ +openclipart-0.12.ebuild:
+ initial commit for #62278; thanks to Stefan Briesenick <sbriesen@gentoo.org>
+ for the ebuild
+
diff --git a/x11-misc/openclipart/Manifest b/x11-misc/openclipart/Manifest
new file mode 100644
index 000000000000..1b93e5e5de25
--- /dev/null
+++ b/x11-misc/openclipart/Manifest
@@ -0,0 +1,3 @@
+MD5 1784611faaaef2b8d0816e55c27de113 openclipart-0.12.ebuild 1863
+MD5 8dad4c602e8fc48cf21cf32d762b9af0 metadata.xml 231
+MD5 9ae01cef1127f8736b4ad6c8f1cb15bb files/digest-openclipart-0.12 71
diff --git a/x11-misc/openclipart/files/digest-openclipart-0.12 b/x11-misc/openclipart/files/digest-openclipart-0.12
new file mode 100644
index 000000000000..94468f83f0fb
--- /dev/null
+++ b/x11-misc/openclipart/files/digest-openclipart-0.12
@@ -0,0 +1 @@
+MD5 20045090a5238662f6ac8ab2062539c6 openclipart-0.12.tar.bz2 37074521
diff --git a/x11-misc/openclipart/metadata.xml b/x11-misc/openclipart/metadata.xml
new file mode 100644
index 000000000000..72335b4f9bac
--- /dev/null
+++ b/x11-misc/openclipart/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-misc</herd>
+<maintainer>
+<email>desktop-misc@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-misc/openclipart/openclipart-0.12.ebuild b/x11-misc/openclipart/openclipart-0.12.ebuild
new file mode 100644
index 000000000000..f0c592ca424b
--- /dev/null
+++ b/x11-misc/openclipart/openclipart-0.12.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/openclipart/openclipart-0.12.ebuild,v 1.1 2005/06/23 20:59:40 smithj Exp $
+
+inherit eutils
+
+DESCRIPTION="Open Clip Art Library (openclipart.org)"
+HOMEPAGE="http://www.openclipart.org/"
+SRC_URI="http://www.openclipart.org/downloads/${PV}/${P}.tar.bz2"
+
+LICENSE="public-domain" # creative commons
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc svg png pdf wmf gzip"
+
+# we don't really need anything to run, but compression is optionally needed
+DEPEND=""
+RDEPEND=""
+
+# suggested basedir for cliparts
+CLIPART="/usr/share/clipart/${PN}"
+
+select_files() {
+ # select wanted formats, optionally compress them
+
+ local FILE SVG="" PNG="" PDF="" DOC="" COMPRESS=""
+ use svg && SVG="svg"
+ use png && PNG="png"
+ use pdf && PDF="pdf"
+ use wmf && WMF="wmf"
+ use doc && DOC="doc"
+ use gzip && COMPRESS="yes"
+
+ find "$1" -type f -mindepth 1 -maxdepth 1 | while read FILE
+ do
+ local NAME="${FILE%.*}" EXT="${FILE//*.}" YES=0
+ if [ -n "$EXT" ]
+ then
+ if [ "$SVG" = "$EXT" -o "$PNG" = "$EXT" -o "$PDF" = "$EXT" -o "$WMF" = "$EXT" ]
+ then
+ if [ "$SVG" = "$EXT" -a -n "$COMPRESS" ] # compress SVG
+ then
+ gzip -9 < "${FILE}" > "${FILE}z" && echo "${FILE}z"
+ else
+ echo "${FILE}"
+ fi
+ if [ -n "$DOC" -a -f "${NAME}.txt" ] # if clipart has a description ...
+ then
+ gzip -9 "${NAME}.txt" && echo "${NAME}.txt.gz" # ... then compress it always
+ fi
+ YES=1
+ fi
+ fi
+ if [ $YES -eq 1 -a -f "${1}/README" ]
+ then
+ gzip -9 "${1}/README" && echo "${1}/README.gz"
+ fi
+ done | sort -u # kill dupes
+}
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ local DIR FILES
+ dodoc LICENSE.txt README.txt
+ find -type d | sort | while read DIR
+ do
+ FILES=$(select_files "$DIR")
+ if [ -n "${FILES}" ]
+ then
+ einfo "Installing ${DIR#*/}"
+ insinto "${CLIPART}/${DIR#*/}"
+ doins ${FILES}
+ fi
+ done
+}