summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-10-08 02:57:22 +0000
committerAron Griffis <agriffis@gentoo.org>2004-10-08 02:57:22 +0000
commit055e9cc5be08ba5644fbf0cd38333112d416b61a (patch)
treebc8bf50c58a9b5708d4cb9b5e48251c9ef24eab8 /x11-misc
parentia64 stable #66667 (Manifest recommit) (diff)
downloadgentoo-2-055e9cc5be08ba5644fbf0cd38333112d416b61a.tar.gz
gentoo-2-055e9cc5be08ba5644fbf0cd38333112d416b61a.tar.bz2
gentoo-2-055e9cc5be08ba5644fbf0cd38333112d416b61a.zip
Add xcut to portage. Thanks to Aaron Brooks for the ebuild
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xcut/ChangeLog10
-rw-r--r--x11-misc/xcut/Manifest2
-rw-r--r--x11-misc/xcut/files/digest-xcut-0.21
-rw-r--r--x11-misc/xcut/metadata.xml9
-rw-r--r--x11-misc/xcut/xcut-0.2.ebuild26
5 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/xcut/ChangeLog b/x11-misc/xcut/ChangeLog
new file mode 100644
index 000000000000..fcd77da5db10
--- /dev/null
+++ b/x11-misc/xcut/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/xcut
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcut/ChangeLog,v 1.1 2004/10/08 02:57:22 agriffis Exp $
+
+*xcut-0.2 (07 Oct 2004)
+
+ 07 Oct 2004; Aron Griffis <agriffis@gentoo.org> +metadata.xml,
+ +xcut-0.2.ebuild:
+ Add xcut to portage. Thanks to Aaron Brooks for the ebuild
+
diff --git a/x11-misc/xcut/Manifest b/x11-misc/xcut/Manifest
new file mode 100644
index 000000000000..226baaa77bf7
--- /dev/null
+++ b/x11-misc/xcut/Manifest
@@ -0,0 +1,2 @@
+MD5 33689895e37a4677a328ec0ddeeb31f8 xcut-0.2.ebuild 701
+MD5 644495c2510758999994e47464c3b54b files/digest-xcut-0.2 59
diff --git a/x11-misc/xcut/files/digest-xcut-0.2 b/x11-misc/xcut/files/digest-xcut-0.2
new file mode 100644
index 000000000000..6dc7d85a79eb
--- /dev/null
+++ b/x11-misc/xcut/files/digest-xcut-0.2
@@ -0,0 +1 @@
+MD5 557103a20f9a122a09a1c03096a6f665 xcut-0.2.tar.gz 10310
diff --git a/x11-misc/xcut/metadata.xml b/x11-misc/xcut/metadata.xml
new file mode 100644
index 000000000000..1984bf2cfe76
--- /dev/null
+++ b/x11-misc/xcut/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>agriffis@gentoo.org</email>
+ <name>Aron Griffis</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/xcut/xcut-0.2.ebuild b/x11-misc/xcut/xcut-0.2.ebuild
new file mode 100644
index 000000000000..82ed4739bd7b
--- /dev/null
+++ b/x11-misc/xcut/xcut-0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcut/xcut-0.2.ebuild,v 1.1 2004/10/08 02:57:22 agriffis Exp $
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="Commandline tool to manipulate the X11 cut and paste buffers"
+HOMEPAGE="http://xcut.sourceforge.net"
+SRC_URI="mirror://sourceforge/xcut/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11"
+
+src_compile() {
+ xmkmf || die
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR=${D} install.man || die "make install.man failed"
+ dodoc README || die "dodoc failed"
+}