summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-11-15 22:24:56 +0000
committerJeroen Roovers <jer@gentoo.org>2011-11-15 22:24:56 +0000
commit0337e932aafe1de8b6cf6cf8a97825992495fdd3 (patch)
treeb17098eb07d1de943e79918ec7399378718b5e76 /x11-misc/xfe
parentVersion bump. Fix build with recent glib. Clean up old revisions. (diff)
downloadgentoo-2-0337e932aafe1de8b6cf6cf8a97825992495fdd3.tar.gz
gentoo-2-0337e932aafe1de8b6cf6cf8a97825992495fdd3.tar.bz2
gentoo-2-0337e932aafe1de8b6cf6cf8a97825992495fdd3.zip
Version bump thanks to teidakankan (bug #377625).
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xfe')
-rw-r--r--x11-misc/xfe/ChangeLog7
-rw-r--r--x11-misc/xfe/xfe-1.32.4.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-misc/xfe/ChangeLog b/x11-misc/xfe/ChangeLog
index 184d39977fc5..456f6728cda6 100644
--- a/x11-misc/xfe/ChangeLog
+++ b/x11-misc/xfe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xfe
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.66 2011/05/27 07:21:52 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.67 2011/11/15 22:24:56 jer Exp $
+
+*xfe-1.32.4 (15 Nov 2011)
+
+ 15 Nov 2011; Jeroen Roovers <jer@gentoo.org> +xfe-1.32.4.ebuild:
+ Version bump thanks to teidakankan (bug #377625).
*xfe-1.32.3 (27 May 2011)
diff --git a/x11-misc/xfe/xfe-1.32.4.ebuild b/x11-misc/xfe/xfe-1.32.4.ebuild
new file mode 100644
index 000000000000..50510356d7c2
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.32.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.32.4.ebuild,v 1.1 2011/11/15 22:24:56 jer Exp $
+
+EAPI=4
+
+inherit base
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="x11-libs/libX11
+ media-libs/libpng
+ =x11-libs/fox-1.6*[truetype,png]
+ startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README TODO )
+PATCHES=( "${FILESDIR}"/${PN}-1.32.2-missing_Xlib_h.patch )
+
+src_prepare() {
+ base_src_prepare
+ cat >po/POTFILES.skip <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ $(use_enable debug)
+}