summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-12-13 09:18:50 +0000
committerSven Wegener <swegener@gentoo.org>2008-12-13 09:18:50 +0000
commit2301685485db000206d7954ae4c93693755f5a14 (patch)
tree0c0227c09be9c89becf61ff953210b240bc5d925 /x11-misc/x11vnc
parentFix update code. Switch over to svn repository. (diff)
downloadgentoo-2-2301685485db000206d7954ae4c93693755f5a14.tar.gz
gentoo-2-2301685485db000206d7954ae4c93693755f5a14.tar.bz2
gentoo-2-2301685485db000206d7954ae4c93693755f5a14.zip
Version bump.
(Portage version: 2.2_rc17/cvs/Linux 2.6.28-rc8 x86_64)
Diffstat (limited to 'x11-misc/x11vnc')
-rw-r--r--x11-misc/x11vnc/ChangeLog7
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.6.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/x11-misc/x11vnc/ChangeLog b/x11-misc/x11vnc/ChangeLog
index 0feac196035c..6bc2c4f35852 100644
--- a/x11-misc/x11vnc/ChangeLog
+++ b/x11-misc/x11vnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/x11vnc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.60 2008/10/25 08:55:13 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.61 2008/12/13 09:18:50 swegener Exp $
+
+*x11vnc-0.9.6 (13 Dec 2008)
+
+ 13 Dec 2008; Sven Wegener <swegener@gentoo.org> +x11vnc-0.9.6.ebuild:
+ Version bump.
*x11vnc-0.9.5 (25 Oct 2008)
diff --git a/x11-misc/x11vnc/x11vnc-0.9.6.ebuild b/x11-misc/x11vnc/x11vnc-0.9.6.ebuild
new file mode 100644
index 000000000000..7af7da660f84
--- /dev/null
+++ b/x11-misc/x11vnc/x11vnc-0.9.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.6.ebuild,v 1.1 2008/12/13 09:18:50 swegener Exp $
+
+DESCRIPTION="A VNC server for real X displays"
+HOMEPAGE="http://www.karlrunge.com/x11vnc/"
+SRC_URI="mirror://sourceforge/libvncserver/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="jpeg zlib threads ssl crypt v4l xinerama avahi system-libvncserver"
+
+RDEPEND="system-libvncserver? ( >=net-libs/libvncserver-0.9.1 )
+ zlib? ( sys-libs/zlib )
+ jpeg? ( media-libs/jpeg )
+ ssl? ( dev-libs/openssl )
+ avahi? ( >=net-dns/avahi-0.6.4 )
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/libXdamage
+ x11-libs/libXext"
+
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/inputproto
+ x11-proto/trapproto
+ x11-proto/recordproto
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_compile() {
+ local myconf=""
+
+ # we need to force threads on, because our system libvncserver gets build with thread support
+ use system-libvncserver && myconf="--with-pthread"
+
+ econf \
+ $(use_with system-libvncserver) \
+ $(use_with avahi) \
+ $(use_with xinerama) \
+ $(use_with ssl) \
+ $(use_with ssl crypto) \
+ $(use_with crypt) \
+ $(use_with v4l) \
+ $(use_with jpeg) \
+ $(use_with zlib) \
+ $(use_with threads pthread) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc x11vnc/{ChangeLog,README}
+}