summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-07-18 11:31:25 +0000
committerAlex Alexander <wired@gentoo.org>2009-07-18 11:31:25 +0000
commit2c3fe2f0ce8e36f009cbaa16da577aa7ecaee0cf (patch)
tree5a23f895b979cd489eb8b5a92e37ebc1697207ba /x11-misc/okindd
parentInsert -lm to LIBADD for forced asneeded wrt #274074. (diff)
downloadgentoo-2-2c3fe2f0ce8e36f009cbaa16da577aa7ecaee0cf.tar.gz
gentoo-2-2c3fe2f0ce8e36f009cbaa16da577aa7ecaee0cf.tar.bz2
gentoo-2-2c3fe2f0ce8e36f009cbaa16da577aa7ecaee0cf.zip
New ebuild for okindd
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/okindd')
-rw-r--r--x11-misc/okindd/ChangeLog10
-rw-r--r--x11-misc/okindd/files/okindd_home_and_naming.patch18
-rw-r--r--x11-misc/okindd/metadata.xml12
-rw-r--r--x11-misc/okindd/okindd-0.5.8.ebuild46
4 files changed, 86 insertions, 0 deletions
diff --git a/x11-misc/okindd/ChangeLog b/x11-misc/okindd/ChangeLog
new file mode 100644
index 000000000000..4688dd677fe0
--- /dev/null
+++ b/x11-misc/okindd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/okindd
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/okindd/ChangeLog,v 1.1 2009/07/18 11:31:12 wired Exp $
+
+*okindd-0.5.8 (17 Jul 2009)
+
+ 17 Jul 2009; Alex Alexander <wired@gentoo.org>
+ +okindd-0.5.8.ebuild, +files/okindd_home_and_naming.patch, +metadata.xml:
+ New ebuild for okindd
+
diff --git a/x11-misc/okindd/files/okindd_home_and_naming.patch b/x11-misc/okindd/files/okindd_home_and_naming.patch
new file mode 100644
index 000000000000..59a446235c79
--- /dev/null
+++ b/x11-misc/okindd/files/okindd_home_and_naming.patch
@@ -0,0 +1,18 @@
+--- src/src.pro.old 2009-05-25 00:55:37.369064692 +0300
++++ src/src.pro 2009-05-25 00:56:10.167178104 +0300
+@@ -6,7 +6,7 @@
+ TARGET = okindd
+ DESTDIR = ../bin
+ HEADERS += okindadapter.h
+-INSTALLS += target pics examples shortcut
++INSTALLS += target pics examples
+
+ target.path = /usr/bin/
+
+@@ -16,6 +16,3 @@
+ examples.path = /usr/share/doc/okindd/examples/
+ examples.files += ../scripts/* ../conf/okinddrc.example
+
+-shortcut.path = ~/.kde/Autostart/
+-shortcut.files += ../okindd.desktop
+-
diff --git a/x11-misc/okindd/metadata.xml b/x11-misc/okindd/metadata.xml
new file mode 100644
index 000000000000..25de6ae5dfed
--- /dev/null
+++ b/x11-misc/okindd/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>alex.alexander@gmail.com</email>
+<name>Alex Alexander (wired)</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/x11-misc/okindd/okindd-0.5.8.ebuild b/x11-misc/okindd/okindd-0.5.8.ebuild
new file mode 100644
index 000000000000..f6934af867fd
--- /dev/null
+++ b/x11-misc/okindd/okindd-0.5.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/okindd/okindd-0.5.8.ebuild,v 1.1 2009/07/18 11:31:12 wired Exp $
+
+EAPI="2"
+
+inherit qt4
+
+MY_P="${P}-20090410"
+
+DESCRIPTION="On Screen Display (OSD) for KDE 4.x - works on any qt desktop"
+HOMEPAGE="http://sites.kochkin.org/okindd/Home"
+SRC_URI="http://sites.kochkin.org/okindd/Home/source-code/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-dbus:4"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/okindd_home_and_naming.patch" )
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i "s:okind/:okindd/:g" "${S}"/conf/okinddrc.example ||
+ die "sed: fixing example paths failed"
+
+ qt4_src_prepare
+}
+
+src_configure() {
+ eqmake4 okindd.pro || die "configure failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ domenu "${S}"/okindd.desktop || die "domenu failed"
+
+ elog "You can find an example configuration file at"
+ elog " /usr/share/doc/okindd/examples/okinddrc.example"
+ elog "It should be placed in \${HOME}/.okindd/"
+}