summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-11-20 14:48:20 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-11-20 14:48:20 +0000
commit2206523c0afe5a577001e82cd6734a9a8b914d7d (patch)
tree94fe93db62d7dc6d5f335ac5a813c13d73fb0b24 /x11-misc/notification-daemon
parentAdditional dependencies with USE=doc, bug 247703. (diff)
downloadgentoo-2-2206523c0afe5a577001e82cd6734a9a8b914d7d.tar.gz
gentoo-2-2206523c0afe5a577001e82cd6734a9a8b914d7d.tar.bz2
gentoo-2-2206523c0afe5a577001e82cd6734a9a8b914d7d.zip
upstream fix for handling line wrapping for lines longer then 50 characters but shorter then 65
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'x11-misc/notification-daemon')
-rw-r--r--x11-misc/notification-daemon/ChangeLog12
-rw-r--r--x11-misc/notification-daemon/files/notification-daemon-0.3.7-line-wrapping.patch12
-rw-r--r--x11-misc/notification-daemon/notification-daemon-0.3.7-r1.ebuild35
3 files changed, 57 insertions, 2 deletions
diff --git a/x11-misc/notification-daemon/ChangeLog b/x11-misc/notification-daemon/ChangeLog
index 02ae2196708c..04dc4014b344 100644
--- a/x11-misc/notification-daemon/ChangeLog
+++ b/x11-misc/notification-daemon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-misc/notification-daemon
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/ChangeLog,v 1.47 2007/12/13 19:35:19 compnerd Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/ChangeLog,v 1.48 2008/11/20 14:48:07 cardoe Exp $
+
+*notification-daemon-0.3.7-r1 (20 Nov 2008)
+
+ 20 Nov 2008; Doug Goldstein <cardoe@gentoo.org>
+ +files/notification-daemon-0.3.7-line-wrapping.patch,
+ +notification-daemon-0.3.7-r1.ebuild:
+ upstream fix for handling line wrapping for lines longer then 50
+ characters but shorter then 65
14 Dec 2007; Saleem Abdulrasool <compnerd@gentoo.org>
-files/notification-daemon-0.3.6-binding-tool.patch,
diff --git a/x11-misc/notification-daemon/files/notification-daemon-0.3.7-line-wrapping.patch b/x11-misc/notification-daemon/files/notification-daemon-0.3.7-line-wrapping.patch
new file mode 100644
index 000000000000..a137549cc2f7
--- /dev/null
+++ b/x11-misc/notification-daemon/files/notification-daemon-0.3.7-line-wrapping.patch
@@ -0,0 +1,12 @@
+diff -up notification-daemon/src/themes/standard/theme.c.fix notification-daemon/src/themes/standard/theme.c
+--- a/notification-daemon/src/themes/standard/theme.c 2008-03-21 17:17:37.000000000 +0100
++++ b/notification-daemon/src/themes/standard/theme.c 2008-03-21 17:18:11.000000000 +0100
+@@ -812,7 +812,7 @@ set_notification_text(GtkWindow *nw, con
+ update_content_hbox_visibility(windata);
+
+ gtk_widget_set_size_request(
+- ((body != NULL && *body == '\0')
++ ((body != NULL && *body != '\0')
+ ? windata->body_label : windata->summary_label),
+ WIDTH - (IMAGE_SIZE + IMAGE_PADDING) - 10,
+ -1);
diff --git a/x11-misc/notification-daemon/notification-daemon-0.3.7-r1.ebuild b/x11-misc/notification-daemon/notification-daemon-0.3.7-r1.ebuild
new file mode 100644
index 000000000000..c3c354355ed9
--- /dev/null
+++ b/x11-misc/notification-daemon/notification-daemon-0.3.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/notification-daemon-0.3.7-r1.ebuild,v 1.1 2008/11/20 14:48:07 cardoe Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Notifications daemon"
+HOMEPAGE="http://www.galago-project.org/"
+SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.4.0
+ >=x11-libs/gtk+-2.4.0
+ >=gnome-base/gconf-2.4.0
+ >=x11-libs/libsexy-0.1.3
+ >=dev-libs/dbus-glib-0.71
+ x11-libs/libwnck"
+DEPEND="${RDEPEND}
+ =sys-devel/automake-1.9*
+ >=sys-devel/gettext-0.14
+ !xfce-extra/notification-daemon-xfce"
+
+DOCS="AUTHORS ChangeLog NEWS"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix line wrapping, upstream bug #162
+ epatch "${FILESDIR}"/${PN}-0.3.7-line-wrapping.patch
+}