summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-04-14 10:36:54 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-04-14 10:36:54 +0000
commit2379490b4d47827d0864ad22b9208b32e327147a (patch)
tree1b6fbc1cc6aab506a1ba8336ee0fa5ed1038bed0 /x11-misc/icecc
parentremove sparc support (diff)
downloadgentoo-2-2379490b4d47827d0864ad22b9208b32e327147a.tar.gz
gentoo-2-2379490b4d47827d0864ad22b9208b32e327147a.tar.bz2
gentoo-2-2379490b4d47827d0864ad22b9208b32e327147a.zip
new version
Diffstat (limited to 'x11-misc/icecc')
-rw-r--r--x11-misc/icecc/ChangeLog8
-rw-r--r--x11-misc/icecc/files/digest-icecc-2.01
-rw-r--r--x11-misc/icecc/files/icecc-2.0.patch11
-rw-r--r--x11-misc/icecc/icecc-2.0.ebuild37
4 files changed, 56 insertions, 1 deletions
diff --git a/x11-misc/icecc/ChangeLog b/x11-misc/icecc/ChangeLog
index f3c1d6ecc7c4..0cae2812d28e 100644
--- a/x11-misc/icecc/ChangeLog
+++ b/x11-misc/icecc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/icecc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/icecc/ChangeLog,v 1.5 2003/03/17 09:22:12 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icecc/ChangeLog,v 1.6 2003/04/14 10:36:54 phosphan Exp $
+
+*icecc-2.0 (14 Apr 2003)
+
+ 14 Apr 2003; Patrick Kursawe <phosphan@gentoo.org> icecc-2.0.ebuild,
+ files/digest-icecc-2.0, files-icecc-2.0.patch :
+ new version
*icecc-1.5 (17 Mar 2003)
diff --git a/x11-misc/icecc/files/digest-icecc-2.0 b/x11-misc/icecc/files/digest-icecc-2.0
new file mode 100644
index 000000000000..732f9d284081
--- /dev/null
+++ b/x11-misc/icecc/files/digest-icecc-2.0
@@ -0,0 +1 @@
+MD5 44f24b502df7b2a8d14bed96dcbe5bfc icecc-2.0.tar.bz2 337549
diff --git a/x11-misc/icecc/files/icecc-2.0.patch b/x11-misc/icecc/files/icecc-2.0.patch
new file mode 100644
index 000000000000..855431abf148
--- /dev/null
+++ b/x11-misc/icecc/files/icecc-2.0.patch
@@ -0,0 +1,11 @@
+--- icecc/icecc.cpp 2003-04-03 22:48:22.000000000 +0200
++++ icecc/icecc.cpp.new 2003-04-14 11:27:47.000000000 +0200
+@@ -49,7 +49,7 @@
+ themeBrowser(0),
+ icewmCfgDir(getenv("ICEWM_PRIVCFG")),
+ aTools(COUNTTOOLS),
+-themeDir("/usr/local/share/icecc/themes/")
++themeDir("/usr/share/icecc/themes/")
+ {
+ setCaption(tr("IceWM Control Center " VERSION));
+
diff --git a/x11-misc/icecc/icecc-2.0.ebuild b/x11-misc/icecc/icecc-2.0.ebuild
new file mode 100644
index 000000000000..617e0deb6bfc
--- /dev/null
+++ b/x11-misc/icecc/icecc-2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icecc/icecc-2.0.ebuild,v 1.1 2003/04/14 10:36:54 phosphan Exp $
+
+DESCRIPTION="IceWM Control Center"
+SRC_URI="http://tsa.dyndns.org/mirror/xvadim/${P}.tar.bz2"
+HOMEPAGE="http://tsa.dyndns.org/mirror/xvadim/"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=qt-3.0.0"
+
+SLOT="0"
+
+inherit eutils
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}.patch || die "Patch failed"
+}
+
+src_compile () {
+ econf || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+
+ rm -rf ${D}/usr/doc
+ dohtml ${PN}/docs/en/*.{html,sgml}
+ dodoc AUTHORS ChangeLog README TODO
+ dodir /usr/share/${PN}/themes
+ cp -a theme/* ${D}/usr/share/${PN}/themes/
+ chmod go-w ${D}/usr/share/${PN}/themes/
+}