summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-10-28 06:53:57 +0000
committerSamuli Suominen <drac@gentoo.org>2007-10-28 06:53:57 +0000
commita518363a4f2e76aa592715a13d340b6b01ece436 (patch)
tree4613269bcdec3a940e045cb804ca62d476d920ec /x11-misc/grun
parentSparc stable --- part of Bug #192840 (diff)
downloadgentoo-2-a518363a4f2e76aa592715a13d340b6b01ece436.tar.gz
gentoo-2-a518363a4f2e76aa592715a13d340b6b01ece436.tar.bz2
gentoo-2-a518363a4f2e76aa592715a13d340b6b01ece436.zip
Revision bump to raise debian patch level, also closing #197257.
(Portage version: 2.1.3.16)
Diffstat (limited to 'x11-misc/grun')
-rw-r--r--x11-misc/grun/ChangeLog7
-rw-r--r--x11-misc/grun/files/digest-grun-0.9.2-r16
-rw-r--r--x11-misc/grun/grun-0.9.2-r1.ebuild62
-rw-r--r--x11-misc/grun/grun-0.9.2.ebuild4
4 files changed, 76 insertions, 3 deletions
diff --git a/x11-misc/grun/ChangeLog b/x11-misc/grun/ChangeLog
index bd5ba057863f..053e3f9a22d2 100644
--- a/x11-misc/grun/ChangeLog
+++ b/x11-misc/grun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/grun
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/ChangeLog,v 1.20 2007/08/02 12:50:51 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/ChangeLog,v 1.21 2007/10/28 06:53:56 drac Exp $
+
+*grun-0.9.2-r1 (28 Oct 2007)
+
+ 28 Oct 2007; Samuli Suominen <drac@gentoo.org> +grun-0.9.2-r1.ebuild:
+ Revision bump to raise debian patch level, also closing #197257.
02 Aug 2007; Roy Marples <uberlord@gentoo.org> grun-0.9.2.ebuild:
Keyworded ~x86-fbsd, #156902 thanks to Marc Kowarsky.
diff --git a/x11-misc/grun/files/digest-grun-0.9.2-r1 b/x11-misc/grun/files/digest-grun-0.9.2-r1
new file mode 100644
index 000000000000..2a42d7b34886
--- /dev/null
+++ b/x11-misc/grun/files/digest-grun-0.9.2-r1
@@ -0,0 +1,6 @@
+MD5 a0f817fd0f6603844204c69af26fef5a grun_0.9.2-14.1.diff.gz 142379
+RMD160 8e26f2d20a65a616b18df28aa8da5dd0162fb3ea grun_0.9.2-14.1.diff.gz 142379
+SHA256 c9a527199fb5b2080e018683989d413bc53ef8f55a440ab333d5d063b0e6dbfc grun_0.9.2-14.1.diff.gz 142379
+MD5 f045fd0c34c81563d7177bfd2d9c9c16 grun_0.9.2.orig.tar.gz 113745
+RMD160 16b97485badd41da671012538b19388975ee9670 grun_0.9.2.orig.tar.gz 113745
+SHA256 5286a6b3ae2e0d05b36b99278947b3f9732a00a920f0321dab02e464f4a0d3c2 grun_0.9.2.orig.tar.gz 113745
diff --git a/x11-misc/grun/grun-0.9.2-r1.ebuild b/x11-misc/grun/grun-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..a7214153eda2
--- /dev/null
+++ b/x11-misc/grun/grun-0.9.2-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/grun-0.9.2-r1.ebuild,v 1.1 2007/10/28 06:53:56 drac Exp $
+
+PATCH_LEVEL=14.1
+
+inherit eutils
+
+DESCRIPTION="a GTK+ application launcher with nice features such as a history"
+HOMEPAGE="http://packages.qa.debian.org/g/grun.html"
+SRC_URI="mirror://debian/pool/main/g/grun/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/g/grun/${PN}_${PV}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${PN}_${PV}-${PATCH_LEVEL}.diff
+}
+
+src_compile() {
+ [[ -z ${TERM} ]] && TERM=xterm
+
+ econf $(use_enable nls) --disable-gtktest --enable-testfile \
+ --enable-associations --with-default-xterm=${TERM}
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ einstall || die "einstall failed."
+ dodoc AUTHORS BUGS ChangeLog LANGUAGES NEWS README TODO
+}
+
+pkg_postinst() {
+ elog "It is recommended to bind grun to a keychain. Fluxbox users can"
+ elog "do this by appending e.g. the following line to ~/.fluxbox/keys:"
+ elog
+ elog "Mod4 r :ExecCommand grun"
+ elog
+ elog "Then reconfigure Fluxbox (using the menu) and hit <WinKey>-<r>"
+ elog
+ elog "The default system-wide definition file for associating file"
+ elog "extensions with applications is /usr/share/grun/gassoc, the"
+ elog "default system-wide definition file for recognized console"
+ elog "applications is /usr/share/grun/consfile. They can be overridden"
+ elog "on a per user basis by ~/.gassoc and ~/.consfile respectively."
+ elog
+ elog "To change the default terminal application grun uses, adjust the"
+ elog "TERM environment variable accordingly and remerge grun, e.g."
+ elog
+ elog "TERM=Eterm emerge grun"
+}
diff --git a/x11-misc/grun/grun-0.9.2.ebuild b/x11-misc/grun/grun-0.9.2.ebuild
index fef79b4b5e90..842f4cc1b3c4 100644
--- a/x11-misc/grun/grun-0.9.2.ebuild
+++ b/x11-misc/grun/grun-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/grun-0.9.2.ebuild,v 1.31 2007/08/02 12:50:51 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/grun-0.9.2.ebuild,v 1.32 2007/10/28 06:53:56 drac Exp $
inherit eutils
@@ -8,7 +8,7 @@ PATCH_LEVEL="14"
RESTRICT="mirror"
DESCRIPTION="a GTK+ application launcher with nice features such as a history"
-HOMEPAGE="http://packages.debian.org/unstable/x11/grun.html"
+HOMEPAGE="http://packages.qa.debian.org/g/grun.html"
SRC_URI="mirror://debian/pool/main/g/grun/${PN}_${PV}.orig.tar.gz
mirror://debian/pool/main/g/grun/${PN}_${PV}-${PATCH_LEVEL}.diff.gz"