summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2007-01-13 09:56:05 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2007-01-13 09:56:05 +0000
commit0b85d79550190cc47963626c263d19979d008f60 (patch)
tree207d0d8704555ce0fbe7427a79ec93431128f6e2 /x11-misc/googleearth
parentStable on ppc64; bug #159278 (diff)
downloadgentoo-2-0b85d79550190cc47963626c263d19979d008f60.tar.gz
gentoo-2-0b85d79550190cc47963626c263d19979d008f60.tar.bz2
gentoo-2-0b85d79550190cc47963626c263d19979d008f60.zip
Restore genstef's changes
(Portage version: 2.1.2_rc4-r3)
Diffstat (limited to 'x11-misc/googleearth')
-rw-r--r--x11-misc/googleearth/files/digest-googleearth-43
-rw-r--r--x11-misc/googleearth/googleearth-4.ebuild28
2 files changed, 20 insertions, 11 deletions
diff --git a/x11-misc/googleearth/files/digest-googleearth-4 b/x11-misc/googleearth/files/digest-googleearth-4
index 338a355b3bc9..138f9505ada6 100644
--- a/x11-misc/googleearth/files/digest-googleearth-4
+++ b/x11-misc/googleearth/files/digest-googleearth-4
@@ -1,3 +1,6 @@
MD5 0a97dfa4b22d561799a0131822293fad GoogleEarthLinux.bin 21607720
RMD160 fed3a3cb81f963dcf1dde8e386640fd08a1ce9f8 GoogleEarthLinux.bin 21607720
SHA256 369046688de0a749ddce2aa444c6cd5c8b0a0fbd23f16626e241e3df6f8e0d76 GoogleEarthLinux.bin 21607720
+MD5 9e061c7621a4128934cd8fa0cb42c682 libGL.so.1 783320
+RMD160 d002afd0d501cc161dbf8dabd26b254841f6b2f3 libGL.so.1 783320
+SHA256 6d36f11a514e51cb09f3f77c10e4b61c7d96c849ab65cba2c1dbf67c62d8d706 libGL.so.1 783320
diff --git a/x11-misc/googleearth/googleearth-4.ebuild b/x11-misc/googleearth/googleearth-4.ebuild
index ece684e2a81e..d614c35ee64a 100644
--- a/x11-misc/googleearth/googleearth-4.ebuild
+++ b/x11-misc/googleearth/googleearth-4.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-4.ebuild,v 1.1 2007/01/12 19:29:38 masterdriverz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-4.ebuild,v 1.2 2007/01/13 09:56:05 masterdriverz Exp $
inherit eutils fdo-mime
DESCRIPTION="A 3D interface to the planet"
HOMEPAGE="http://earth.google.com/"
-SRC_URI="http://dl.google.com/earth/GE4/GoogleEarthLinux.bin"
+SRC_URI="http://dl.google.com/earth/GE4/GoogleEarthLinux.bin
+ video_cards_fglrx? ( http://dev.gentooexperimental.org/~anarchy/libGL.so.1 )"
LICENSE="googleearth MIT X11 SGI-B-1.1 openssl as-is ZLIB"
SLOT="0"
KEYWORDS="~x86 ~amd64"
RESTRICT="mirror strip"
-IUSE=""
+IUSE="video_cards_fglrx"
RDEPEND="x86? (
media-libs/fontconfig
@@ -27,19 +28,20 @@ RDEPEND="x86? (
x11-libs/libXrender )
<virtual/x11-7.0 ) )
amd64? (
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-baselibs
- || (
- >=app-emulation/emul-linux-x86-xlibs-7.0
- x11-drivers/nvidia-drivers
- x11-drivers/nvidia-legacy-drivers
- <x11-drivers/ati-drivers-8.28.8 ) )
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-baselibs
+ || (
+ >=app-emulation/emul-linux-x86-xlibs-7.0
+ x11-drivers/nvidia-drivers
+ x11-drivers/nvidia-legacy-drivers
+ video_cards_fglrx? ( x11-drivers/ati-drivers )
+ <x11-drivers/ati-drivers-8.28.8 ) )
media-fonts/ttf-bitstream-vera"
S="${WORKDIR}"
src_unpack() {
- unpack_makeself
+ unpack_makeself GoogleEarthLinux.bin
# make the postinst scripts behave
sed -i -e 's:$SETUP_INSTALLPATH/::' \
-e "s:^xdg-mime:linux/xdg/xdg-mime:" \
@@ -77,6 +79,10 @@ src_install() {
# make sure we install with correct permissions
fowners -R root:root /opt/${PN}
fperms -R a-x,a+X /opt/googleearth/{xml,res{,ources}}
+
+ if use video_cards_fglrx; then
+ mv ${DISTDIR}/libGL.so.1 ${D}/opt/${PN}
+ fi
}
pkg_postinst() {