summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-19 11:21:35 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-19 11:21:35 +0000
commit7d6103b55a8948703ed63dbdf58fb8941582d937 (patch)
treeb9efa113bb57b066961b0cd3d0ca434165b8d3f7 /x11-misc/fracplanet
parentversion bump (diff)
downloadgentoo-2-7d6103b55a8948703ed63dbdf58fb8941582d937.tar.gz
gentoo-2-7d6103b55a8948703ed63dbdf58fb8941582d937.tar.bz2
gentoo-2-7d6103b55a8948703ed63dbdf58fb8941582d937.zip
USE opengl in x11-libs/qt:3 is required for QGLWidget wrt #228221, thanks to Evil Compile Person.
(Portage version: 2.1.5.5)
Diffstat (limited to 'x11-misc/fracplanet')
-rw-r--r--x11-misc/fracplanet/ChangeLog6
-rw-r--r--x11-misc/fracplanet/fracplanet-0.3.3.ebuild10
2 files changed, 13 insertions, 3 deletions
diff --git a/x11-misc/fracplanet/ChangeLog b/x11-misc/fracplanet/ChangeLog
index 06483dad0614..0d3f57fc2406 100644
--- a/x11-misc/fracplanet/ChangeLog
+++ b/x11-misc/fracplanet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/fracplanet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fracplanet/ChangeLog,v 1.1 2008/05/24 12:48:20 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fracplanet/ChangeLog,v 1.2 2008/06/19 11:21:35 drac Exp $
+
+ 19 Jun 2008; Samuli Suominen <drac@gentoo.org> fracplanet-0.3.3.ebuild:
+ USE opengl in x11-libs/qt:3 is required for QGLWidget wrt #228221, thanks
+ to Evil Compile Person.
*fracplanet-0.3.3 (24 May 2008)
diff --git a/x11-misc/fracplanet/fracplanet-0.3.3.ebuild b/x11-misc/fracplanet/fracplanet-0.3.3.ebuild
index 36eef60c4533..5cf441cceae1 100644
--- a/x11-misc/fracplanet/fracplanet-0.3.3.ebuild
+++ b/x11-misc/fracplanet/fracplanet-0.3.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fracplanet/fracplanet-0.3.3.ebuild,v 1.1 2008/05/24 12:48:20 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fracplanet/fracplanet-0.3.3.ebuild,v 1.2 2008/06/19 11:21:35 drac Exp $
EAPI=1
-inherit qt3
+inherit eutils qt3
DESCRIPTION="Interactive tool for creating fractal planets with terrains, oceans, rivers, lakes and icecaps."
HOMEPAGE="http://www.bottlenose.demon.co.uk/share/fracplanet"
@@ -25,6 +25,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}
+pkg_setup() {
+ if ! built_with_use x11-libs/qt:3 opengl; then
+ die "Re-emerge x11-libs/qt with USE opengl."
+ fi
+}
+
src_compile() {
export PATH="${QTDIR}/bin:${PATH}"
./configure || die "./configure failed."